+ Responder ao Tópico



  1. #1

    Padrão problema de acesso interno de cameras com endereço de ddns...

    ola....

    sou usuario novo aqui do forum e tambem do mikrotik.....

    tenho um a rb-750gl em minha casa funcionado como routeador para minha rede interna da casa com um ap unifi da ubiquiti....esta tudo funcionado normal exceto uma coisa com o redirecionamento de portas......como tenho varias câmeras aqui em casa fiz o redirecionamento das portas para cada câmera de ip que possuo, ja tenho um servidor que fica atualizado o ddns do no-ip.org e estou conseguindo acessar as cameras quando estou fora da rede com o ip do ddns do no-ip......o problema é que quando estou na rede interna tenho acessar pelo endereço do no-ip nao estou conseguindo.....(se coloco o endereco de ip de cada camera e a porta ai consigo).....antes quando usava um router da linksys e fazia o direcionamento das portas tinha cesso das câmeras tanto na rede interna quanto na externa pelo endereço do no-ip.......


    alguém poderia me ajudar???

  2. #2
    Pronto Para Ajudar!!! Avatar de mjmmarcus2
    Ingresso
    Jun 2012
    Localização
    Paulista Pernambuco
    Posts
    428

    Padrão Re: problema de acesso interno de cameras com endereço de ddns...

    Este é o seu problema, veja porque parou

    https://under-linux.org/showthread.php?t=173882



  3. #3

    Padrão Re: problema de acesso interno de cameras com endereço de ddns...

    então ate pensei que poderia ser isto mais ai fiz também um teste com o servidor ddns do changeip.org e acontece a mesma coisa....inclusive usei um script aqui do forum para sempre atualizar o ip pelo proprio mikrotik......

  4. #4

    Padrão Re: problema de acesso interno de cameras com endereço de ddns...

    Mjmmarcus não é isso não tenho a mesma situação aqui e uso o changeip...até hj nao sei pq isso ocorre.



  5. #5
    Alex Rock Avatar de alexrock
    Ingresso
    Jan 2006
    Localização
    S. J. do Rio Preto-SP
    Posts
    828

    Padrão Re: problema de acesso interno de cameras com endereço de ddns...

    Da pra resolver usando regras dst-nat.

  6. #6

    Padrão Re: problema de acesso interno de cameras com endereço de ddns...

    eu uso dst-nat para as portas...tem alguma configuração especifica que devo colocar??pois já uso para acesso externo mas quando estou na própria rede não vai,...



  7. #7
    Avatar de Danusio
    Ingresso
    Jun 2011
    Localização
    Aparecida de Goiânia-GO
    Posts
    582

    Padrão Re: problema de acesso interno de cameras com endereço de ddns...

    Na própria rede só funciona usando o ip local e não o ip externo, isso sempre foi assim para qualquer tipo de acesso remoto.

  8. #8

    Padrão Re: problema de acesso interno de cameras com endereço de ddns...

    Como o colega Danusio disse, na rede local tem que se usar IP local, nas minhas instalações sempre uso DVR + DDNS e só acesso as cameras internas com IP local.



  9. #9

    Padrão Re: problema de acesso interno de cameras com endereço de ddns...

    São 2 pontos em questão:
    1 - Realmente, usando local, não há como acessar pelo endereço externo, pelo menos aqui como @Danusio citou acima, também foi assim.

    2 - O no-ip realmente parou, estamos recebendo algumas ligações de clientes com problemas de acesso remoto usando o no-ip.

  10. #10

    Padrão Re: problema de acesso interno de cameras com endereço de ddns...

    é que ate semana passada quando eu usava um router da linksys e4200 e fazia o redirecionamento das portas, eu conseguia tanto pela rede local quanto pelo externo usando o endereço do ddns......por isso achei que seria uma configuração do router....



  11. #11
    Alex Rock Avatar de alexrock
    Ingresso
    Jan 2006
    Localização
    S. J. do Rio Preto-SP
    Posts
    828

    Padrão Re: problema de acesso interno de cameras com endereço de ddns...

    É possível fazer sim galera, não tem essa que não dá!

    Duas formas: via DNS, adicionando uma entrada estática que resolve o DDNS para o Ip interno, mas tem que usar o DNS do Mikrotik / Linux / Windows / etc como DNS local. Esse é a forma mais correta e profissional (menos gambiarra).

    A outra é via dst-nat, exemplo (IP / firewall / nat):

    Para acessar de fora - dentro vc faz um dst-nat, protocolo TCP, porta 8080, In interface "sua interface da Internet", action dst-nat para o IP interno, porta interna
    Isso quer dizer: tudo que vier da interface internet, destino porta 8080, troque o destino para Ip interno, porta 8080. Correto?

    Dessa forma, para acessar de dentro - dentro vc faz um dst-nat, src-address 192.168.0.0/24 protocolo TCP, porta 8080, action dst-nat para o IP interno, porta interna.
    Isso quer dizer: tudo que vier do range local, porta 8080 troque o destino para o Ip interno, porta 8080.

    O único senão é que tudo que for acessado nesse porta será redirecionado para seu DVR, mesmo sendo para outro destino na mesmo porta.

    Não passo as regras mastigadas para que quem use passe a tentar entender o que está fazendo, sem essa de copiar e colar.
    É importante estudar o fluxo do iptables, que é o fw do RouterOS: http://wiki.mikrotik.com/wiki/Manual:Packet_Flow

    Dá pra fazer até chover com o fw do Routeros!

    Abraços.

  12. #12

    Padrão Re: problema de acesso interno de cameras com endereço de ddns...

    Sou muito novo nesta área, aqui quem manjava tudo era meu EX-sócio, eu ficava mais na ADM e instalações, mais faz uns 5 meses que ele saiu e estou estudando para saber como operar o MK, então muitas regras já estão criadas, o mais estranho é que o redirecionamento dst-nat para o ip do MK-Auth funciona dentro e fora da rede, mais usando a mesma regra para o ip do cliente (hotspot) não acessa, vou colocar este link que o amigo alexrock indicou na pasta materiais para estudo.
    Valeu ....



  13. #13
    Alex Rock Avatar de alexrock
    Ingresso
    Jan 2006
    Localização
    S. J. do Rio Preto-SP
    Posts
    828

    Padrão Re: problema de acesso interno de cameras com endereço de ddns...

    Citação Postado originalmente por Gustavo Santiago Fra Ver Post
    mais usando a mesma regra para o ip do cliente (hotspot) não acessa, vou colocar este link que o amigo alexrock indicou na pasta materiais para estudo.
    Valeu ....
    No caso de hotspot a coisa muda de figura, tem que ver em se o DVR está na mesma rede, se está bypassed...

  14. #14

    Padrão Re: problema de acesso interno de cameras com endereço de ddns...

    você poderia me explicar como fazer essa forma via dns estática??pois na parte de dns já adicionei o dns estático com o numero de ip do mikrotik mas não funcionou...



  15. #15

    Padrão Re: problema de acesso interno de cameras com endereço de ddns...

    Bom dia,

    Desculpe reviver esse tópico antigo mas é que estou com o mesmo problema do colega.

    Acesso as câmeras de fora da rede pelo DDNS normal.
    Acesso as câmeras de dentro da rede pelo IP interno normal.
    Não consigo acessar as câmeras de dentro da rede pelo DDNS.

    Uso Vivo Fibra com um discador PPPOE na porta de internet
    Usei dst-nat para abrir as portas das câmeras (8080, 9000, 37777)

    Alguém pode me ajudar a conseguir acessar as câmeras de dentro da rede usando o DDNS?

    Agradeço desde já,

    Obrigado.

  16. #16
    Avatar de Danusio
    Ingresso
    Jun 2011
    Localização
    Aparecida de Goiânia-GO
    Posts
    582

    Padrão Re: problema de acesso interno de cameras com endereço de ddns...

    De dentro da rede não tem como mesmo acessar as cameras via ddns, pois vc vai estar usando o ip externo dentro do bloco ip externo, dessa forma ele fica em loop.
    Vc tem que configurar no seu programa de acesso as cameras um link com ip local e outro com ip externo.



  17. #17

    Padrão Re: problema de acesso interno de cameras com endereço de ddns...

    Citação Postado originalmente por Danusio Ver Post
    De dentro da rede não tem como mesmo acessar as cameras via ddns, pois vc vai estar usando o ip externo dentro do bloco ip externo, dessa forma ele fica em loop.
    Vc tem que configurar no seu programa de acesso as cameras um link com ip local e outro com ip externo.
    Obrigado pela resposta amigo, entendi o que disse e vou ver no programa das câmeras se consigo fazer essa configuração, mas tenho uma dúvida, porque quando coloco um roteador normal, Tplink ou Dlink eu consigo fazer esses acessos normalmente, é uma limitação do RouterOS?

  18. #18

    Padrão Re: problema de acesso interno de cameras com endereço de ddns...

    Pessoal, pesquisando aqui um pouco uma regra de nat chamada Hairpin NAT

    https://wiki.mikrotik.com/wiki/Hairpin_NAT

    Fiz aqui alguns testes mas não tive sucesso, alguém poderia me ajudar a implementa-lá

    Segue meu NAT

    /ip firewall nat
    add action=masquerade chain=srcnat out-interface=pppoe-out1
    add action=dst-nat chain=dstnat dst-port=37777 protocol=tcp src-address-list=\
    "" to-addresses=192.168.50.166 to-ports=37777
    add action=dst-nat chain=dstnat dst-port=9000 protocol=tcp src-address-list=\
    "" to-addresses=192.168.50.166 to-ports=9000
    add action=dst-nat chain=dstnat dst-port=8080 protocol=tcp src-address-list=\
    "" to-addresses=192.168.50.166 to-ports=8080



  19. #19
    Avatar de Danusio
    Ingresso
    Jun 2011
    Localização
    Aparecida de Goiânia-GO
    Posts
    582

    Padrão Re: problema de acesso interno de cameras com endereço de ddns...

    É devido vc estar em outra nat, na mesma rede nat não funciona.

  20. #20

    Padrão Re: problema de acesso interno de cameras com endereço de ddns...

    Para quem interessar consegui resolver o problema usando Hairpin NAT

    Segui exatamente o que diz esse guia e funcionou, agora consigo acessar minhas cameras de dentro e de fora da rede usando DDNS.

    http://networkingforintegrators.com/...or-externally/

    Abraço.