Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Bom tarde a todos.

    Venho mais uma vez ao forum para tentar solucionar um problema.

    Apos efetuar a troca de uma RB750GL e por no lugar uma RB450G o balance parou de funcionar.

    Segue codigo.
    Código :
    /ip address
    add address=192.168.88.1/24 network=192.168.88.0 broadcast=192.168.88.255 interface=Local
    add address=10.1.1.2/24 network=10.1.1.0 broadcast=10.1.1.255 interface=WAN1
    add address=10.1.2.2/24 network=10.1.2.0 broadcast=10.1.2.255 interface=WAN2
    add address=10.1.3.2/24 network=10.1.3.0 broadcast=10.1.3.255 interface=WAN3
     
    /ip firewall mangle
    add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
    add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn
    add chain=input in-interface=WAN3 action=mark-connection new-connection-mark=WAN3_conn
     
    add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
    add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2
    add chain=output connection-mark=WAN3_conn action=mark-routing new-routing-mark=to_WAN3
     
    add chain=prerouting dst-address=192.168.1.0/24 action=accept in-interface=Local
    add chain=prerouting dst-address=192.168.2.0/24 action=accept in-interface=Local
    add chain=prerouting dst-address=192.168.3.0/24 action=accept in-interface=Local
     
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:3/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:3/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:3/2 action=mark-connection new-connection-mark=WAN3_conn passthrough=yes
    add chain=prerouting connection-mark=WAN1_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN1
    add chain=prerouting connection-mark=WAN2_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN2
    add chain=prerouting connection-mark=WAN3_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN3
     
     
    /ip route
    add dst-address=0.0.0.0/0 gateway=10.1.1.1 routing-mark=to_WAN1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.1.2.1 routing-mark=to_WAN2 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.1.3.1 routing-mark=to_WAN3 check-gateway=ping
     
    add dst-address=0.0.0.0/0 gateway=10.1.1.1 distance=1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.1.2.1 distance=2 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=10.1.3.1 distance=3 check-gateway=ping
     
    /ip firewall nat
    add chain=srcnat out-interface=WAN1 action=masquerade
    add chain=srcnat out-interface=WAN2 action=masquerade
    add chain=srcnat out-interface=WAN3 action=masquerade
     
    #Servidor DNS
    8.8.8.8,8.8.4.4

    Tudo sai apenas pela wan1 ele não divide mais entre os link.
    Porem se eu for em IP - Firewall - Connections, ele requisita para wan2 e wan3.
    Há, testei os link separadamente ambos estão funcionamento normalmente.
    Versão da 750GL era 5.24 e da 450G e 5.26, será que e esse o motivo? ( 750GL queimou )

    Ficaria grato se pudesem me ajudar novamente

    E desde já um muito obrigado.

  2. Amigo, coloca distance=1 nessas rotas e teste.

    /ip route add dst-address=0.0.0.0/0 gateway=10.1.1.1 distance=1 routing-mark=to_WAN1 check-gateway=ping add dst-address=0.0.0.0/0 gateway=10.1.2.1 distance=1 routing-mark=to_WAN2 check-gateway=ping add dst-address=0.0.0.0/0 gateway=10.1.3.1 distance=1 routing-mark=to_WAN3 check-gateway=ping

    vlw



  3. Como voce restaurou o backup?
    Exportou e importou ou fez backup e importou?

  4. Carlosaps, não adiantou trocar as distances.

    RobsonCostta, Eu refiz ela na mão comando por comando, não importei backup.

    Porem o problema parece estar na outra RB em modo cliente, ela não esta pegando o IP correto.

    O IP correto seria 172.17.0.4 ela esta pegando 0.30 no dhcp-client.

    Teria alguma forma de setar o IP do dhcp-client manualmente (SXT 5nd r2 modo cliente), eu troquei essa sxt junto porem agora que notei que ela não estava pegando o IP que deveria



  5. O IP de saída não seria 192.168.88.x, segundo sua configuração?






Tópicos Similares

  1. troquei o ip da placa e a adsl parou de funcionar.Porque??
    Por miguiju no fórum Servidores de Rede
    Respostas: 4
    Último Post: 01-05-2005, 23:02
  2. Orinoco AP1000 Parou de funcionar
    Por f22bsd no fórum Redes
    Respostas: 2
    Último Post: 11-02-2005, 07:52
  3. COMANDO RPM PAROU DE FUNCIONAR
    Por davi no fórum Servidores de Rede
    Respostas: 1
    Último Post: 17-09-2004, 15:47
  4. Parou de funcionar
    Por Perdigao no fórum Servidores de Rede
    Respostas: 2
    Último Post: 04-05-2004, 07:00
  5. touchpad parou de funcionar depois de atualizacao de kernel
    Por luisoft no fórum Sistemas Operacionais
    Respostas: 0
    Último Post: 26-04-2004, 08:03

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L