+ Responder ao Tópico



  1. Ola, estou querendo colocar um hotspot com senha aleatória, onde o cliente compra o cartão com x horas.
    Mas não to conseguindo fazer com que ele funcione, fiz o hotpost, fiz o pool, dhcp e quando chega na hora de logar nao loga.
    obs: to usando a pagina de hotspot padrao do Mikrotik.
    Segue abaixo o script.

    :global content [/file get [/file find name=user.txt] contents] ;:global contentLen [ :len $content ] ;
    :global lineEnd 0;
    :global line "";
    :global lastEnd 0;
    :do {
    :set lineEnd [:find $content "\r\n" $lastEnd ] ;
    :set line [ick $content $lastEnd $lineEnd] ;
    :set lastEnd ( $lineEnd + 0) ;
    :local tmpArray [:toarray $line] ;
    :if ( [ick $tmpArray 0] != "" ) do={
    ut $tmpArray;
    /ip hotspot user add profile=1HS name=[ick $tmpArray]
    /ip hotspot user remove [find name="\r"]


    }
    add o profile


    /ip hotspot user profile
    add idle-timeout=none keepalive-timeout=2m mac-cookie-timeout=3d name=1HS rate-limit=1M/1M session-timeout=1h transparent-proxy=yes

    e gero as senhas que serão usada no user.txt
    http://www.random.org/passwords/

    att, fico no aguardo de ideias para solução.

    onde tem essa é (: p) sem o espaço

  2. Cara, vou salvar sua vida, depois me paga uma cerveja, ehehehhe.
    Vai nesse site http://www.air.com.mt/tools/19-codes , ela vai gerar o script pronto, é só importar.



  3. Amigo usa o user manager no mikrotik , e mais simples

    http://andreysmith.wordpress.com/201...-user-manager/

    e ai gerando login e senha ..
    fazendo cartão VAUCHER

    Clique na imagem para uma versão maior

Nome:	         Hotspot+Voucher.png
Visualizações:	386
Tamanho: 	53,9 KB
ID:      	53517

    Agora a caixa de cerveja e pra mim

  4. Citação Postado originalmente por Galactica Ver Post
    Amigo usa o user manager no mikrotik , e mais simples

    http://andreysmith.wordpress.com/201...-user-manager/

    e ai gerando login e senha ..
    fazendo cartão VAUCHER

    Clique na imagem para uma versão maior

Nome:	         Hotspot+Voucher.png
Visualizações:	386
Tamanho: 	53,9 KB
ID:      	53517

    Agora a caixa de cerveja e pra mim
    Bom, isso roda numa routerboard 750 com 32MB de memória?
    O que ele vai gastar em uma RB melhor não vai sobrar nada pra comprar a cerveja...
    Tô só zuando amigo....
    Ondei montei esse sistema, o atendente simplesmente entrega o voucher ao cliente, pois nem não saberia utilizar o Userman.



  5. Certo, vo fazer os teste como user-manager.
    Mas minha ideia era so coloca a senha ou o usuario.
    Mas na pagina de hotspot não to conseguindo fazer essa validação.

    Aqui eu to com um Rb 2011iAS-RM so de teste.
    Se der certo vo coloca para rodar em uma cloud






Tópicos Similares

  1. Script para Desabilitar Hotspot
    Por renanphp no fórum Redes
    Respostas: 0
    Último Post: 11-07-2011, 13:09
  2. Respostas: 3
    Último Post: 03-06-2011, 19:06
  3. Criptografar senha no script para samba
    Por gilmarmoretto no fórum Servidores de Rede
    Respostas: 0
    Último Post: 24-01-2009, 12:27
  4. Exemplos de Scripts para HotSpot
    Por tarcisiomk10 no fórum Redes
    Respostas: 4
    Último Post: 19-05-2008, 10:57
  5. Respostas: 1
    Último Post: 02-07-2004, 07:33

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L