+ Responder ao Tópico



  1. Estou utilizando a configuração abaixo para um load balance, o problema é que tudo está saindo pela WAN1 deixando as outras interfaces paradas, se eu desabilito a WAN1 automaticamente passa para a WAN2, porem continua sem fazer o balanceamento.

    .....

    IP DOS MODENS
    ************************************************
    modem 01 = 192.168.11.1
    modem 02 = 192.168.21.1
    modem 03 = 192.168.31.1
    modem 04 = 192.168.41.1
    modem 05 = 192.168.51.1
    modem 06 = 192.168.61.1
    modem 07 = 192.168.71.1


    Ips MIKROTIK:
    ************************************************


    /ip address
    add address=10.0.0.1/24 disabled=no interface=Local network=10.0.0.0
    add address=192.168.11.254/24 disabled=no interface=WAN1 network=192.168.11.0
    add address=192.168.21.254/24 disabled=no interface=WAN2 network=192.168.21.0
    add address=192.168.31.254/24 disabled=no interface=WAN3 network=192.168.31.0
    add address=192.168.41.254/24 disabled=no interface=WAN4 network=192.168.41.0
    add address=192.168.51.254/24 disabled=no interface=WAN5 network=192.168.51.0
    add address=192.168.61.254/24 disabled=no interface=WAN6 network=192.168.61.0
    add address=192.168.71.254/24 disabled=no interface=WAN7 network=192.168.71.0


    Rotas
    ************************************************


    /ip route
    add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.11.1 scope=30 target-scope=10
    add check-gateway=ping disabled=no distance=2 dst-address=0.0.0.0/0 gateway=192.168.21.1 scope=30 target-scope=10
    add check-gateway=ping disabled=no distance=3 dst-address=0.0.0.0/0 gateway=192.168.31.1 scope=30 target-scope=10
    add check-gateway=ping disabled=no distance=4 dst-address=0.0.0.0/0 gateway=192.168.41.1 scope=30 target-scope=10
    add check-gateway=ping disabled=no distance=5 dst-address=0.0.0.0/0 gateway=192.168.51.1 scope=30 target-scope=10
    add check-gateway=ping disabled=no distance=6 dst-address=0.0.0.0/0 gateway=192.168.61.1 scope=30 target-scope=10
    add check-gateway=ping disabled=no distance=7 dst-address=0.0.0.0/0 gateway=192.168.71.1 scope=30 target-scope=10


    add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.11.1 routing-mark=to_WAN1 scope=30 target-scope=10
    add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.21.1 routing-mark=to_WAN2 scope=30 target-scope=10
    add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.31.1 routing-mark=to_WAN3 scope=30 target-scope=10
    add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.41.1 routing-mark=to_WAN4 scope=30 target-scope=10
    add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.51.1 routing-mark=to_WAN5 scope=30 target-scope=10
    add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.61.1 routing-mark=to_WAN6 scope=30 target-scope=10
    add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.71.1 routing-mark=to_WAN7 scope=30 target-scope=10




    Mascaramento
    ************************************************


    /ip firewall nat
    add action=masquerade chain=srcnat comment="MASK WAN1" disabled=no out-interface=WAN1
    add action=masquerade chain=srcnat comment="MASK WAN2" disabled=no out-interface=WAN2
    add action=masquerade chain=srcnat comment="MASK WAN3" disabled=no out-interface=WAN3
    add action=masquerade chain=srcnat comment="MASK WAN4" disabled=no out-interface=WAN4
    add action=masquerade chain=srcnat comment="MASK WAN5" disabled=no out-interface=WAN5
    add action=masquerade chain=srcnat comment="MASK WAN6" disabled=no out-interface=WAN6
    add action=masquerade chain=srcnat comment="MASK WAN7" disabled=no out-interface=WAN7




    Regras Balanceamento
    ************************************************


    /ip firewall mangle
    add action=accept chain=output comment="Sem Balance" disabled=no dst-address-list=SemBalance


    add action=mark-connection chain=input disabled=no in-interface=WAN1 new-connection-mark=WAN1_conn passthrough=yes
    add action=mark-connection chain=input disabled=no in-interface=WAN2 new-connection-mark=WAN2_conn passthrough=yes
    add action=mark-connection chain=input disabled=no in-interface=WAN3 new-connection-mark=WAN3_conn passthrough=yes
    add action=mark-connection chain=input disabled=no in-interface=WAN4 new-connection-mark=WAN4_conn passthrough=yes
    add action=mark-connection chain=input disabled=no in-interface=WAN5 new-connection-mark=WAN5_conn passthrough=yes
    add action=mark-connection chain=input disabled=no in-interface=WAN6 new-connection-mark=WAN6_conn passthrough=yes
    add action=mark-connection chain=input disabled=no in-interface=WAN7 new-connection-mark=WAN7_conn passthrough=yes


    add action=mark-routing chain=output connection-mark=WAN1_conn disabled=no new-routing-mark=to_WAN1 passthrough=yes
    add action=mark-routing chain=output connection-mark=WAN2_conn disabled=no new-routing-mark=to_WAN2 passthrough=yes
    add action=mark-routing chain=output connection-mark=WAN3_conn disabled=no new-routing-mark=to_WAN3 passthrough=yes
    add action=mark-routing chain=output connection-mark=WAN4_conn disabled=no new-routing-mark=to_WAN4 passthrough=yes
    add action=mark-routing chain=output connection-mark=WAN5_conn disabled=no new-routing-mark=to_WAN5 passthrough=yes
    add action=mark-routing chain=output connection-mark=WAN6_conn disabled=no new-routing-mark=to_WAN6 passthrough=yes
    add action=mark-routing chain=output connection-mark=WAN7_conn disabled=no new-routing-mark=to_WAN7 passthrough=yes


    add action=accept chain=prerouting disabled=no dst-address=192.168.11.0/24 in-interface=Local
    add action=accept chain=prerouting disabled=no dst-address=192.168.21.0/24 in-interface=Local
    add action=accept chain=prerouting disabled=no dst-address=192.168.31.0/24 in-interface=Local
    add action=accept chain=prerouting disabled=no dst-address=192.168.41.0/24 in-interface=Local
    add action=accept chain=prerouting disabled=no dst-address=192.168.51.0/24 in-interface=Local
    add action=accept chain=prerouting disabled=no dst-address=192.168.61.0/24 in-interface=Local
    add action=accept chain=prerouting disabled=no dst-address=192.168.71.0/24 in-interface=Local


    add action=mark-connection chain=prerouting comment=WAN1 disabled=no dst-address-type=!local in-interface=Local new-connection-mark=WAN1_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:7/0
    add action=mark-connection chain=prerouting comment=WAN2 disabled=no dst-address-type=!local in-interface=Local new-connection-mark=WAN2_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:7/1
    add action=mark-connection chain=prerouting comment=WAN3 disabled=no dst-address-type=!local in-interface=Local new-connection-mark=WAN3_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:7/2
    add action=mark-connection chain=prerouting comment=WAN4 disabled=no dst-address-type=!local in-interface=Local new-connection-mark=WAN4_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:7/3
    add action=mark-connection chain=prerouting comment=WAN5 disabled=no dst-address-type=!local in-interface=Local new-connection-mark=WAN5_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:7/4
    add action=mark-connection chain=prerouting comment=WAN6 disabled=no dst-address-type=!local in-interface=Local new-connection-mark=WAN6_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:7/5
    add action=mark-connection chain=prerouting comment=WAN7 disabled=no dst-address-type=!local in-interface=Local new-connection-mark=WAN7_conn passthrough=yes per-connection-classifier=both-addresses-and-ports:7/6

  2. Estes links sao de mesma velocidade?



  3. Sim! todos de 2 mega!






Tópicos Similares

  1. O que há de errado nesta validação de login
    Por triplox no fórum Linguagens de Programação
    Respostas: 1
    Último Post: 05-06-2009, 23:43
  2. O que há de errado nesse script?????
    Por analistaslack no fórum Linguagens de Programação
    Respostas: 15
    Último Post: 28-12-2006, 18:15
  3. O que há de errado com esta ACL
    Por cvr no fórum Servidores de Rede
    Respostas: 0
    Último Post: 06-10-2006, 08:47
  4. Squid - o que há de errado
    Por edisonjr no fórum Servidores de Rede
    Respostas: 9
    Último Post: 28-02-2005, 09:38
  5. Respostas: 3
    Último Post: 25-11-2002, 18:22

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L