Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Sarg não mostra ip dos clientes

    Clique na imagem para uma versão maior

Nome:	         rede.jpg
Visualizações:	130
Tamanho: 	25,6 KB
ID:      	53960
    Tenho o seguinte cenário um servidor com o squid + sarg em paralelo com Mikrotik para fazer relatório de acesso dos funcionários, (é um servidor de uma prefeitura, e não precisamos fazer cache), só que no relatório do Sarg sai apenas o IP que esta na mikrotik. Na mikrotik uso um hotspot com autenticação em um Freeradius.
    Vou colocar aqui os conf do squid e do sarg pra ver se tem algum erro.
    sarg.conf.txt
    squid.conf.txt

    E as configurações que estou em NAT na MIKROTIK.

    Clique na imagem para uma versão maior

Nome:	         mikrotik.jpg
Visualizações:	138
Tamanho: 	161,8 KB
ID:      	53963Clique na imagem para uma versão maior

Nome:	         nat1.jpg
Visualizações:	84
Tamanho: 	57,0 KB
ID:      	53964Clique na imagem para uma versão maior

Nome:	         nat2.jpg
Visualizações:	81
Tamanho: 	41,0 KB
ID:      	53965

    Uma screen do SARG

    Clique na imagem para uma versão maior

Nome:	         sarg.jpg
Visualizações:	105
Tamanho: 	81,7 KB
ID:      	53966

    Alguém ja passou por isso e encontrou uma solução pois queria um relatório de acesso para cada usuário.

  2. #2

    Padrão Re: Sarg não mostra ip dos clientes

    Acredito que isso ocorra porque o Mikrotik está redirecionando o tráfego para o squid.
    Sendo uma requisição do Mikrotik e retornando para ele.

    Soluções: fazer esse squid transparente ou colocar no navegador dos usuários o ip do squid.



  3. #3

    Padrão Re: Sarg não mostra ip dos clientes

    Mas a configuração do meu squid ja esta.
    http_port 5128 transparent

  4. #4

    Padrão Re: Sarg não mostra ip dos clientes

    Citação Postado originalmente por jaelcio Ver Post
    Mas a configuração do meu squid ja esta.
    http_port 5128 transparent
    Desculpe, me expressei errado, seria mudar a topologia da sua rede para forçar a passagem do cliente pelo servidor squid onde ele não ficaria em paralelo.



  5. #5

    Padrão Re: Sarg não mostra ip dos clientes

    Então devo ligar o servidor squid diretamente no Mikrotik?

  6. #6

    Padrão Re: Sarg não mostra ip dos clientes

    na regra de NAT na sua RB...
    coloque em output interface... a interface de saida WAN

    e veja se vai resolver



  7. #7

    Padrão Re: Sarg não mostra ip dos clientes

    Mas em qual das NAT nas masquerade ou no redirecionamento do Squid?

  8. #8

    Padrão Re: Sarg não mostra ip dos clientes

    Na regra de redirecionamento da porta 80 para o squid vc coloca netmap em em vez de dst-nat.
    ai o ip de origem vai para o servidor squid.



  9. #9

    Padrão Re: Sarg não mostra ip dos clientes

    Fiz o teste alterando para netmap mas continua registrando apenas o ip do MIKROTIK.

  10. #10

    Padrão Re: Sarg não mostra ip dos clientes

    a regra de redirecionamento está acima da regra de mascaramento?



  11. #11

    Padrão Re: Sarg não mostra ip dos clientes

    Esta abaixo
    Miniaturas de Anexos Miniaturas de Anexos Clique na imagem para uma versão maior

Nome:	         1.jpg
Visualizações:	40
Tamanho: 	210,1 KB
ID:      	53975  

  12. #12

    Padrão Re: Sarg não mostra ip dos clientes

    coloca acima e vc verá que vai funcionar do jeito que vc quer.
    assim que vc mudar a regra vai demorar um pouco para funcionar 100% porque tem algumas sessoes ativas.
    se puder reinicie o mikrotik que vai derrubar todas as sessoes.



  13. #13

    Padrão Re: Sarg não mostra ip dos clientes

    Clique na imagem para uma versão maior

Nome:	         1.jpg
Visualizações:	43
Tamanho: 	210,1 KB
ID:      	53976

    Fiz como você falou ai esta uma print de como esta agora, reiniciei a RB e continua registrando apenas o IP do mikrotik.

  14. #14

    Padrão Re: Sarg não mostra ip dos clientes

    essa rede que vc ta redirecionando para o squid está utilizando o hotspot?
    pois será preciso marcar la na aba extra a tem as opçoes para o hotspot.
    vc deve escolher uma delas.
    Eu nao me lembro qual delas seria.
    Se alguem no forum puder completar essa informação talvez resolveria essa informação



  15. #15

    Padrão Re: Sarg não mostra ip dos clientes

    Sim é com Hotspot com autenticação em Freeradius. Qual dessas podera ser.

  16. #16

    Padrão Re: Sarg não mostra ip dos clientes

    eu nao me lembro. desculpe
    mas ja trabalhei numa empresa que faziamos o redirecionamento para o proxy e tinha de selecionar uma dessa opçoes.
    faz um tempo e nao sei corretamente qual delas é.
    se ninguem se manifestar aqui, o melhor será vc testar uma por vez



  17. #17

    Padrão Re: Sarg não mostra ip dos clientes

    Como disse acima...
    Na regra do NAT, configure o output interface, para a sua interface de saida (WAN)

  18. #18

    Padrão Re: Sarg não mostra ip dos clientes

    Tentei colocar no meu redirecionamento do Squid o output interface mas deu esse erro.

    Clique na imagem para uma versão maior

Nome:	         2.jpg
Visualizações:	63
Tamanho: 	239,1 KB
ID:      	53997



  19. #19

    Padrão Re: Sarg não mostra ip dos clientes

    Citação Postado originalmente por jaelcio Ver Post
    Tentei colocar no meu redirecionamento do Squid o output interface mas deu esse erro.

    Clique na imagem para uma versão maior

Nome:	         2.jpg
Visualizações:	63
Tamanho: 	239,1 KB
ID:      	53997
    amigo, eu disse a regra de NAT, não a regra de redirect.

  20. #20

    Padrão Re: Sarg não mostra ip dos clientes

    Foi ja alterei aqui e vou colocar um print.
    Clique na imagem para uma versão maior

Nome:	         3.jpg
Visualizações:	52
Tamanho: 	236,9 KB
ID:      	54028

    Vou reiniciar a RB e fazer uns testes de acesso pra gerar um relatório no sarg e ja lhe informo o resultado.