Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Configuração DNS - Duvidas

    Boa tarde pessoal,

    Estou com umas duvidas sobre DNS e gostaria de uma dicas pra entender o correto funcionamento

    Minha Rede:

    Link's -> Balance -> RB principal -> clientes;
    -> Cache ->

    O balance esta com os link's devidamente configurados, ips, dns, geteway, subrede tudo ok.
    1 -O correto é setar na RB principal (r1) como DNS o endereço do balance para la ele resolver correto?
    Mas fazendo conforme acima a RB não faz o cache de DNS que é importante visto que economiza tempo na resolução de nomes

    2 - Quando crio um DHCP server, na network ele coloca com o DNS o geteway dele, até ai tudo bem, mas se eu não acrescentar manualmente o segundo DNS (ip do balance) , os pcs nesse DHCP não navegam.

  2. #2
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão

    Boa noite,

    Certifique-se de ter ativado a opção abaixo, na RB que faz o DHCP server.

    Código :
    /ip dns set allow-remote-requests=yes

    Abraço

    Obs.: Caso este roteador seja acessível via internet (IP Público), você previsa criar uma regra de filtro bloqueado requisições de entrada pela interface que está conectada à internet, para que você não se torne um DNS proxy.



  3. #3

    Padrão Re: Configuração DNS - Duvidas

    Citação Postado originalmente por gamineiro Ver Post
    Boa noite,

    Certifique-se de ter ativado a opção abaixo, na RB que faz o DHCP server.

    Código :
    /ip dns set allow-remote-requests=yes

    quanto ao allow remote request, ta ativo sim, isso ja tinha visto;

    Abraço

    Obs.: Caso este roteador seja acessível via internet (IP Público), você previsa criar uma regra de filtro bloqueado requisições de entrada pela interface que está conectada à internet, para que você não se torne um DNS proxy.

    Me explica melhor, porém veja que, conforme citei, ele fica atraz do balance.

    Obrigado,

  4. #4
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão Re: Configuração DNS - Duvidas

    Se está atrás do balance, não precisa de filtro.

    Abraço



  5. #5

    Padrão Re: Configuração DNS - Duvidas

    Citação Postado originalmente por gamineiro Ver Post
    Se está atrás do balance, não precisa de filtro.

    Abraço
    Imaginei, memso com o redir de portas do balance pra ele não tem problema né?

  6. #6
    Moderador Avatar de gamineiro
    Ingresso
    Jan 2008
    Localização
    RS
    Posts
    423
    Posts de Blog
    2

    Padrão

    Citação Postado originalmente por gabrielest Ver Post
    Imaginei, memso com o redir de portas do balance pra ele não tem problema né?
    Se tiver redirecionamento da porta de DNS ou uma DMZ, tem problema sim!!! Ná duvida, crie esta regra:

    Código :
    /ip firewall filter
    add action=drop chain=input comment="DROP DNS" dst-port=53 protocol=udp in-interface=INTERFACE_WAN

    Abraço



  7. #7

    Padrão Re: Configuração DNS - Duvidas

    Citação Postado originalmente por gamineiro Ver Post
    Se tiver redirecionamento da porta de DNS ou uma DMZ, tem problema sim!!! Ná duvida, crie esta regra:

    Código :
    /ip firewall filter
    add action=drop chain=input comment="DROP DNS" dst-port=53 protocol=udp in-interface=INTERFACE_WAN

    Abraço
    Uhm...
    Obrigado,
    Vou dar uma checada

  8. #8

    Padrão Re: Configuração DNS - Duvidas

    Pessoal,
    Continuo com duvidas em relação ao DNS, não estou conseguindo usar o cache de DNS do próprio MK, vejam:
    Minha rede é roteada em OSPF, e o nat é feito no roteador de borda, de consequencia o correto seria que o DNS também ficasse nela.
    Até onde sei o que vc configura no DNS settings é onde o mk vai procurar o "nome" pra resolver (seja do google, open dns, giga, etc..etc..) e ativando o allow remote request ele repassa para as requisições internas da rede. Dai gostaria de saber como faço para fazer o cache de DNS.



  9. #9

    Padrão Re: Configuração DNS - Duvidas

    Ai pessoal,
    Da uma forcinha ai please.....estou querendo muito usar o cache de DNS do próprio MK para "agilizar" as coisas mas estou apanhando um pouco..

  10. #10

    Padrão Re: Configuração DNS - Duvidas

    O amigo vai por mim o cache do Mk não é isso tudo não... ele vai apenas armazena por poucos minutos o que já foi acessado.
    Se você quer um dns de verdade e tem uma rede grande usa um dns como Unbound Ou Bind.
    Se você usa alguma maquina com Linux fica muito fácil de instalar, ate virtualizar o dns você pode...
    Não deu pra entender direito como funciona sua rede mais se o Gateway é um mikrotik e os clientes conseguem chegar ate ele tem que funciona, basta marcar o Aloow Remote... Além disso ponha la no campo Servers 8.8.8.8/208.67.220.220 e seja feliz.
    Se usa PPoe vai no profile e seta la o ip do seu mikrotik como Dns, se usa Dhcp e so ir em Ip/Dhcp Server/Network ponha la em Dns Servers o Ip do Mk...
    Espero ter ajudado.



  11. #11

    Padrão

    pois é amigo, o meu ta assim não, "que inveja kkkkk", ....sera que tem algo a ver com o fato de ter incluido a rede em Static no DNS?? me disseram que era assim pra vc poder ter o reverso se alguém pingar de dentro da sua rede pra outro site.

  12. #12

    Padrão Re: Configuração DNS - Duvidas

    Amigo, monte um servidor de dns propriamente dito, vai funcionar bem melhor, como o amigo disse vc pode virtualizar. Se for so cache, use unbound e bem fácil de configurar.



  13. #13

    Padrão Re: Configuração DNS - Duvidas

    Vai depender muito da quantidade de requisições (clientes). Mas genericamente falando, um processador desses novos, equivalente a um i3, com 4gb de memória e 40gb de HD, já da pra rodar uma rede razoavelmente grande. Tenho vários cases com essas configurações em provedores com pouco mais de 1000 clientes. O pessoal agora está rodando muito Servidor de DNS nas Edge Router Lite, mas ela tem um hardware modesto, grandes redes não vai rodar bem, porém redes menores é bem mais em conta que manter um servidor ligado 24h x 7...

  14. #14

    Padrão Re: Configuração DNS - Duvidas

    Boa gente,
    Obrigado a todas a dicas que o pessoal tem se esforçado mas vejam.....minha questão por enquanto é muito mais modesta rererererere 1000 clientes...kkkk. um dia chego lá, tamos trabalhando pra isso....mas vejam então, vou mudar a direção da pergunta.....alguém aqui usa o servidor de DNS do proprio cache??? não sei o Thunder mas o speed tem esse recurso....., alguém usa???... que seja com speed, thunder, ou o que for....o que vcs acham melhor, resolver logo no MK ou deixar tudo por conta do cache??



  15. #15

    Padrão Re: Configuração DNS - Duvidas

    Arthur, ainda não tive oportunidade de levantar o DNS nas Edge, mas falando com o UesleyCorrea, ele me disse que não precisa, já tem o pacote do bind e do unbound compilado.

  16. #16

    Padrão Re: Configuração DNS - Duvidas

    Vai de unbound champz pare de bater cabeça, um core2duo e 2gb ddr3 e ja era.
    O cache do dns fica na RAM, não precisa muita ram, basta que ela seja veloz.
    Ver se no vai pegar um pc duvidoso pra um serviço tão nobre.
    Ja penso sua rede parar por isso ?
    então pode ir de i3 ou pentium dual core lga 1155.
    e a função static do mk serve pra você redireciona um domínio para um site local ou um ip que você queira.
    Ser você usa um cache em linux ou Mkauth você pode por o dns la.
    A maioria dos Caches fazem cache do dns. mais não acho legal...
    o Seu mikrotik ou Unbound ou Bind vai fazer "cache" de um outro dns, aew você vai la e poem o mikrotik como dns ou seu servidor de cache como dns primario, então o resultado é que você vai usar o cache do cache do dns ?...
    Se ta sem dinheiro outra solução é virtualiza o Dns em um pc que já tenha fazendo algo na rede.



  17. #17

    Padrão Re: Configuração DNS - Duvidas

    @Fael me surgiu uma duvida aqui, eu tenho um server HP virtualizado, ja coloquei nele um serviço de DNS próprio, a alguns dias meus clientes começaram a reclamar de lentidão na abertura de paginas, bati cabeça e não encontrava o problema, foi então que eu desabilitei a opção ALLOW REMOTE REQUESTS no BALANCE e no CONCENTRADOR, depois disso ficou uma bala o ping no máximo chega a 3ms, e eu nao entendi o porque, não sei muito de MK ainda estou dando os primeiros passo em microtik, mas sinceramente pergunto? porque será que quando eu desabilitei ficou melhor?

    Aguardo sua ajuda! obrigado.

  18. #18

    Padrão Re: Configuração DNS - Duvidas

    Então @Maclaud quando você desmarca essa opção você ta desabilitando o Cache dns do Mikrotik, de alguma forma isso tava gerando um atraso pra você.
    Se já tem um servidor Dns (dentro da rede), não tem logica por ele dentro do Mikrotik (Em servers), vai ser um cache em cima de outro cache, apenas gerando atraso na sua rede.
    Ideal mesmo e setar o Dns (Unbound ou outro) diretamente no gerenciador de sua rede, exemplo, aqui uso o 10.10.13.13 (Dns privado) como primary, como secundário uso o próprio mikrotik (192.168.0.1) em caso de falha de um o outro assume...
    Detalhe, o Mikrotik esta com Allow remote request marcado e com 5 Dns diferentes em "Servers", Google, GigaDns, Open dns...
    Como é sua rede ? PPPOE, Dhcp, Ipfixo ?
    Lembrando que o Dns não muda o Ping até um host e sim diminui a latência na abertura de paginas...
    Imagine você que o Ping para um dns fica em média 100Ms, se você tiver um dns privado em sua rede, cai pra 1Ms...
    Mais isso só é proveitoso em redes não muitos pequenas (Pelo ttl ser muito baixo hoje). Acima de 100 Clientes já é recomendável, sem contar que problemas chatos como facebook não abrir algumas fotos e sites não abrir algumas paginas, são resolvidos.
    Detalhe, o dns deve ta em seu concentrador...
    Espero ter esclarecido ;0



  19. #19

    Padrão Re: Configuração DNS - Duvidas

    Obrigado pela Resposta rapida amigo, o DNS tá em um SERVIDOR HP compramos para colocar neles serviços como esse e o RADIUSNET do Fábricio, dele vem para minha RB 1009 que é meu balance, e da 1009 vem para minha RB 1036, nos clientes tem ficado agora com o DNS local desse servidor e melhorou muito, não sei se deixando assim pode me dar problemas no futuro caso meu servidor pare, mas é uma maquina nova robusta XEON de 4 Núcleos com 8G de RAM, acredito que aguenta muita coisa, tenho poucos clientes ainda, chegando aos 530, media de 370 conectados por dia em horarios de picos.

  20. #20

    Padrão Re: Configuração DNS - Duvidas

    Show de bola, aqui temos um servidor de 24Gb que agrega + de 10 Maquinas virtuas, exceto cache, temos Vod, Dude, Dns, AirControl, RadiusNet, testadores de link e etc...
    tudo virtualizado e 100%
    Apenas o Cache que não virtualizamos.
    Ta na hora de voce ativar um cache, 500+ é perfeito e to vendo que você gosta de coisa boa no Cpd, 1009/1036...
    Recomendo o Thunder...