+ Responder ao Tópico



  1. #41

    Padrão Re: Configurar load balance

    tenho problemas com bradesco net empresa com balance src-address ,da erro de multiplos ips e fecha a conexao

  2. #42
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão Re: Configurar load balance

    me chame @jailtonnetlink pra ver seu ballance deve estar com erro



  3. #43

    Padrão Re: Configurar load balance

    Bom Pessoal intaum deixa eu colocar aqui o "NOVO" Load Ballance..como comentado ae pelo Acronimo a evolução do load também pode ser considerado como novo mediante a novos recusros que surgiram apartir do MUM 2010 (que também estive la )...
    Só gostaria que aqueles que fossem testar ( novatos ) não usassem apenas o copiar e colar que entendessem antes de colocar pra rodar .
    O exemplo a seguir é num cenário com 3 links ( podendo ser dedicado mais adsl oou adsl apenas):

    src-address=192.168.11.252 ( ip do concentrador depoois do Load )

    add action=mark-connection chain=prerouting comment=\
    "((((( LOAD BALLANCE PCC/HTTPS )))))" \
    connection-mark=no-mark in-interface=adsl_ether2 new-connection-mark=\
    ISP1_conn
    add action=mark-connection chain=prerouting connection-mark=no-mark \
    in-interface=Discador_2 new-connection-mark=ISP2_conn
    add action=mark-connection chain=prerouting connection-mark=no-mark \
    in-interface=Discador_3 new-connection-mark=ISP3_conn
    ---------------------------------------------------------------------------------------
    add action=mark-routing chain=output comment=\
    "((((( LOAD BALLANCE PCC/HTTPS )))))" \
    connection-mark=ISP1_conn new-routing-mark=ISP1_trafic passthrough=no
    add action=mark-routing chain=output connection-mark=ISP2_conn \
    new-routing-mark=ISP2_trafic passthrough=no
    add action=mark-routing chain=output connection-mark=ISP3_conn \
    new-routing-mark=ISP3_trafic passthrough=no

    ----------------------------------------------------------------------------------------
    add action=mark-routing chain=prerouting comment=\
    "((((( LOAD BALLANCE PCC/HTTPS )))))" \
    dst-address-type=!local in-interface=ether1-Link new-routing-mark=\
    ISP1_trafic passthrough=no per-connection-classifier=both-addresses:3/0
    add action=mark-routing chain=prerouting dst-address-type=!local \
    in-interface=ether1-Link new-routing-mark=ISP2_trafic passthrough=no \
    per-connection-classifier=both-addresses:3/1
    add action=mark-routing chain=prerouting dst-address-type=!local \
    in-interface=ether1-Link new-routing-mark=ISP3_trafic passthrough=no \
    per-connection-classifier=both-addresses:3/2
    -------------------------------------------------------------------------------------------
    /ip firewall nat
    add action=masquerade chain=srcnat out-interface=Discador_1
    add action=masquerade chain=srcnat out-interface=Discador_2
    add action=masquerade chain=srcnat out-interface=Discador_3
    ---------------------------------------------------------------------------
    /ip route
    add distance=1 gateway=Discador_1 routing-mark=ISP1_trafic
    add distance=1 gateway=Discador_2 routing-mark=ISP2_trafic
    add distance=1 gateway=Discador_3 routing-mark=ISP3_trafic
    ----------------------
    o segredo esta aqui :
    add distance=1 dst-address=172.16.0.0/24 gateway=192.168.11.252
    add distance=1 dst-address=192.168.1.0/24 gateway=192.168.11.252
    add distance=1 dst-address=192.168.200.0/24 gateway=192.168.11.252

    OBS: Os IPs 172.16.0.0/24 , 192.168.1.0/24 e 192.168.200.0/24 são usados na rede inclusive o thunder...dae so não usar o NAT no concentrador e dispensar a lista de endereços que sobrecarrega o link default .

    Isso ae espero ajudar

  4. #44
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão Re: Configurar load balance

    mas este balance tem muito mangle amigo



  5. #45

    Padrão Re: Configurar load balance

    Acronimo e Arthur
    Esse foi o melhor que cheguei ... e funciona redondinho

  6. #46

    Padrão Re: Configurar load balance




  7. #47

    Padrão Re: Configurar load balance

    também to precisando de ajuda pra fazer um balance quem puder ajuda agradeço Skype: [email protected]

  8. #48

    Padrão Re: Configurar load balance

    Paguei uma consultoria para um cara aqui do forum configurar esse modelo de balance com apenas tres linhas no mangle, ate agora so tive problemas, a rede esta amarrada, tenho problemas com series onlines, para resolver a amarração e series online tive que tirar o nat dos concentradores e usar src-address, o problema e que agora o cliente tem que reiniciar frequentemente a nano para a net voltar, estou esperando para ver se o cidadão que fez a configuração se manifesta para resolver meu problema ou devolver o dinheiro!



  9. #49

    Padrão Re: Configurar load balance

    Ceilandia, aproximadamente 150megas

  10. #50

    Padrão Re: Configurar load balance

    Citação Postado originalmente por wesleydialmeida Ver Post
    Paguei uma consultoria para um cara aqui do forum configurar esse modelo de balance com apenas tres linhas no mangle, ate agora so tive problemas, a rede esta amarrada, tenho problemas com series onlines, para resolver a amarração e series online tive que tirar o nat dos concentradores e usar src-address, o problema e que agora o cliente tem que reiniciar frequentemente a nano para a net voltar, estou esperando para ver se o cidadão que fez a configuração se manifesta para resolver meu problema ou devolver o dinheiro!
    Essa questão de NAT no concentrador você resolve fácil, só fazer uma rota de retorno no seu balance apontando p/ o ip do concentrador, veja na resposta do nosso amigo rps67, ele dá a dica de como fazer.

    Já usando scr-address, aqui não deu certo, ficou uma lentidão tremenda. Depois de tanto pesquisar, testar e também contar c/ ajuda do nosso amigo @Arthur Bernardes, consegui fazer c/ pouquíssimas regras, apenas uma regra p/ cada link, e está perfeito, já testei tudo, desde videos online, jogos e acesso externo, DVR e tudo mais, tá perfeito aqui.

    Abraço.



  11. #51
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão Re: Configurar load balance

    Citação Postado originalmente por Arthur Bernardes Ver Post
    Você deixar NAT somente no backbone é mais do que uma obrigação.

    Agora, "src-address" não resolve tudo, e firewall com somente 3 regras pra balanceamento é algo meio inusitado.

    Arthur este é o mesmo balance do qual lhe passei, e do qual sempre implantamos, inusitado?

  12. #52
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão Re: Configurar load balance

    Arthur me espere no face logo vou entrar



  13. #53

    Padrão Re: Configurar load balance

    Faz um tempo que tento acertar o balance sem nat na central...
    toda vez que tiro o nat fica saindo mais por um dos links.
    Ja desativei algumas regras no mangle do balance, ja acrescentei outras e nada.

    Alguma diga?

  14. #54
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão Re: Configurar load balance

    evite modinhas @Juniin use a mesma rb de balance
    Clique na imagem para uma versão maior

Nome:	         suelen.jpg
Visualizações:	71
Tamanho: 	327,7 KB
ID:      	58035 Clique na imagem para uma versão maior

Nome:	         ccr-marc.jpg
Visualizações:	87
Tamanho: 	172,9 KB
ID:      	58036



  15. #55
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão Re: Configurar load balance

    sim, mas se perguntar 10 profissionais em rede (que estudaram e entendem mesmo sobre rede) 9 irão falar sobre modinha, balance é algo tão simples que tem mais de 20 formas, todas são corretas, e todas são erradas se for olhar bem, existem um padrão comum simples e eficaz, usar modinhas é simplesmente mais um ponto de falha, use algo simples, hoje mesmo fizmeos em ecmp pois no cenario do cliente so daria desta forma

  16. #56

    Padrão Re: Configurar load balance

    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="Cliente pelo mesmo link" \
    connection-mark=ISP1_conn in-interface=Local new-routing-mark=ISP1
    add action=mark-routing chain=prerouting connection-mark=ISP1_conn \
    in-interface=Local new-routing-mark=ISP2
    add chain=prerouting comment=\
    "====================================================================" \
    dst-address=192.168.88.0/30 src-address=192.168.88.0/30
    add action=mark-connection chain=prerouting comment=\
    "===================================================================" \
    connection-mark=no-mark in-interface=pppoe-out1 new-connection-mark=\
    ISP1_conn
    add action=mark-connection chain=prerouting connection-mark=no-mark \
    in-interface=pppoe-out2 new-connection-mark=ISP2_conn
    add action=jump chain=prerouting comment=\
    "====================================================================" \
    connection-mark=no-mark in-interface=Local jump-target=Policy_Router
    add action=jump chain=prerouting dst-port=443 in-interface=Local jump-target=\
    Policy_Router protocol=tcp
    add action=mark-routing chain=prerouting comment=\
    "====================================================================" \
    connection-mark=ISP1_conn new-routing-mark=ISP1_Trafic src-address=\
    192.168.88.0/30
    add action=mark-routing chain=prerouting connection-mark=ISP2_conn \
    new-routing-mark=ISP2_Trafic src-address=192.168.88.0/30
    add action=mark-routing chain=output comment=\
    "====================================================================" \
    connection-mark=ISP1_conn new-routing-mark=ISP1_Trafic
    add action=mark-routing chain=output connection-mark=ISP2_conn \
    new-routing-mark=ISP2_Trafic
    add action=mark-connection chain=Policy_Router comment=\
    "====================================================================" \
    dst-address-type=!local new-connection-mark=ISP1_conn \
    per-connection-classifier=both-addresses:2/0
    add action=mark-connection chain=Policy_Router dst-address-type=!local \
    new-connection-mark=ISP2_conn per-connection-classifier=\
    both-addresses:2/1

    ja desativei algumas e ativei novamente e, nesse momento,
    as regras em negrito estao desativadas..

    valeu por responder



  17. #57
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão Re: Configurar load balance

    querido amigo @Arthur Bernardes me informe uma coisa simples pois vc esta pensando em pequena escala amigo

    se for pensar algo como vc ta citando primeiro não irá pensar em balance convenhamos, segundo, fazer um balance com ospf é sim modinha cara sei que vai defender esta "modinha" pois esta lucrando com isso

    mas vamos la,


    primeiro vc tem uma rb, concentrando seus clientes,

    cenario balance na mesma rb que concentra seus clientes, +ospf entre as rbs de torres pode se usar vlan (que recomendo) ou mpls/vpls) mas sem usar regrinhas de forum e sim entender realmente a camada osi, e isso é "foder" como o amigo disse? entçao esta precisndo estudar, pegar um cenario de grande escala,

    sou contra nat na rede sim, totalmente contra, então aprenda ler o cenario cada um é cada um,

    então colocar uma rb pra balance fazer ospf é o correto?

    desculpe amigo, mas ainda tem muito que aprender de rede, encerro por aki, não irei discutir estas "modinhas" de balance sem nat, balance sem mangle, balance sem link não


    vai tentar fazer o agregation no cisco, e vai entender de forma facil o que é realmente um balance

  18. #58
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão Re: Configurar load balance

    Obs citou que modinha é fazer nat? qunado começa a cursar rede de computadores, aprende que nat é o conceito padrão de rede para economia de ips, a decadas, então nao julgue modinha meu amigo, aprendeu ospf ano passado né?



  19. #59
    SUPORTE E CONSULTORIA Avatar de Acronimo
    Ingresso
    Oct 2008
    Localização
    Rio de Janeiro - RJ
    Posts
    2.109
    Posts de Blog
    1

    Padrão Re: Configurar load balance

    Tirar AS é obrigatoriedade de todo provedor serio, e que tem condições de tirar (o que incentivo a todos) nao cuspo agora ficar falando que o correto é uma rb com balance +ospf para outra rb, e nat somente em uma é a forma grotesca de falar (não sei porra alguma de camada OSI muito menos de firewall) simples aprendeu algo e quer colocar pra vender

    pcc meu amigo é simples divisão de peso, e agregação de frames, vc pode colocar no seu concentrador onde autentica clientes, e nele sim criar um ospf evitando o duplo nat, algo simples muito simples nada complexo,

    colocar complexidade em rede para vender o produto pra mim tem um nome onde todos falam "FALTA DE ETICA" profissionais a anos no ramo, mestres, instrutores falam a mesma coisa, procure conversar com o Adilson Florentino onde tive o prazer de trabalhar junto quando ele ministrava roteaemnto avançado e CCNA CCNP Linux, algo simples faz a diferença, algo complexo causa dor de cabeça

  20. #60

    Padrão Re: Configurar load balance

    Acronimo, nao uso ospf porque tanto o pc que autentica os clientes quanto a rb que faz o balance estao no mesmo lugar, lugar fisico e, por tanto, nao vi necessidade de ospf... fiz apenas uma regra para apontar o ip dos clientes pra rb do balance. Seria roteamento estatico!?
    desse jeito a navegaçao funciona mesmo sem o nat na central, mas meu problema é que fica usando mais um dos links do balance sempre que desativo o nat na central, entao fica nat nos dois e, lendo o post, vi que nao é legal.

    Desativei as regras de output tambem, nao percebi mudança no desempenho, entao deixei sem elas...

    alguma diga?