Página 1 de 6 12345 ... ÚltimoÚltimo
+ Responder ao Tópico



  1. Bom dia a todos da comunidade. Não sei se estou postando no fórum correto, caso esteja errado o tópico pode ser movido p/ o fórum correto.

    Bom, vamos lá. Cenário comum:
    Balance PCC Mikrotik-->Concentrador Mikrotik (Tudo RB Serie 1000).

    Após subir um OSPF entre o balance e o concentrador, o acesso externo (cameras, TS, DVR...) parou. Sempre fiz o direcionamento apontando p/ o ip do Concentrador, e a partir do Concentrador tem outro direcionamento que aponta p/ o ip do cliente (pppoe).

    Isso funcionava normalmente. Após o OSPF sei que o direcionamento deve ser apontado direto do balance p/ o ip do pppoe-cliente, fiz as alterações nas regras porem não funcionou.

    Segue abaixo um exemplo da regra antiga:
    add action=dst-nat chain=dstnat comment=\
    "direcionamento camera fulano" disabled=no dst-address=\ip publico dst-port=9012
    protocol=tcp to-addresses=ip concentrador \ to-ports=9012

    OSPF Balance:
    /routing ospf instance
    set [ find default=yes ] distribute-default=always-as-type-1 name=R1 router-id=\10.255.255.1
    /routing ospf network
    add area=backbone network=192.168.0.0/30
    add area=backbone network=10.255.255.1/32

    OSPF Concentrador:
    /routing ospf instance
    set [ find default=yes ] name=R2 router-id=10.255.255.2
    /routing ospf network
    add area=backbone network=192.168.0.0/30
    add area=backbone network=10.255.255.2/32
    add area=backbone network=172.16.0.0/21 = faixa dos clientes

    Quando tento o acesso externo, até chega pacotes na regra no balance mas não passa pra frente.

    Bom, se faltou alguma informação é só falarem que passo.
    Detalhe, a rede está funcionando normal, o problema é somente o acesso externo.

    Desde já agradeço a todos.

  2. Se o ip do Cliente esta chegando direto no load balance pelo OSPF,agora vc redireciona direto para o ip do cliente nao mais para o concentrador.



  3. Citação Postado originalmente por sostenes Ver Post
    Se o ip do Cliente esta chegando direto no load balance pelo OSPF,agora vc redireciona direto para o ip do cliente nao mais para o concentrador.
    @sostenes Sim, exatamente isso, veja o trecho que eu descrevi ao abrir o tópico:
    Após o OSPF sei que o direcionamento deve ser apontado direto do balance p/ o ip do pppoe-cliente, fiz as alterações nas regras porem não funcionou.

    então, a regra ficou assim:
    add action=dst-nat chain=dstnat comment=\
    "direcionamento camera fulano" disabled=no dst-address=\ip publico
    dst-port=9012 protocol=tcp to-addresses=172.16.x.x \
    to-ports=9012

    Detalhe: o ip 172.16.x.x é o ip do pppoe-cliente. Esse ip tá fixo no cadastro dele, sempre que autenticar pega o mesmo ip. E também está fora do Pool de endereço, então não corre o risco de outro cliente estar pegando o mesmo ip.

    Outra coisa, do balance consigo pingar normalmente no ip do pppoe-cliente.

  4. Citação Postado originalmente por benerofonte Ver Post
    Voce está fazendo outro nat no concentrador?

    Porque no caso o nat deveria ser feito ou apenas no pcc ou apenas no concentrador. O OSPF vai mudar as rotas, mas na o gateway principal da rede.


    O ideal realmente seria fazer os redirecionamentos apenas no PCC, porque é ele que vai tratar a saida da sua rede. E no mikrotik nao fazer o NAT, fazer apenas o OSPF entre ele e o PCC.
    @benerofonte Sim, também isso mesmo, eu não mencionei mas não tem NAT no Concentrador. Existe apenas NAT especifico, como o NAT da pgcorte do sistema MK-Auth.



  5. Citação Postado originalmente por benerofonte Ver Post
    Dá uma verificada no NAT do MK Auth, ele pode esta fazendo um NAT em cima de outro NAT. Ai o sistema de rotas fica doido e nao sabe quem tem o poder de fazer a traduçao do endereço.
    hummm entendi, pode ser mesmo, vou verificar agora.

    Desativei todos os NAT no Concentrador e não foi. Nem mesmo um simples direcionamento p/ acesso externo ao Concentrador não funciona, veja abaixo a regra que fiz, pode ser que tenha alguma coisa errada:

    add action=dst-nat chain=dstnat comment=\
    "DIRECIONA CONEXAO EXTERNA P/ O SERVER MK" dst-address=ip publico \
    dst-port=8292 protocol=tcp to-addresses=192.168.x.x to-ports=8291

    Abraço e obrigado pela força até agora.






Tópicos Similares

  1. Problemas com acesso externo no PROFTPD
    Por perucio no fórum Servidores de Rede
    Respostas: 2
    Último Post: 27-02-2013, 10:24
  2. problema com acesso a nat em clientes...
    Por fpmazzi no fórum Servidores de Rede
    Respostas: 2
    Último Post: 18-05-2005, 00:33
  3. problemas com acesso de root via ssh
    Por roggy no fórum Servidores de Rede
    Respostas: 16
    Último Post: 11-04-2005, 06:27
  4. Problemas com acesso a terminal service
    Por vfigueiredo no fórum Servidores de Rede
    Respostas: 5
    Último Post: 14-02-2005, 18:21
  5. Problemas com Acesso
    Por black_burn no fórum Servidores de Rede
    Respostas: 2
    Último Post: 04-08-2004, 21:44

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L