+ Responder ao Tópico



  1. #1

    Padrão VLAN para balance PCC

    Boa tarde, fiz configuração de uma rb1100 com vlans para conectar mais 4 links numa rb750gl, mas somente duas linhas conectavam e demorava bastante ainda... tem alguém que usa vlans para conectar os pppoe-client de adsl? Se sim, teria como me passar como foi montado?

  2. #2

    Padrão Re: VLAN para balance PCC

    Marcelo, passei pelo mesmo problema que você...
    O Problema é que o Mk designa o mesmo mac para todos os 4 pppoe client, na hora de disca ocorre lentidão e também as vezes conecta ou Não conecta...
    Consegui contorna na base da gambiarra, usando bridge + vlan...
    Hoje ja to mudando o esquema para um Sw Gerenciável e em segundo plano uma Crs que usa 1 Switch Chip para todas as portas e tem mais recursos para VLAN.



  3. #3

    Padrão Re: VLAN para balance PCC

    Logico que é Gambi, Nunca que a bridge vai ter mesma performance que usando o próprio Switch para fazer a vlan. Daqui a pouco você vai dizer que a bridge se sai melhor que Usa Master/Slave Port.
    Com bridge você perde performance, não que esse seja o maior problema, mais se existe uma maneira "melhor" de ser feita, ela "deve" ser aplicada.
    Tem a opção "Secure" no switch chip, ideal para quem possui uma rede de gerencia e quer segurança e isolação total dos dados também.
    Não fique só nas palavras arthur, teste, faça funciona e mostre aqui...
    Você mesmo me apresentou a ideia eu apliquei e não foi como o esperado, surpresas do Ros : ).
    A Lembrando que a Bridge resolveu o problema da discagem e criou outro...


  4. #4

    Padrão Re: VLAN para balance PCC

    Bom dia,

    o que fiz foi o seguinte:

    RB1100AHX2
    - na ether13 - criei 4 VLANS com id (101, 102, 103, 104) daqui vai um cabo para a RB750
    - criei 4 discadores pppoe-client e setei como interface cada uma das VLANS acima

    RB750
    - ether01 entra o cabo que vem da RB1100AHX2 - criei 4 VLANS nessa porta com o mesmo id da RB1100AHX2.
    - criei 4 bridges e em cada uma coloquei uma VLAN e a porta física onde cada modem estava conectado.

    mesmo assim algumas conectam e outras não, e mesmo quando alguma conecta, demora bastante.

    fiz algo errado?



  5. #5

    Padrão

    Citação Postado originalmente por marcelonx Ver Post
    Bom dia,

    o que fiz foi o seguinte:

    RB1100AHX2
    - na ether13 - criei 4 VLANS com id (101, 102, 103, 104) daqui vai um cabo para a RB750
    - criei 4 discadores pppoe-client e setei como interface cada uma das VLANS acima

    RB750
    - ether01 entra o cabo que vem da RB1100AHX2 - criei 4 VLANS nessa porta com o mesmo id da RB1100AHX2.
    - criei 4 bridges e em cada uma coloquei uma VLAN e a porta física onde cada modem estava conectado.

    mesmo assim algumas conectam e outras não, e mesmo quando alguma conecta, demora bastante.

    fiz algo errado?
    interior do parana?

  6. #6

    Padrão Re: VLAN para balance PCC

    Não.... interior de Mato Grosso.



  7. #7

    Padrão Re: VLAN para balance PCC

    Não sei se vem ao caso, mas nessas RB's de inumeras portas tem CI de switch pra um range de portas, na 1100 são se não me engano um AR8327 (Ou algo assim) pras portas 4 a 8, e outro pras portas 9 a 13 (Tá, ele chama de 1-5 e 6-10, mas não é o que está silkado na placa! A mim o que conta é o circuito e não o que o sistema operacional diz), elas são separadas fisicamente justo pra facilitar essa identificação.


    Enfim, resulta num desempenho pior quando você define um master-port em outro CI. dá um
    set ether13 master-port=ether1
    e depois adicionar a vlan na interface ether1 e vai dar retrabalho pra RB 2 vezes, a princípio devia diminuir só um pouco o desempenho mas na RB1200 diminui bastante (Talvez porque ela tem 5, mas é o mesmo CI da RB1100 (Não AH x2).


    Enfim, não sei como contornar o problema mas tem deficiências causadas pelas portas escolhidas, os 2 pares de 5 vão pra um switch, as 2 juntas vão pra outro, e a porta solitária (13 na lataria, mas dentro silkado na placa a 13 é a 6!) vai direto pro chipset.

    Te aconselharia então a definir o master-port no mesmo switch da porta com as VLAN's, esses CI's aceitam pelo menos 30 VLan's sem ocupar o processador (Enquanto na porta 13 quem trata isso é o processador, talvez por isso o desempenho ruim).

    Tenta usar a porta 13 como saída pros clientes já que ela vem direto do processador.

  8. #8

    Padrão Re: VLAN para balance PCC

    Amigo eu uso o mesmo cenário aqui ja a uns 08 meses.
    O lançe ai pode ser o MTU do discador, ou simplesmente a operadora, aqui a GVT faz muito isso.



  9. #9

    Padrão Re: VLAN para balance PCC

    Gostaria de testar as configurações citadas acima, tenho 05 linhas discadas em uma RB2011 a 5km, vendo o comentário de @RobsonCostta, achei interessante poder discar em meu servidor e não na torre. Ainda mais vendo a possibilidade de colocar um switch gerenciável na torre e discando em meu servidor central junto a CCR.
    @RobsonCostta, passa como vc fez ai para testa por aqui.

    Agradeço Antecipadamente.

    Solon Araújo.

  10. #10

    Padrão Re: VLAN para balance PCC

    Amigo vou fazer um vídeo e posto o link aqui!



  11. #11

    Padrão Re: VLAN para balance PCC

    pessoal estou com o mesmo problema, somente um ou dois pppoe que eu consigo conectar alguem sabe o problema?

  12. #12

    Padrão Re: VLAN para balance PCC

    Acompanhando...



  13. #13

    Padrão Re: VLAN para balance PCC

    tive que fazer com tunel eoip

  14. #14

    Padrão Re: VLAN para balance PCC

    Maionef poderia me explica como ??? estou com msm problema aq!



  15. #15

    Padrão

    Tive esse problema um tempo atrás, consegui resolver!

    Vamos lá isso acontece pq a vlan criada no mikrotik respeita a mac da interface, resultado a MAC que chega nos servidores da operadora são iguais, logicamente a operadora bloqueia mac duplicadas, então a solução é fazer com que cada linha chegue com vlan diferente lá.
    Acontece que não tem como vc editar a mac da vlan no mikrotik então solução, é uma pequena gambiarra.

    Porem omo sabemos a bridge pode ser inserida a mac que quiser.

    Primeiro vc fecha a vlan para cada modem. depois no mikrotik cria uma bridge para cada vlan e bota ela dentro, ou seja cada bridge só tem uma vlan, depois disso seta uma mac diferente em cada bridge, dessa forma a mac da vlan vai ser a que ta na bridge.

    /interface bridge
    add admin-mac=DE:AD:00:BE:EF:00 auto-mac=no fast-forward=no name=bridge1
    add admin-mac=DE:AD:00:BE:EF:01 auto-mac=no fast-forward=no name=bridge2
    add admin-mac=DE:AD:00:BE:EF:03 auto-mac=no fast-forward=no name=bridge3
    add admin-mac=DE:AD:00:BE:EF:04 auto-mac=no fast-forward=no name=bridge4


    Espero ter ajudado!