+ Responder ao Tópico



  1. #1

    Post Acessar AP por trás do mikrotik, de computador em outra rede.

    Tenho um modem wifi TP-Link conectado à internet, que serve a minha LAN Doméstica com DHCP ativo;
    Rede:192.168.1.0
    Máscara: 255.255.255.0
    Gateway: 192.168.1.1

    Meu PC é conectado a essa rede com a seguinte IP;
    IP PC: 192.168.1.101
    Máscara: 255.255.255.0
    Gateway: 192.168.1.1

    Como já tinha um roteador D-link DIR-300, resolvi comprar uma RB750 e uma antena externa de 15db para compartilhar a internet com os vizinhos. Rezetei o D-Link e coloquei ele no modo AP, e conectei ele ao mikrotik. Procurei por instruções no fórum e depois de alguma pesquisa consegui configurar o mikrotik, criei o Hotspot para fazer a autenticação e o controle de banda. Tudo funcionando direitinho. A LAN no mikrotik ficou assim:
    Rede: 192.168.100.0/24
    IP Mikrotik: 192.168.100.1
    Máscara: 255.255.255.0
    Gateway: 192.168.100.1
    DHCP: 192.168.100.2-192.168.100.254

    ether1-Link de internet: 192.168.1.103
    ether2-master-lan
    ether3-slave-master lan
    ether4-slave-master lan-Vizinhos (AP D-Link)
    ether5-slave-master lan

    Até aí tudo bem, quando estou conectado na rede do mikrotik (192.168.100.0/24), via cabo ou pelo AP (via wifi), autenticado no Hotspote e tudo mais, consigo navegar na internet e acessar o mikrotik tanto pela interface web como pelo winbox, e tenho acesso à página do D-Link, pois estou na mesma faixa de IP que está o AP.
    O problema é quando estou conectado na rede do TP-Link (192.168.1.0/24), pois consigo acessar o mikrotik, tanto pela interface web como pelo winbox, mas não consigo acessar o AP. Sei que tenho que fazer algumas configurações de redirecionamento, mas segui vários métodos que encontrei no fórum e não consegui fazer o acesso. Acho que estou fazendo alguma coisa errada.

    Queria a ajuda dos colegas mais experientes para resolver!

    Segue abaixo um desenho para ficar mais claro, acho eu! hehe

    Clique na imagem para uma versão maior

Nome:	         Esquema da rede.jpg
Visualizações:	277
Tamanho: 	87,4 KB
ID:      	57447
    Última edição por Francylucio; 21-02-2015 às 00:34.

  2. #2

    Padrão

    Código :
    /ip firewall nat add action=dst-nat chain=dstnat comment="REDIRECIONA P/ AP" disabled=no dst-address=192.168.1.102 \
        dst-port=8000 protocol=tcp to-addresses=192.168.100.2 to-ports=80

    coloque essa regra no MK, ai para acessar o dlink use o seguinte endereço, 192.168.1.102:8000



  3. #3

    Padrão Re: Acessar AP por trás do mikrotik, de computador em outra rede.

    Citação Postado originalmente por berghetti Ver Post
    Código :
    /ip firewall nat add action=dst-nat chain=dstnat comment="REDIRECIONA P/ AP" disabled=no dst-address=192.168.1.102 \
        dst-port=8000 protocol=tcp to-addresses=192.168.100.2 to-ports=80

    coloque essa regra no MK, ai para acessar o dlink use o seguinte endereço, 192.168.1.102:8000
    Boa noite berghetti, eu já havia tentado esse método através de regra no NAT, e não deu certo. Mas para tirar as dúvidas eu colei sua regra no mikrotik, mudando somente o IP de 192.168.1.102 para 192.168.1.106, pois tenho uma câmera no 102, e do mesmo jeito não consegui o acesso ao AP. Já até desabilitei meu antivírus para testar se era ele que tava bloqueando o acesso e nada!

  4. #4

    Padrão Re: Acessar AP por trás do mikrotik, de computador em outra rede.

    Coloquei o IP 192.168.1.102 porque foi o IP que você colocou como se o mikrotik estivesse usando, mas já que não é, tem que por o IP que o MK usa.



  5. #5

    Padrão Re: Acessar AP por trás do mikrotik, de computador em outra rede.

    Citação Postado originalmente por berghetti Ver Post
    Coloquei o IP 192.168.1.102 porque foi o IP que você colocou como se o mikrotik estivesse usando, mas já que não é, tem que por o IP que o MK usa.
    Desculpe, já corrigi o erro, falha minha. O IP que o MK recebe do TP-Link é 192.168.1.103. Então reinseri a regra , desta vez com o IP correto, 192.168.1.103, e mesmo assim não consigo acessar o AP. O interessante é que quando tento acessar o MK pela interface web do MK (192.168.1.103), consigo normalmente, mas quando tento acessar o AP (192.168.1.103:8000), já com as regras no NAT, não consigo.

  6. #6

    Padrão Re: Acessar AP por trás do mikrotik, de computador em outra rede.

    a regra ta contabilizando pacotes? e o IP do d-link é esse que ta na regra mesmo?



  7. #7

    Padrão

    Depois de alguns testes, a ajuda do berghetti e um pouco de paciência, descobri o que estava errado e compartilho com quem tiver interesse.

    Primeiro: A conexão física do AP com o mikrotik é feita pela porta WAN do AP. Então, antes de mudá-lo para o modo Access Point, tem que configurar a permissão de acesso remoto no AP, pois no modo Access Point não dá para alterar essa configuração.

    Segundo: Depois de inserir as regras de NAT, também tem que adicionar o AP no IP Bindings, lá no Hotspot.

    Resumindo, aí está os comandos que utilizei. Para configurar seu mikrotik basta editar os IP's.

    Inserindo regras no NAT
    Código :
    /ip firewall nat add action=dst-nat chain=dstnat comment="REDIRECIONA P/ AP" disabled=no dst-address=192.168.1.103 \ 
    dst-port=8000 protocol=tcp to-addresses=192.168.100.2 to-ports=80

    Inserindo bypassed no Hotspot
    Código :
    / ip hotspot ip-binding add mac-address=00:xx:xx:xx:xx:xx address=192.168.100.2 \
    to-address=192.168.100.2 server=hotspot type=bypassed comment="" \
    disabled=no
    Boa sorte!
    Fui...........

  8. #8

    Padrão Re: Acessar AP por trás do mikrotik, de computador em outra rede.

    Problema resolvido.....