+ Responder ao Tópico



  1. #1

    Padrão Direcionar Cliente Para apenas um link

    Pessoal, Boa Noite! Sou novo aqui no forum, estou passando por um problema vou citar abaixo começando pelo meu cenário.

    (Internet)---------------[LoadBalance]---------------[MK]----------------Clientes.


    Meu problema ta sendo o seguinte tenho um load com 2 link de 60mb da Net, estou precisando direcionar alguns clientes para puxar só de um link, pois alguns clientes estão com problema com paginas de banco quando os 2 link estão ativo. Quando fui fazer o teste desativei um link e as paginas abriram normal. Gostaria de saber se alguem sabe a regra pra direcionar o cliente para um link só. Os clientes autenticam na rede com PPPoE. Desde já agradeço a todos.

  2. #2

    Padrão Re: Direcionar Cliente Para apenas um link

    Mude o seu balance, não mascare nada no concentrador, mascare so no balance e seja feliz.
    Mais não esqueça de fazer o roteamento de retorno dos ips dos clientes do balance para o concentrador.
    Feito isso nunca mais terá problemas com bancos, jogos, etc...



  3. #3

    Padrão Re: Direcionar Cliente Para apenas um link

    pegando carona aqui.este assunto e muito interessante pois tenho a mesma bronca aqui. mas não entendi. você pode traduzir para min. eu uso o balance pcc.

  4. #4

    Padrão Re: Direcionar Cliente Para apenas um link

    http://mk-auth.com.br/forum/topics/d...om-balance-pcc


    Der uma olhada ai vc vai ter uma norção.



  5. #5

    Padrão Re: Direcionar Cliente Para apenas um link

    Citação Postado originalmente por isaquias Ver Post
    pegando carona aqui.este assunto e muito interessante pois tenho a mesma bronca aqui. mas não entendi. você pode traduzir para min. eu uso o balance pcc.
    Vc não mascarando os ips dos clientes no concentrador, os ips dos clientes chegaram no balance, se mascarar no concentrador somente o ip do concentrador chegará no concentrador! Sendo assim não tem como fazer muita coisa não!

  6. #6

    Padrão Re: Direcionar Cliente Para apenas um link

    Eu uso a técnica do amigo Andrio. Rota estática entre concentrador e balance. Assim os IPs chegam na RB de balance. Lá posso tratar algum eventual problema, como escolher por qual link o cliente irá sair.



  7. #7

    Padrão Re: Direcionar Cliente Para apenas um link

    Mesmo que você mascare no NAS e tenha um load-balance externo, ainda assim da pra fazer. É só criar uma rede diferente para os clientes PPPoE que você quer fixar em um link, e usar o mesmo load-balance com essa rede diferente saindo sempre pela mesma rota.

    Caso você faça o load-balance na mesma RB que autentica os clientes PPPoE (NAS), fica mais facil ainda, como ja foi comentado. Uma coisa interessante que tem no user-manager é o campo Address-list no limitation de cada profile. Se você usa um pool de ip pro PPPoE, o IP do cliente, ao conectar, é adicionar automaticamente a address-list informada lá no cadastro do profile dele, e você pode fazer marcação de rotas, no mangle, utilizando essa address-list como base. Mesmo que você use outro servidor Radius, você pode implementar esse parametro radius da mikrotik, é só dar uma pesquisada no wiki da mikrotik que tem as especificações dos parametros radius próprios da mikrotik e adicionar no seu servidor radius.

    num caso assim, direcionar o cliente para um link em específico é simples assim:
    digamos que o link 1 o gateway é: 10.1.1.1/24
    digamos que o link 2 o gateway é: 10.2.1.1/24

    então adiciona uma rota com com um nome, assim:

    adicionar uma tabela de roteamento de nome "route_link1" para o primeiro link
    Código :
    /ip route add dst-address=0.0.0.0/0 gateway=10.1.1.1 routing-mark=route_link1

    adicionar uma tabela de roteamento de nome "route_link2" para o segundo link
    Código :
    /ip route add dst-address=0.0.0.0/0 gateway=10.2.1.1 routing-mark=route_link2

    Agora basta no mangle você fazer a marcação para uma conexão sair por uma tabela de roteamento específica. Digamos que você tenha uma address-list com os IPs dos clientes que tem que sair pelo primeiro link um chamada "addr-toLink1", e outra para os clientes que tem que sair pelo segundo link chamada "addr-toLink2" então, adiciona:

    Para marcar a conexão do cliente para a tabela de roteamento específica do primeiro link:
    Código :
    /ip firewall mangle add chain=prerouting src-address-list=addr-toLink1 action=mark-routing new-mark-routing=route_link1

    Para marcar a conexão do cliente para a tabela de roteamento específica do segundo link:
    Código :
    /ip firewall mangle add chain=prerouting src-address-list=addr-toLink2 action=mark-routing new-routing-mark=route_link2

    Tem que enxugar essas configurações para o seu cenário, para as suas configurações específicas, mas um dos caminhos é esse.

    Se os IPs dos seus clientes PPPoE são fixos, você pode simplesmente adicionar uma routing rule para o IP dele marcando para uma tabela de roteamento em específico, nesse caso, as routing rule acontecem antes mesmo do mangle, deve funcionar. Além disso, você pode usar as routing rule a nível de interface se não me engano, então daria pra adicionar uma interface pppoe server binding para os clientes específicos que tu quer rotear para um link em específico e adicionar uma regra para essa interface.

  8. #8

    Padrão Re: Direcionar Cliente Para apenas um link

    Olhe aqui vc vai ter um noção rsrs http://wiki.mikrotik.com/wiki/Load_B...tiple_Gateways


    Porém se vc se tiver um concentrador muda um pouco tenta ai.



  9. #9

    Padrão Re: Direcionar Cliente Para apenas um link

    Sim tente adaptar as regras não tem muito o que fazer. =P