+ Responder ao Tópico



  1. :local username "Aqui seu usuario"
    :local password "Aqui sua senha"
    :global hostname "aqui seu host name criado no site"


    :global dyndnsForce
    :global previousIP
    :local resolvedIP [:resolve $hostname]


    #print some debug
    #:log info ("UpdateDynDNS: username = $username")
    #:log info ("UpdateDynDNS: password = $password")
    :log info ("UpdateDynDNS: hostname = $hostname")
    :log info ("UpdateDynDNS: previousIP = $previousIP")
    :log info ("UpdateDynDNS: resolvedIP = $resolvedIP")


    # get the current IP address from the internet (in case of double-nat)
    /tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
    :local result [/file get dyndns.checkip.html contents]


    # parse the current IP result
    :local resultLen [:len $result]
    :local startLoc [:find $result ": " -1]
    :set startLoc ($startLoc + 2)
    :local endLoc [:find $result "" -1]
    :local currentIP [:pick $result $startLoc $endLoc]
    :log info "UpdateDynDNS: currentIP = $currentIP"


    # Remove the # on next line to force an update every single time - useful for debugging,
    # but you could end up getting blacklisted by DynDNS!
    # Edit: Not really needed anymore... the result is not equal... Update will happen.


    #:set dyndnsForce true


    # Determine if dyndns update is needed
    # more dyndns updater request details http://www.dyndns.com/developers/specs/syntax.html
    #This is where we check the DNS record against actual result. Thanks to jimstolz76
    :if (($currentIP != $resolvedIP) || ($dyndnsForce = true)) do={
    :set dyndnsForce false
    :set previousIP $currentIP
    /tool fetch user=$username password=$password mode=http address="members.dyndns.org" \
    src-path="/nic/update?hostname=$hostname&myip=$currentIP" dst-path="/dyndns.txt"
    :local result [/file get dyndns.txt contents]
    :log info ("UpdateDynDNS: Dyndns update needed")
    :log info ("Update Result: " . $result)
    :put ("Dyndns Update Result: " . $result)
    } else= {
    :log info ("UpdateDynDNS: No dyndns update needed")
    }
    /system scheduler add name=dyndns interval=00:30 on-event="/system script run dynDns\r\n"
    Depois de muintas tentativas unico que funciona perfeito

  2. O que vai aqui?

    :local resolvedIP [:resolve $hostname] <------------



  3. Olá jaksonp

    Nessa linha que indicou não vem nada, na verdade o $hostname é a variável e ela é declarada acima antes dessa linha:

    :global hostname "aqui seu host name criado no site" <- Agora aqui sim onde ela é declarada, você vai informar(entre as aspas duplas) o seu hostname cadastrado no site. Que no caso desse script é para o site dyndns.com.

  4. a tá, blza obrigado, mais uma dúvida funciona na RB 950?



  5. Amigo qual mudança tenho que fazer para usar com uma conta do changeip






Tópicos Similares

  1. Respostas: 2
    Último Post: 09-11-2011, 09:18
  2. Problemas com teste de ping na versão 3.23
    Por cooperrj no fórum Redes
    Respostas: 4
    Último Post: 21-05-2009, 07:54
  3. Cliente de Email que funciona com Exchange
    Por replicante no fórum Servidores de Rede
    Respostas: 1
    Último Post: 21-04-2005, 20:21
  4. www.dominio.com.br soh funciona externo a empresa
    Por quecosuix no fórum Servidores de Rede
    Respostas: 0
    Último Post: 12-04-2005, 10:11
  5. Site www.citibank.com.br não funciona com squid + iptables !
    Por hawk23 no fórum Servidores de Rede
    Respostas: 4
    Último Post: 27-07-2004, 21:50

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L