+ Responder ao Tópico



  1. Senhores, bom dia.

    Estou tentando executar um script no Mikrotik para atualizar meu DynDNS, mas quando rodo ele a partir do terminal eu recebo o seguinte erro: failure: dns server failure. Uso um RB750 v5.25. Este erro está impedindo que eu mantenha meu host atualizado.

    Segue meu script:

    Código :
    :local ddnsuser "meusuario"
    :local ddnspass "minhasenha"
    :local theinterface "pppoe-iface2"
    :local ddnshost "meu.hostname.dyndns"    
    :local ipddns [:resolve $ddnshost];
    :local ipfresh [ /ip address get [/ip address find interface=$theinterface ] address ]
    :if ([ :typeof $ipfresh ] = nil ) do={
       :log info ("DynDNS: No ip address on $theinterface .")
    } else={
       :for i from=( [:len $ipfresh] - 1) to=0 do={
          :if ( [:pick $ipfresh $i] = "/") do={
        :set ipfresh [:pick $ipfresh 0 $i];
          }
    }
    :if ($ipddns != $ipfresh) do={
        :log info ("DynDNS: IP-DynDNS = $ipddns")
        :log info ("DynDNS: IP-Fresh = $ipfresh")
       :log info "DynDNS: Update IP needed, Sending UPDATE...!"
       :local str "/nic/update?hostname=$ddnshost&myip=$ipfresh&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG"
       /tool fetch address=members.dyndns.org src-path=$str mode=http user=$ddnsuser \
             password=$ddnspass dst-path=("/DynDNS.".$ddnshost)
        :delay 1
        :local str [/file find name="DynDNS.$ddnshost"];
        /file remove $str
        :global ipddns $ipfresh
      :log info "DynDNS: IP updated to $ipfresh!"
        } else={
         :log info "DynDNS: dont need changes";
        }
    }

    Obrigado e bom fds!

  2. é só atualizar a sua versão, que ja vai dar certo.






Tópicos Similares

  1. Problema ao rodar script de backup no Crontab
    Por jbenini no fórum Servidores de Rede
    Respostas: 11
    Último Post: 24-10-2008, 07:19
  2. Socket - Cliente Rodar Script no Servidor
    Por cebolark no fórum Linguagens de Programação
    Respostas: 9
    Último Post: 04-09-2006, 07:13
  3. SLACK - rodar script no boot...
    Por LordNae no fórum Sistemas Operacionais
    Respostas: 6
    Último Post: 18-07-2006, 09:29
  4. MOVIDO: SLACK - rodar script no boot...
    Por Duca no fórum Servidores de Rede
    Respostas: 0
    Último Post: 17-07-2006, 09:08
  5. Problemas ao fazer Bridge no Mikrotik
    Por hawk23 no fórum Redes
    Respostas: 8
    Último Post: 05-04-2006, 18:32

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L