#################CONFIGURAÇÃO VPN COM L2TP - SITE-TO-SITE(MATRIZ+FILIAL) ######################

Olá Galera pesquisando um pouco aki no under-linux vi muita gente com dificuldade de fechar um vpn Site-to-Site utilizando o protocolo l2tp,
por este motivo venho por meio deste simplificar esse serviço de vpn muito simples mais eficaz,e dependendo das circunstãncia ele irá,
lhe atender muito bem.

Bom vamos ao que interessa:

Lembrando que essa é uma onfiguração que só poderá feita de Mikrotik Server(onde vc esta) para Mikrotik Cliente(seu cliente)
ou seja de uma MATRIZ para uma FILIAL.

Cenario:

Servidor: Mikrotik
Ip Local: 192.168.77.1/24
Ip Publico: 189.xxx.xxx.158/32

Cliente: Mikrotik
Ip Local: 192.168.1.1/24
Ip Publico: 186.xxx.xxx.14/30

Os 2 Mikrotiks precisa está necessariamente conectado á internet.

######################CONFIGURAÇÃO VPN COM L2TP - SERVER##########################

1º No servidor criamos um pool como está abaixo:

/ip pool
add name=Pool-Blz_Net ranges=10.0.10.2-10.0.10.27

2º No servidor criamos um profile como está abaixo:

/ppp profile
add change-tcp-mss=yes dns-server=10.0.10.1 local-address=10.0.10.1 name=\
vpn-blz_net remote-address=Pool-Blz_Net

3º Ainda no servidor criamos uma secret

/ppp secret
add local-address=10.0.10.1 name=teste.blz password=blzxx profile=\
vpn-blz_net remote-address=10.0.10.3 service=l2tp

4º Vamos ativar o serviço l2tp e criar um l2tp-server com a profile criada no exercicio de nº (2).

/interface l2tp-server server
set default-profile=vpn-blz_net enabled=yes max-mru=1460 max-mtu=1460
add name=l2tp-teste.blz user=teste.blz


5º Ainda no servidor criamos no route as rotas de destino apontadas para o gateway do meu cliente como está abaixo:
Esse ip 192.168.1.0/24 é uma faixa de ip que supostamente eu tenho na rede do meu cliente, isso significa que,
todos os computadores e equipamentos que estiverem dentro desta faixa de ip, eu não só vou conseguir pingar neles como tbm,
entrar dentro deles...

/ip route
add comment=VPN-Pa_Vitoria distance=1 dst-address=10.1.10.0/28 gateway=10.0.10.3
add comment=Pa-Vitoria distance=1 dst-address=192.168.1.0/24 gateway=10.0.10.3






################CONFIGURAÇÃO VPN COM L2TP - CLIENTE##############################


Agora vamos para o Mikrotik cliente

1º Vamos ativar o serviço de l2tp:

/interface l2tp-server server
set enabled=yes


2º Vamos criar uma interface com l2tp-client como está abaixo!
Este ip 189.xxx.xxx.158 é o ip a qual seu cliente vai se comunicar com o servidor,
falando em uma liguagem mais clara este ip fica no seu sevidor, ou seja um ip publico,
no caso de adsl vou deixar o script de renovação do ip, porque eles mudam de vez em quanto...
esse script é adicionando no servidor.

/interface l2tp-client
add add-default-route=no allow=pap,chap,mschap1,mschap2 connect-to=\
189.xxx.xxx.158 dial-on-demand=no disabled=no keepalive-timeout=60 max-mru=\
1460 max-mtu=1460 mrru=disabled name=VPN-Server-Luzinopolis password=\
pavitoria profile=default-encryption user=teste.xx

3º Em routes no mikrotik cliente vamos apontar a rota para a faixa do nosso Servidor Mikrotik e o gateway
tbm para o nosso Servidor Mikrotik.
Pronto feito isso já temos comunicação de ambos os lados.

/ip route
add comment="vpn-Luzinopolis" distance=1 dst-address=192.168.77.0/24 gateway=10.0.10.1


E para finalizar:

Fazer os testes e ver se realmente estamos tendo comunicação do nosso server para o cliente façam o seguinte

1º suponhamos que o ip da sua maquina que está conctada ao server, esteja na mesma faixa de ip local configurada no servidor: 192.168.77.0/24

Ip da sua maquina: 192.168.77.150

Então: ping para: 192.168.1.1 que é a faixa de ip do cliente e terá resposta, se não verifique se não fez nada errado.
Suponhamos que ele tenha nesta mesma rede outro equipamento com o ip 192.168.1.20 tbm irá ter resposta, desde que este esquipamento esteja
na mesma interface onde foi setada a faixa 192.168.1.1/24.

Bom pessoal é isso, nos perdoe pelo nivel baixo de liguagem expressiva e espero ter ajudado alguem com esse topico...

Como Prometido, pra quem não tem ip fixo e usa adsl ai está os scripts de atualização do seu ip:

#################### SCRIPTS #############################################
Esse primeiro script vc add ele manual mesmo:
Nome desse primeiro script: "SetL2TP"
:global newr1 [:resolve hostname.changeip.org]
/int l2tp-client set VPN-Server-Luzinopolis connect-to=$newr1
:log info "SetL2TPscript:Changing IP"

/system scheduler add disabled=yes interval=1m name=SetL2TP on-event="system script run SetL2TP" \
policy=read,write,test start-time=startup

/system script add name=EnaSched_1 policy=ftp,reboot,read,write,policy,test,winbox,password,sniff \
source="sys sched ena SetL2TP"
/system script add name=DisaSched_1 policy=ftp,reboot,read,write,policy,test,winbox,password,sniff \
source="sys sched disa SetL2TP"

/tool netwatch add disabled=no down-script=EnaSched_1 host=10.0.10.1 interval=15s timeout=1s \
up-script=DisaSched_1


Att,

Altemar Ribeiro (Mazim)
Cel: (63)9928-9018Skype: altemar_ribeiro87@outlook.com
E-mail: mazim@blznet.com - altemar.redeinfornet@gmail.com
Site: http://www.blznet.com/