Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Post {TUTORIAL} Como liberar banda automaticamente para os clientes no MIKROTIK

    Olá, depois de passar um bom tempo pesquisando e obtendo ajuda da galera aqui do Under,
    finalmente consegui criar a regra para liberar banda automaticamente no Mikrotik para todos os clientes
    e agora vou repassar aqui em forma de tutorial para sanar duvidas e ajudar futuramente outras pessoas.

    A versão do meu MK é a v6.27
    O modo de autenticação que uso é PPPoE, porém eu acredito que funcione com qualquer tipo de autenticação

    Como deixar banda livre para todos os clientes

    Primeiramente foi criado uma regra de queue:

    /queue simple
    add disabled=no max-limit=900M/900M name=MADRUGADAO target="0.0.0.0/0"

    Após criar a regra de queue arraste ela pra cima, para que seja a primeira regra de todas.

    ai vocês me perguntam porque eu coloquei 900M no max-limit ao contrario de unlimited,
    o problema é que aqui, comigo, quando eu colocava unlimited ela simplismente não funcionava sobre as outras regras
    e só passou a funcionar quando eu defini um max-limit

    agora criaremos um script:

    /system script

    add name=DISABLE_MADRUGADAO policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive source=\
    "/queue simple disable MADRUGADAO"
    add name=ENABLE_MADRUGADAO policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive source=\
    "/queue simple enable MADRUGADAO"


    porque o meu source esta assim ? source=\"/queue simple disable MADRUGADAO"


    Esta assim porque quando eu colocava source="/queue simple { disable \[find name=MADRUGADAO\] }"
    ele não funcionava, então eu fiz ele como se fosse direto no terminal e funcionou.

    agora vamos fazer o agendamento para habilitar e desabilitar essa regra de queue:

    /system scheduler
    add interval=1d name=ENABLE_MADRUGADAO on-event=ENABLE_MADRUGADAO policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive start-date=\
    may/02/2015 start-time=23:00:00
    add interval=1d name=DISABLE_MADRUGADAO on-event=DISABLE_MADRUGADAO policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive start-date=\
    may/02/2015 start-time=07:00:00

    Pronto


    Como aumentar banda para os clientes, mas com limite

    Muitas pessoas querem aumentar a banda para os clientes mas sem deixar livre, pois um cliente só pode acabar consumindo toda a banda que tiver na rede, podendo até gerar lentidão para muitas pessoas. então aqui eu mostro como aumentar a banda, mas deixando com limite.

    o método que eu encontrei para fazer isso foi alterar a velocidade dos profiles, e ai desconectar o cliente para que ele reconecte com o novo limite de velocidade. Vamos lá.

    Vamos começar criando uns Scripts:

    /system script

    Este aqui é para aumentar a velocidade dos profiles para 10mb:

    add name=ENABLE_MADRUGADAO policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive source="/interf\
    ace ethernet disable ether1\r\
    \n\r\
    \n/ppp profile set EMPRESARIAL-1M rate-limit=10M\r\
    \n\r\
    \n/ppp profile set EMPRESARIAL-2M rate-limit=10M\r\
    \n\r\


    EMPRESARIAL-1M é o nome do meu profile, 10M é a nova velocidade. como podem ver, eu comecei a regra desativando a ether1 (no fim eu explico o motivo).

    Este aqui é para voltar os profiles para a velocidade normal

    add name=DISABLE_MADRUGADAO policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive source="/interf\
    ace ethernet disable ether1\r\
    \n\r\
    \n/ppp profile set EMPRESARIAL-1M rate-limit=512K/1M\r\
    \n\r\
    \n/ppp profile set EMPRESARIAL-2M rate-limit=1M/2M\r\
    \n\r\

    aqui como podem ver, o plano EMPRESARIAL-1M voltou a ter 512k de upload e 1M de download.

    O motivo da regra desativar a ether1.

    como disse no começo, o cliente precisa ser desconectado e reconectar para poder ter a nova velocidade definida no profile, tentei de varias fomas e não consegui, o unico meio que encontrei foi, ou criar um script para reiniciar a rb, ou desabilitar a ether na qual a rede pppoe esta direcionada para que o cliente seja forçado a se desconectar, escolhi a segunda alternativa, sabendo disso, vamos criar a regra para poder reabilitar a ether1,

    /system script

    add name=ATIVAR-ETHER policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive source=\
    "/interface ethernet enable ether1"

    Agora vamos configurar os agendamentos.


    /system scheduler

    Este aqui para ativar o script que muda os profiles para 10M

    add interval=1d name=ATIVAR_MADRUGADAO on-event=ENABLE_MADRUGADAO policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive start-date=may/02/2015 start-time=23:00:00

    Este aqui para chamar o script que reativa a ether1

    add name=ENABLE-ETHER-START on-event=ENABLE-ETHER-START policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive \
    start-date=may/06/2015 start-time=23:00:15

    como podem ver, eu coloquei ela para ser executada 15 segundos após a outra, para que tenha tempo do cliente se desconectar.

    Este aqui para ativar o script que volta os profiles ao normal

    add interval=1d name=DISABLE_MADRUGADAO on-event=DISABLE_MADRUGADAO policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive start-date=may/02/2015 start-time=07:00:00

    Este aqui para reativar a ether1 desta terceira regra

    add name=ENABLE-ETHER-START on-event=ENABLE-ETHER-START policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive \
    start-date=may/06/2015 start-time=07:00:15

    como podem ver, 15 segundos depois da regra também.

    Fim.

    Pronto pessoal esse é o caminho que eu encontrei para liberar banda automaticamente para os meus clientes,
    lembro a vocês que não sou nenhum expert em mikrotik, na verdade sou iniciante, e não sei se contém erros, porém comigo funcionou dessa forma, e eu não tive nenhum problema, qualquer duvida só dizer.

    Abraços.
    Última edição por taiendychyvu; 06-05-2015 às 14:49. Razão: adicionei como dobrar a banda,.

  2. #2

    Padrão Re: {TUTORIAL} Como liberar banda automaticamente para os clientes no MIKROTIK

    Você divulga isso aos seus clientes? tipo que depois das 11hrs eles tem mais banda e tallz? Obrigado por compartilhar



  3. #3

    Padrão Re: {TUTORIAL} Como liberar banda automaticamente para os clientes no MIKROTIK

    Ótima contribuição para o fórum amigo parabéns.

  4. #4

    Padrão Re: {TUTORIAL} Como liberar banda automaticamente para os clientes no MIKROTIK

    Sim isso mesmo @RickBrito a partir das 23:00:00 seus clientes tem toda a banda disponível até as 07:00:00 com um intervalo de 1d.



  5. #5

    Padrão Re: {TUTORIAL} Como liberar banda automaticamente para os clientes no MIKROTIK

    Citação Postado originalmente por RickBrito Ver Post
    Você divulga isso aos seus clientes? tipo que depois das 11hrs eles tem mais banda e tallz? Obrigado por compartilhar
    Amigo, aqui não divulgamos, mas também não "escondemos" o motivo da não divulgação é que a pessoa pode pegar o plano mais barato porque sabe que a noite ele vai poder usar quanto quiser, podendo gerar certos prejuízos, por isso a não divulgação, e a maioria dos clientes acham que a velocidade aumenta porque tem menos pessoas usando e não porque o provedor libera mais banda pra ele.. Dessa forma acabamos agradando os que vivem de download, rsrsrs. Porém caso reclamem que durante o dia a Net tem velocidade menor, ai pra evitar problema com esse determinado cliente explicamos que é por causa dessa regra ai. Mas fica a critério de cada um..

  6. #6

    Padrão Re: {TUTORIAL} Como liberar banda automaticamente para os clientes no MIKROTIK

    muito bom o seu tópico, gostaria de ver mais pessoas como você compartilhando coisa boas para acrescentar ao fórum e as pessoas que vivem neste mundo louco, gostaria que mais pessoas fizessem isso, para acrescentar e não criticar e ficar querendo mostrar que sabe mais que o outro ... Parabéns ... Rodrigo



  7. #7

    Padrão Re: {TUTORIAL} Como liberar banda automaticamente para os clientes no MIKROTIK

    Citação Postado originalmente por agatangelos Ver Post
    muito bom o seu tópico, gostaria de ver mais pessoas como você compartilhando coisa boas para acrescentar ao fórum e as pessoas que vivem neste mundo louco, gostaria que mais pessoas fizessem isso, para acrescentar e não criticar e ficar querendo mostrar que sabe mais que o outro ... Parabéns ... Rodrigo
    Muito obrigado, já aprendi algumas coisas aqui no under, acho sempre bom procurar retribuir

  8. #8

    Padrão

    Citação Postado originalmente por taiendychyvu Ver Post
    Amigo, aqui não divulgamos, mas também não "escondemos" o motivo da não divulgação é que a pessoa pode pegar o plano mais barato porque sabe que a noite ele vai poder usar quanto quiser, podendo gerar certos prejuízos, por isso a não divulgação, e a maioria dos clientes acham que a velocidade aumenta porque tem menos pessoas usando e não porque o provedor libera mais banda pra ele.. Dessa forma acabamos agradando os que vivem de download, rsrsrs. Porém caso reclamem que durante o dia a Net tem velocidade menor, ai pra evitar problema com esse determinado cliente explicamos que é por causa dessa regra ai. Mas fica a critério de cada um..
    Bem pensado essa questão, na hora já pensei que isso seria um atrativo e divulgar como um opção a mais, porem como povo Brasileiro é, ia pega o plano mais barato e deixar pra usar a net de verdade depois das 11hrs, muito bom.



  9. #9

    Padrão

    Citação Postado originalmente por wld.net1 Ver Post
    Sim isso mesmo @RickBrito a partir das 23:00:00 seus clientes tem toda a banda disponível até as 07:00:00 com um intervalo de 1d.
    Eu entendi a regra, minha pergunta era sobre a questão de divulgar ou não aos clientes.

  10. #10

    Padrão Re: {TUTORIAL} Como liberar banda automaticamente para os clientes no MIKROTIK

    pessoal eu estava precisando fazer ao parecido, sendo que eu queria por todos os usuários (pppoe) com 2MB quando houvesse necessidade, será que eu conseguira adaptado estas regras? não precisa entrar automaticamente, pode ser manual a mudança. .. Valeu!



  11. #11

    Padrão Re: {TUTORIAL} Como liberar banda automaticamente para os clientes no MIKROTIK

    Citação Postado originalmente por agatangelos Ver Post
    pessoal eu estava precisando fazer ao parecido, sendo que eu queria por todos os usuários (pppoe) com 2MB quando houvesse necessidade, será que eu conseguira adaptado estas regras? não precisa entrar automaticamente, pode ser manual a mudança. .. Valeu!
    Para mudar a velocidade de cada usuário eu acredito que não da certo, o ideal seria mudar a velocidade do profile e ai derrubar e esperar o cliente reconectar, ai vc poderia usar um script pra essa função..

  12. #12

    Padrão Re: {TUTORIAL} Como liberar banda automaticamente para os clientes no MIKROTIK

    Citação Postado originalmente por RickBrito Ver Post
    Bem pensado essa questão, na hora já pensei que isso seria um atrativo e divulgar como um opção a mais, porem como povo Brasileiro é, ia pega o plano mais barato e deixar pra usar a net de verdade depois das 11hrs, muito bom.
    O que poderia ser uma boa ideia é vender o plano um pouco mais caro, mas com essa opção de banda livre durante a madrugada, ai algumas pessoas poderiam se interessar,



  13. #13

    Padrão Re: {TUTORIAL} Como liberar banda automaticamente para os clientes no MIKROTIK

    Legal o post @taiendychyvu

    Tenho uma função parecida no meu sistema. O FoxPanel chamado de Horário Turbo. No cadastro do plano vc escolhe a hora de ativação e desativação e a velocidade de down e up que vai ser setada no momento do horário turbo. Alem de poder escolher para quais clientes e planos usar ou não.

    Uma coisa que achei engraçado aconteceu a alguns dias atrás. O cliente entrou em contato com meu socio no sistema para saber se poderia usar o modo turbo de forma inversa. Falou que a noite o link ficava saturada e queria baixar a velocidade dos clientes anoite em determinado horário. falamos que sim pode ser usado dessa forma tbm. Mas achei o fato inusitado.

    Atenciosamente,
    Everson Morais
    Developer foxPanel
    www.foxpanel.com.br

  14. #14

    Padrão Re: {TUTORIAL} Como liberar banda automaticamente para os clientes no MIKROTIK

    Citação Postado originalmente por eversoncsa Ver Post
    Legal o post @taiendychyvu

    Tenho uma função parecida no meu sistema. O FoxPanel chamado de Horário Turbo. No cadastro do plano vc escolhe a hora de ativação e desativação e a velocidade de down e up que vai ser setada no momento do horário turbo. Alem de poder escolher para quais clientes e planos usar ou não.

    Uma coisa que achei engraçado aconteceu a alguns dias atrás. O cliente entrou em contato com meu socio no sistema para saber se poderia usar o modo turbo de forma inversa. Falou que a noite o link ficava saturada e queria baixar a velocidade dos clientes anoite em determinado horário. falamos que sim pode ser usado dessa forma tbm. Mas achei o fato inusitado.

    Atenciosamente,
    Everson Morais
    Developer foxPanel
    www.foxpanel.com.br
    Obrigado, talvez o motivo do cliente pedir o inverso é porque ele deve vender mais residencial do que empresarial ai durante a noite é quando a maioria das pessoas voltam do trabalho e acabam gerando um consumo maior do que o de dia, porem é relevante que depois das 00:00 a maioria das pessoas já estão dormindo..



  15. #15

    Padrão Re: {TUTORIAL} Como liberar banda automaticamente para os clientes no MIKROTIK

    Não vejo como uma boa solução, para um provedor, acredito que cliente tem que ter somente o que foi contratado, não precisamos agrada-los, pois são eternos insatisfeitos, isto cria mecanismos de problemas, um deles seria justamente a falta de desejo de querer um plano maior.

  16. #16

    Padrão Re: {TUTORIAL} Como liberar banda automaticamente para os clientes no MIKROTIK

    Já tive essa ideia quando comecei no ramo, mas achei que não daria certo depois que a clientela aumentasse, mas é uma boa pra galera que usa softwares que consomem banda como P2P.



  17. #17

    Padrão Re: {TUTORIAL} Como liberar banda automaticamente para os clientes no MIKROTIK

    Citação Postado originalmente por biohazzard Ver Post
    Não vejo como uma boa solução, para um provedor, acredito que cliente tem que ter somente o que foi contratado, não precisamos agrada-los, pois são eternos insatisfeitos, isto cria mecanismos de problemas, um deles seria justamente a falta de desejo de querer um plano maior.

    Existem casos e casos. Acho que agradar o cliente é valido sim. Em qualquer nicho de mercado que vc queira seguir o cliente sempre vem em primeiro lugar. Porem não usaria a regra postada acima pelo fato de beneficiar todos de forma igual independente do plano e valor pago. Podendo até quem tem um plano inferior usar um gerenciador de download como orbit e acabar prejudicando a conexão dos outros.

    Até por isso no meu sistema fiz o modo turbo por planos. No meu caso dobro a velocidade do plano. Quem tem 1 mega de 0h a 7h usa 2 megas... Quem tem 2 megas usa 4megas e por ai vai. Veja essa forma bem justa e os clientes sabem que quando maior seu plano maior vai ser sua velocidade anoite. Isso não tira do cliente a motivação de querer contratar sempre um plano maior.

    Atenciosamente,
    Everson Morais
    Developer foxPanel
    www.foxpanel.com.br

  18. #18

    Padrão Re: {TUTORIAL} Como liberar banda automaticamente para os clientes no MIKROTIK

    Me desculpe colegas, a atitude do dono do tópico é louvável, parabéns.
    Mais isso não é 1 tiro no pé, e pior do que rancalo.
    A regra não tem freio, isso que dizer que voce pode facilmente inopera 1 ptp, ou 1 cliente com muita requisição torne a net de todos lentos, acredite, existe pessoas que navegam ou jogam na madrugada, o beneficio pode gerar reclamações...
    tem que ser algo como dobrar a banda ou 1 PCQ.
    Como everson disse, modo turbo é ideal, uso e aprovo aqui, dps das 00.00 a velocidade é dobrada, DOBRADA, se deixa livre 1 louco pode pegar 100Mb só pra ele.



  19. #19

    Padrão Re: {TUTORIAL} Como liberar banda automaticamente para os clientes no MIKROTIK

    Aqui comigo desde quando abilitei a regra ninguém veio ate nos pra reclamar, e também eu estou sempre de olho pra ver como esta. Existem casos e acasos.

    Porem eu acredito que liberar a banda ou só dobrar a velocidade, é uma ótima alternativa, pois agrada o seu cliente.

  20. #20

    Padrão Re: {TUTORIAL} Como liberar banda automaticamente para os clientes no MIKROTIK

    como fazer pra dobrar?