+ Responder ao Tópico



  1. Olá amigos, preciso da ajuda de vcs pois não sei mais o que fazer, já estou ficando meio louco :s

    Tenho hj 3 links do velox, 10,10 e 15, e tenho 2 RB750GL, uma gerencia os clientes e esta com 15MB ativo, preciso fazer um balance nesse segunda RB, juro que já tentei de tudo, acho que já vi todos os videos do youtube e não consigo, estou a 2 dias sem dormir tentando fazer isso, estou perdendo clientes, já estou entrando em desespero, alguém poderia me ajudar?

  2. Da pra fazer de varias formas @filipemd, PCC é o mais usado visto a capacidade de sempre direcionar um endereço em específico pelo mesmo link, evitando alguns problemas e deixando outros que tem que resolver manualmente.

    Com PCC, você pode considerar o M.D.C de 10, 10 e 15 é 5, e com isso você tem, multiplicando esse valor, o peso de cada link. Cada link de 10 com peso 2, e o de 15 com peso 3. A soma de todos os pesos é 7, então usa isso nas regras...

    O básico do mangle:

    A routing mark "Rota1" é o promeiro link de 10Mb, a "Rota2" seria o segundo de 10Mb, e "Rota3" o link de 15Mb. Como você pode perceber, foram 2 regras para a "Rota1" (peso 2), mais 2 regras para a "Rota2" (peso 2 também), e mais 3 regras para a "Rota3" (com peso 3).

    Código :
    /ip firewall mangle add chain=prerouting per-connection-classifier=both-address-and-ports:7/0 action=mark-routing new-routing-mark=Rota1
    /ip firewall mangle add chain=prerouting per-connection-classifier=both_address-and-ports:7/1 action=mark-routing new-routing-mark=Rota1
    /ip firewall mangle add chain=prerouting per-connection-classifier=both_address-and-ports:7/2 action=mark-routing new-routing-mark=Rota2
    /ip firewall mangle add chain=prerouting per-connection-classifier=both_address-and-ports:7/3 action=mark-routing new-routing-mark=Rota2
    /ip firewall mangle add chain=prerouting per-connection-classifier=both_address-and-ports:7/4 action=mark-routing new-routing-mark=Rota3
    /ip firewall mangle add chain=prerouting per-connection-classifier=both_address-and-ports:7/5 action=mark-routing new-routing-mark=Rota3
    /ip firewall mangle add chain=prerouting per-connection-classifier=both_address-and-ports:7/6 action=mark-routing new-routing-mark=Rota3

    Depois disso, só adiciona as rotas com os nomes. Onde está XXX.XXX.XXX.XXX é o IP do gateway da Rota1 (primeiro link de 10Mb), YYY.YYY.YYY.YYY o IP do gateway da Rota2 (segundo link de 10Mb), e ZZZ.ZZZ.ZZZ.ZZZ o IP do gateway do link de 15Mb.

    Código :
    /ip route add dst-address=0.0.0.0/0 gateway=XXX.XXX.XXX.XXX routing-mark=Rota1
    /ip route add dst-address=0.0.0.0/0 gateway=YYY.YYY.YYY.YYY routing-mark=Rota2
    /ip route add dst-address=0.0.0.0/0 gateway=ZZZ.ZZZ.ZZZ.ZZZ routing-mark=Rota3

    Caso você utilize interfaces PPPoE Client para conectar esses Velox e os IPs são dinamicos, ali nas rotas, ao inves de colocar os IPs dos gateways, coloca a interface PPPoE Client referente a cada link.

    O básico é isso.



  3. Muito Obrigado!






Tópicos Similares

  1. Load Balance ao estilo OSPF
    Por Hawthorn no fórum Servidores de Rede
    Respostas: 0
    Último Post: 18-06-2003, 16:06
  2. Load Balance
    Por Hawthorn no fórum Servidores de Rede
    Respostas: 2
    Último Post: 17-06-2003, 08:53
  3. Load Balance + HA - Possivel ou não dá?
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 23-05-2003, 11:30
  4. Load Balance
    Por no fórum Servidores de Rede
    Respostas: 2
    Último Post: 15-05-2003, 08:21
  5. Load Balance - Urgente
    Por Legolas no fórum Servidores de Rede
    Respostas: 0
    Último Post: 11-04-2003, 08:10

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L