+ Responder ao Tópico



  1. #1

    Padrão Redirecionamento de Pacotes por porta específica

    Bom dia,

    Tenho 2 Rb's atualmente fazendo VPN entre duas lojas. Como a velocidade da conexão com o banco da matriz era muito lenta, resolvemos levantar uma bridge de fibra entre as filiais porém, agora preciso redirecionar os pacotes com chamada em uma porta especifica para esta bridge e o resto do tráfego passar pela VPN

    Alguém sabe como fazer isso?

  2. #2

    Padrão Re: Redirecionamento de Pacotes por porta específica

    Ninguém? :x



  3. #3

    Padrão Re: Redirecionamento de Pacotes por porta específica

    Calma, cara. Postou 10:05 e 13:41 já quer resposta? Deixe o pessoal almoçar direito, hahaha.

    É o seguinte: até onde sei, você não consegue determinar por qual porta de uma bridge o tráfego vai sair. Quem determina a porta a ser usada é o protocolo STP, e ela será usada para todo tipo de tráfego, sem distinção.

    Agora, na camada 3, roteando, você consegue fazer isso aí. Para isso, você não vai poder colocar essa rede óptica na bridge. Ao invés disso, terá que deixá-la fora e fazer o endereçamento IP das filiais e da matriz nas interfaces onde está conectada a fibra (todo mundo na mesma rede e máscara de IP).

    Não sei se você roda OSPF ou algum outro protocolo de roteamento dinâmico entre as filiais, mas basicamente o que vai precisar fazer é criar nas RBs das filiais uma rota para o servidor de banco de dados (no exemplo é 172.16.8.20), passando através da fibra pela RB (no exemplo é 192.168.50.1) que está no mesmo local do servidor de banco de dados, que suponho que seja na matriz, com um routing-mark, ex.:

    Código :
    /ip route add dst-address=172.16.8.20 gateway=192.168.50.1 routing-mark=rota-fibra

    Dessa maneira aí, todo tráfego em direção ao servidor de banco de dados vai passar pela fibra.

    Ainda tem que ajustar a rota no servidor de banco de dados para o tráfego vindo dele para as filiais também passar pela fibra, mas não consigo dar mais explicações sem você ilustrar como está a topologia da rede, se há algum protocolo de roteamento dinâmico rodando, se há NAT, se é apenas 1 filial ou várias (seu post inicial diverge nesse detalhe), etc.

  4. #4

    Padrão Re: Redirecionamento de Pacotes por porta específica

    Citação Postado originalmente por TsouzaR Ver Post
    Calma, cara. Postou 10:05 e 13:41 já quer resposta? Deixe o pessoal almoçar direito, hahaha.

    É o seguinte: até onde sei, você não consegue determinar por qual porta de uma bridge o tráfego vai sair. Quem determina a porta a ser usada é o protocolo STP, e ela será usada para todo tipo de tráfego, sem distinção.

    Agora, na camada 3, roteando, você consegue fazer isso aí. Para isso, você não vai poder colocar essa rede óptica na bridge. Ao invés disso, terá que deixá-la fora e fazer o endereçamento IP das filiais e da matriz nas interfaces onde está conectada a fibra (todo mundo na mesma rede e máscara de IP).

    Não sei se você roda OSPF ou algum outro protocolo de roteamento dinâmico entre as filiais, mas basicamente o que vai precisar fazer é criar nas RBs das filiais uma rota para o servidor de banco de dados (no exemplo é 172.16.8.20), passando através da fibra pela RB (no exemplo é 192.168.50.1) que está no mesmo local do servidor de banco de dados, que suponho que seja na matriz, com um routing-mark, ex.:

    Código :
    /ip route add dst-address=172.16.8.20 gateway=192.168.50.1 routing-mark=rota-fibra

    Dessa maneira aí, todo tráfego em direção ao servidor de banco de dados vai passar pela fibra.

    Ainda tem que ajustar a rota no servidor de banco de dados para o tráfego vindo dele para as filiais também passar pela fibra, mas não consigo dar mais explicações sem você ilustrar como está a topologia da rede, se há algum protocolo de roteamento dinâmico rodando, se há NAT, se é apenas 1 filial ou várias (seu post inicial diverge nesse detalhe), etc.
    hehe, to entrando em parafuso já, infelizmente esse foi o motivo da pressa, peço desculpa!
    Mas então deixa eu tentar expor um pouco melhor, Tenho um segundo mikrotik fazendo a bridge e esse que faz a bridge está conectado no meu mikrotik em uma porta sendo assim ele ganha um ip comum com a possibilidade de fazer rotas igual a VPN que tenho rodando
    porém eu gostaria de desviar os pacotes da porta 50000 pelo IP da bridge
    e o resto pelo IP da VPN
    Não sei se consegui me expressar um pouco melhor



  5. #5

    Padrão Re: Redirecionamento de Pacotes por porta específica

    Citação Postado originalmente por MarceloJr Ver Post
    hehe, to entrando em parafuso já, infelizmente esse foi o motivo da pressa, peço desculpa!
    Mas então deixa eu tentar expor um pouco melhor, Tenho um segundo mikrotik fazendo a bridge e esse que faz a bridge está conectado no meu mikrotik em uma porta sendo assim ele ganha um ip comum com a possibilidade de fazer rotas igual a VPN que tenho rodando
    porém eu gostaria de desviar os pacotes da porta 50000 pelo IP da bridge
    e o resto pelo IP da VPN
    Não sei se consegui me expressar um pouco melhor
    Essa sua explicação não resolveu muita coisa não, hahaha.
    Mas vou tentar ajudar.

    Após fazer o endereçamento das filiais e matriz em uma rede IP distinta na porta onde chega a fibra, faça as seguintes configurações nas RBs das filiais:

    Crie uma rota para direcionar o tráfego (por enquanto não vamos especificar qual) para a RB da matriz
    Código :
    /ip route add dst-address=0.0.0.0/0 gateway=IP_DA_RB_MATRIZ_FIBRA routing-mark=rota-matriz-fibra

    Onde está IP_DA_RB_MATRIZ_FIBRA, você tem que colocar o IP da RB que está na matriz e que pode rotear tráfego para o servidor de banco de dados. Esse IP deve estar na mesma faixa configurada nas RBs nas filiais na interface onde chega a fibra.

    Marque no firewall apenas o tráfego na porta 50000 para sair pela fibra:
    Código :
    /ip firewall mangle add chain=prerouting protocol=tcp dst-address=IP_DO_SERVIDOR_BANCO_DE_DADOS dst-port=50000 action=mark-routing new-routing-mark=rota-matriz-fibra

    Teste aí para ver se isso resolve.
    Como você não disse se há protocolo de roteamento dinâmico rodando na rede (OSPF, por exemplo), rotas estáticas para todos destinos, ou NAT, eu não sei se precisará de alguma configuração a mais que essa.

  6. #6

    Padrão Re: Redirecionamento de Pacotes por porta específica

    Não funcionou!
    Amanhã vou fazer um esquema para explanar de uma forma mais simplificada! Até hoje não compreendo o Mangle e suas funções é uma pena, preciso me aprimorar.

    Abraços!



  7. #7

    Padrão Re: Redirecionamento de Pacotes por porta específica

    Citação Postado originalmente por TsouzaR Ver Post
    Essa sua explicação não resolveu muita coisa não, hahaha.
    Mas vou tentar ajudar.

    Após fazer o endereçamento das filiais e matriz em uma rede IP distinta na porta onde chega a fibra, faça as seguintes configurações nas RBs das filiais:

    Crie uma rota para direcionar o tráfego (por enquanto não vamos especificar qual) para a RB da matriz
    Código :
    /ip route add dst-address=0.0.0.0/0 gateway=IP_DA_RB_MATRIZ_FIBRA routing-mark=rota-matriz-fibra

    Onde está IP_DA_RB_MATRIZ_FIBRA, você tem que colocar o IP da RB que está na matriz e que pode rotear tráfego para o servidor de banco de dados. Esse IP deve estar na mesma faixa configurada nas RBs nas filiais na interface onde chega a fibra.

    Marque no firewall apenas o tráfego na porta 50000 para sair pela fibra:
    Código :
    /ip firewall mangle add chain=prerouting protocol=tcp dst-address=IP_DO_SERVIDOR_BANCO_DE_DADOS dst-port=50000 action=mark-routing new-routing-mark=rota-matriz-fibra

    Teste aí para ver se isso resolve.
    Como você não disse se há protocolo de roteamento dinâmico rodando na rede (OSPF, por exemplo), rotas estáticas para todos destinos, ou NAT, eu não sei se precisará de alguma configuração a mais que essa.
    Essa é a estrutura que tenho hoje

    Clique na imagem para uma versão maior

Nome:	         JfNXjLV.png
Visualizações:	33
Tamanho: 	18,3 KB
ID:      	59596

    A bridge é fornecida por uma empresa tercerizada, então, eles apenas liberaram a bridge e eu utilizo os IP's fornecidos por eles...
    O que eu preciso fazer é O trafego comum vai sair pela VPN e o trafego da Porta 50000 vai sair apenas pela bridge

    talvez agora fique um pouco melhor para entender

    Abraço!