Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão instalar mk-auth em maquina virtual para aviso e bloqueio no pppoe pode?

    bom dia! estou pesquisando aqui, porém com muitas dúvidas. gostaria de uma resposta simples, se pode ou não ao invés de deixar uma maquina rodando o mk-auth eu comprar a licença e e instalar o mk-auth em uma maquina virtual para enviar tela de aviso e bloqueio para meus clientes pppoe?

    pode ou não???

  2. #2

    Padrão Re: instalar mk-auth em maquina virtual para aviso e bloqueio no pppoe pode?

    Complementando o que o @Arthur Bernardes disse...

    Pode sim instalar numa maquina virtual, roda tranquilo, mas essa VM vai ter que estar ligada 24/7 para servir de Radius server do seu router. Tenho um parceiro que ta começando a usar MKAuth e ajudei ele a montar tudo e fizemos exatamente assim, um PC virtualizando MKAuth com XenServer, e sobra maquina para virtualizar um DNS por exemplo, e outros serviços dependendo do PC.



  3. #3
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.094
    Posts de Blog
    15

    Padrão Re: instalar mk-auth em maquina virtual para aviso e bloqueio no pppoe pode?

    Pode instalar, aviso e bloqueio é uma das funções dele. Ainda pode aproveitar e hospedar outras páginas nele. Como por exemplo de notificação.

  4. #4

    Padrão Re: instalar mk-auth em maquina virtual para aviso e bloqueio no pppoe pode?

    Interhome valeu meu brother, obrigado. Caso eu desligue minha máquina, os meus clientes vão ser derrubado? ( ficar sem net?) Eu sei que é pergunta de leigo, porque eu só quero colocar somente para aviso,bloqueio e anúncios.



  5. #5
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.094
    Posts de Blog
    15

    Padrão Re: instalar mk-auth em maquina virtual para aviso e bloqueio no pppoe pode?

    Se usar o mk-auth como autenticador, os clientes que estão conectados permanecem porém os novos não autenticam. Apesar que já vi usuários do sistema exportando para o MK a lista de clientes para contornar esse tipo de situação.
    Prefiro nessa questão ou donde sistemas que usam SSH ou API. Ex. SCUT. Existem vários no mercado.

  6. #6

    Padrão Re: instalar mk-auth em maquina virtual para aviso e bloqueio no pppoe pode?

    aí é que está, mais eu nao quero utilizar o mk-auth como autenticador, apenas quero somente utilizar ele quando for enviar um aviso, um anuncio ou até mesmo bloquear o cliente e ele ver na tela dele... redirecionamento para a pagina do mk-auth entende.

    estou eliminando hotspot da minha rede, migrando para pppoe, entao queria que o mk-auth mosttrasse a tela de aviso e bloqueio no cliente inadiplente



  7. #7
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.094
    Posts de Blog
    15

    Padrão Re: instalar mk-auth em maquina virtual para aviso e bloqueio no pppoe pode?

    Para isso funciona 100%.

  8. #8

    Padrão Re: instalar mk-auth em maquina virtual para aviso e bloqueio no pppoe pode?

    É bem simples não é amigão fazer esse redirecionamento de aviso e bloqueio para clientes pppoe não é?



  9. #9
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.094
    Posts de Blog
    15

    Padrão Re: instalar mk-auth em maquina virtual para aviso e bloqueio no pppoe pode?

    Sim. Coloca a máquina para rodar que lhe envio as regatas. Precisarei do ip da máquina.

  10. #10

    Padrão

    Citação Postado originalmente por interhome Ver Post
    Sim. Coloca a máquina para rodar que lhe envio as regatas. Precisarei do ip da máquina.
    @interhome seria de muita valia ser voce postar as regras aqui no forum.



  11. #11
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.094
    Posts de Blog
    15

    Padrão Re: instalar mk-auth em maquina virtual para aviso e bloqueio no pppoe pode?

    Ok.

  12. #12

    Padrão Re: instalar mk-auth em maquina virtual para aviso e bloqueio no pppoe pode?

    interhome, eu agradeço muito a sua ajuda cara.porém para crescimento do forum e ajudar nao só a mim, você poderia até postar as regras aqui mesmo no forum. pois sei que é dúvida de muitos...



  13. #13

    Padrão Re: instalar mk-auth em maquina virtual para aviso e bloqueio no pppoe pode?

    aê galera.. ja tenho meu servidor apache rodando.. afim de teste, instalei ele no meu pc, através do programa easyphp. fiz toda a configuração. e ja consigo acessar essa pagina de bloqueio de fora da rede. e agora como faço para rodar o script para bloquear os clientes em pppoe???

    servidor apache pronto, redirecionar pagina bloqueio cliente pppoe.


    http://177.42.228.186:81


    preciso criar um host no no-ip, ou o próprio script que vai rodar já faz essa atualização de IP publico?

  14. #14

    Padrão Re: instalar mk-auth em maquina virtual para aviso e bloqueio no pppoe pode?

    Buenas @ruanserver

    Você usa Radius para autenticar? Ou cadastra os profiles e secrets (usuários) direto na RB?

    Uma coisa que você deve levar em consideração também é que esse aviso só vai aparecer quando o cliente tentar acessar um site HTTP. Se ele tentar acessar um site HTTPS, não vai funcionar, a não ser que você configure o apache para trabalhar em HTTPS também; mas mesmo neste caso, o redirecionamento do HTTPS vai gerar um aviso de segurança no browser. Eu não consigo pensar em qualquer forma de prevenir isso além de setar um servidor DNS e fazer ele responder requisições para qualquer nome a um IP em específico (o seu apache nesse caso), mas se torna uma solução bem complexa dai.

    Mas só no HTTP da tranquilo.



  15. #15

    Padrão Re: instalar mk-auth em maquina virtual para aviso e bloqueio no pppoe pode?

    entao inquiery, como eu faço isso???? eu cadastro os usuarios direto na rb em secrets... eu nao uso mk auth.. minha forma de autenticação é pppoe. a única coisa que eu quero é mandar para os clientes pagina de aviso, bloqueio e anuncios, somente...


    aproveitar fazer com que o cliente abra uma pagina especifica minha antes de começar a navegar.

  16. #16

    Padrão Re: instalar mk-auth em maquina virtual para aviso e bloqueio no pppoe pode?

    Não, dai já é bem mais complexo. Só com scripts.

    Bloquear um cliente e redirecionar ele para uma pagina, tranquilo. Anúncios já é outro coisa bem diferente, tem que interferir na tráfego dos HTML e injetar código. Com PPPoE acredito que não tenha como fazer no mikrotik.

    A questão de aparecer um aviso antes de ele começar a navegar, depois de logar, até dá, mas vai ter que usar scripts, dai te indico 2 caminhos: estudar e fazer ou contratar um consultor pra fazer pra você.

    Agora, se você quer só uma pagina de bloqueio, cria um profile lá, chama ele de PERFIL_BLOQUEIO por exemplo, e no campo "Address List" do profile, coloca lá assim "CLIENTE_BLOQUEADO".

    coloca essas regras no firewall:

    Código :
    /ip firewall nat chain=dstnat src-address-list=CLIENTE_BLOQUEADO protocol=tcp dst-port=80 action=dst-nat to-address=IP_DO_APACHE to-port=PORTA_DO_APACHE
    /ip firewall filter add chain=forward src-address-list=CLIENTE_BLOQUEADO protocol=!tcp action=drop
    /ip firewall filter add chain=forward src-address-list=CLIENTE_BLOQUEADO protocol=tcp dst-port=!80 action=drop

    Assim, o cliente que você quiser que aparece a tela de bloqueio, você muda o profile dele para esse "PERFIL_BLOQUEIO". Todo o trafego HTTP dele (porta TCP 80) vai ser direcionado pro Apache, aparecendo a sua mensagem lá. E qualquer outro tipo de trafego vai ser bloqueado.

    Se seu servidor DNS é externo (e não a RB), acredito que requisições DNS vão ser bloqueadas pois vão passar pelo forward e cair num drop daqueles. Dai vai ter que criar uma regra liberando o DNS, antes das regras de drop.

    Código :
    /ip firewall filter add chain=forward in-interface=ETHER_CLIENTES protocol=udp dst-port=53 action=accept



  17. #17

    Padrão Re: instalar mk-auth em maquina virtual para aviso e bloqueio no pppoe pode?

    muito obrigado irmao,,, vai ser somente para bloqueio mesmo.

  18. #18

    Padrão Re: instalar mk-auth em maquina virtual para aviso e bloqueio no pppoe pode?

    ééé, nao sei aonde estou errando, tentei aqui e nao funcionou.

    instalei o easyphp no meu próprio pc. meu cenario aqui é o seguinte:

    modem bridge
    rb discando pppoe
    uso a mesma interface para autenticar hotspot e pppoe
    pppoe faixa de ip 192.168.77.1/24
    tenho um roteador discando meu usuario pppoe que no caso meu ip loca fica 192.168.1.100
    utilizo o dns do google e um da gvt


    o que fiz: coloquei as regras no firewal e no filter rules citadas acima, porém nao funcionou. detalhe, meu ip publico vindo da gvt, ja está resolvido para meu ddns computador.no-ip.info



  19. #19

    Padrão Re: instalar mk-auth em maquina virtual para aviso e bloqueio no pppoe pode?

    Dando uma liga ali vi que eu errei o primeiro comando, para adicionar uma regra de nat, faltou o "add", você chegou a arrumar?

    Se você adicionou a regra pelo winbox, tranquilo, se tentou pelo terminal, a regra não foi adicionada. A primeira linha ficaria assim:

    Código :
    /ip firewall nat add chain=dstnat src-address-list=CLIENTE_BLOQUEADO protocol=tcp dst-port=80 action=dst-nat to-address=IP_DO_APACHE to-port=PORTA_DO_APACHE


    Outra coisa é que se você ja tem regras de filtro e/ou nat adicionadas que podem interferir nesse redirecionamento, vc tem que ajeitar, reconfigurar direitinho.
    Última edição por ab5x2; 23-06-2015 às 09:43.

  20. #20

    Padrão Re: instalar mk-auth em maquina virtual para aviso e bloqueio no pppoe pode?

    Não tenho regras nenhuma adicionadas por mim... A única coisa que fiz foi abrir duas portas no firewall.. Vou abrir agora a 81 para meu IP... Para funcionar esse bloqueio popoe