Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Desconectar cliente em horário específico Mikrotik Ver 6.27

    Alguém poderia me informar como faço para agendar a desconexão de alguns clientes todas as noites em horário especifico?
    Aqui uso hotspot mas todos em bypassed,ou seja,somente IP amarrado ao MAC com senha na wireless.
    Os clientes usam a interface wireless.
    Já tentei algumas dicas que encontrei,mas nenhuma funcionou nessa versão do Mikrotik.
    Gostaria somente que a conexão deles fossem desfeita todos os dias às 23h00 e retornassem às 08h00.
    Agradeço.

  2. #2

    Padrão Re: Desconectar cliente em horário específico Mikrotik Ver 6.27

    Ola, deve ter alguma solução mais elegante a qual vou falar, mas não uso hotspot então não posso verificar agora.
    mas se sua intenção for desativar todos os clientes de uma só vez em um horário especifico, cria uma scheduler e desativa a interface a qual eles estão conectados.



  3. #3

    Padrão

    Citação Postado originalmente por berghetti Ver Post
    Ola, deve ter alguma solução mais elegante a qual vou falar, mas não uso hotspot então não posso verificar agora.
    mas se sua intenção for desativar todos os clientes de uma só vez em um horário especifico, cria uma scheduler e desativa a interface a qual eles estão conectados.
    São somente alguns clientes e não todos amigo.

  4. #4
    Avatar de dpetry
    Ingresso
    Jun 2015
    Localização
    Cabo frio - Rio de Janeiro
    Posts
    181

    Padrão Re: Desconectar cliente em horário específico Mikrotik Ver 6.27

    Olá, vc poderia criar um script na mikrotik e fazer um find no mac q está conectado, derrubando a conexão e adicionando-os na access-list, para que não conectem.

    Ai cria um scheduler para rodar no horário especifico.

    Na verdade seriam dois scripts, um para dar bloq na sessão wireless e outro para liberar.

    -Diogo Petry



  5. #5

    Padrão Re: Desconectar cliente em horário específico Mikrotik Ver 6.27

    Olá, visite esse link que vai te ajudar.

    http://www.cbrown.co/2011/11/05/disa...certain-hours/

  6. #6

    Padrão Re: Desconectar cliente em horário específico Mikrotik Ver 6.27

    Receita de bolo, facinho, facinho

    1° vá para "IP Bindings" e ordene a lista pelo número representado pelo simbolo " # " esse número representa a ordem que o cliente foi criado na lista, mas vc pode alterá-los bastando arrastá-los com o mouse, para cima ou para baixo.
    2° vá em "System/Scheduler" depois clique no sinal de " + " em "Start Time:" vc digita "23:00:00" em "Interval:" vc digita
    "1d 00:00:00" e em "On Event:" vc digita:

    ip hotspot ip-binding
    disable numbers=34
    disable numbers=4
    disable numbers=8

    Depois pode clicar em "ok" a regra já está criada, lembrando que as linhas são muito importantes, basicamente cada linha representa um comando, ou seja no seu caso cada linha um cliente que vai ser desabilitado.

    3° vá em "System/Scheduler" depois clique no sinal de " + " em "Start Time:" vc digita "08:00:00" em "Interval:" vc digita
    "1d 00:00:00" e em "On Event:" vc digita:

    ip hotspot ip-binding
    enable numbers=34
    enable numbers=4
    enable numbers=8

    Depois pode clicar em "ok" e a 2ª regra já está criada. Sendo que a 1ª regra desabilita todos os clientes às 23:00:00 e a 2ª habilita todos os clientes.

    Lembrando também que para a regra funcionar corretamente vc tem que ter seu mikrotik com o "ntp client" devidamente configurado.



  7. #7

    Padrão Re: Desconectar cliente em horário específico Mikrotik Ver 6.27

    Obrigado a todos pela atenção,irei testar e informo o resultado aqui.

  8. #8

    Padrão Re: Desconectar cliente em horário específico Mikrotik Ver 6.27

    Agradeço amigo @eriksonb, mas nao funcionou aqui.



  9. #9

    Padrão Re: Desconectar cliente em horário específico Mikrotik Ver 6.27

    Caro @davidmilfont, se não funcionou é pq vc não fez direito. Acabei de testar e funciona sim. Lembrando tbm que os números 34, 4 e 8 devem ser alterados conforme sua necessidade, ou seja, de acordo com sua relação no ip-binding.
    Clique na imagem para uma versão maior

Nome:	         desativa.jpg
Visualizações:	73
Tamanho: 	142,2 KB
ID:      	59781

  10. #10

    Padrão

    Veja amigo @eriksonb e me informe se existe algum erro.
    Obrigado pela atenção.

    Clique na imagem para uma versão maior

Nome:	         Sem título.jpg
Visualizações:	50
Tamanho: 	97,7 KB
ID:      	59785



  11. #11

    Padrão Re: Desconectar cliente em horário específico Mikrotik Ver 6.27

    Está correto. Só com isso é necessario

  12. #12

    Padrão Re: Desconectar cliente em horário específico Mikrotik Ver 6.27

    Citação Postado originalmente por eriksonb Ver Post
    Está correto. Só com isso é necessario
    Pois é.
    Está assim desde ontem e não desconectou os clientes.
    A sua versão é a 6 do mikrotik?



  13. #13

    Padrão Re: Desconectar cliente em horário específico Mikrotik Ver 6.27

    De um run no script e veja se desconecta.

  14. #14

    Padrão Re: Desconectar cliente em horário específico Mikrotik Ver 6.27

    Se vc acrescentou as regras ontem depois das 23:00 h elas só iram funcionar hj às 23:00 h



  15. #15

    Padrão Re: Desconectar cliente em horário específico Mikrotik Ver 6.27

    Isso mesmo @eriksonb por isso pedi pra ele da um run caso contrário não desconectar é porque o script está errado se desconectar o problema está no agendamento.

  16. #16

    Padrão Re: Desconectar cliente em horário específico Mikrotik Ver 6.27

    Percebi pelo horario dessa resposta que me mandou ontem anoite dizendo que não dava certo.



  17. #17

    Padrão Re: Desconectar cliente em horário específico Mikrotik Ver 6.27

    Citação Postado originalmente por eriksonb Ver Post
    Percebi pelo horario dessa resposta que me mandou ontem anoite dizendo que não dava certo.
    Enviei a resposta esse horário justamente após verificar que não houve a desconexão amigo,mas fiz a configuração bem antes das 23hs e pode ver em Run Count que dei um "Run" também.
    Vou continuar tentando e agradeço a atenção de todos.

  18. #18

    Padrão Re: Desconectar cliente em horário específico Mikrotik Ver 6.27

    Desativa cliente /ip arp disable [/ip arp find comment="Joao"]
    Ativa cliente /ip arp enable [/ip arp find comment="Joao"]
    Só salvar os scripts e agendar suas execuções.



  19. #19

    Padrão Re: Desconectar cliente em horário específico Mikrotik Ver 6.27

    Bom dia @davidmilfont

    Vou dar outra idéia, só para efeito de estudos de sua parte. As ideias anteriores tambem vão funcionar.

    Como você usa IP Binding, faça uma Address-list com os IPs dos usuários que você quer controlar por horário, digamos que ela se chamaria "Controoled_IPs".

    Depois disso, cria regras nos filtros do firewall para bloquear todo o trafego dos clientes nessa address list durante o tempo que você quiser, por exemplo:

    Código :
    /ip firewall filter add chain=forward src-address-list=Controlled_IPs time=23h-23h59m59s,sun,mon,tue,wed,thu,fri,sat action=drop
    /ip firewall filter add chain=forward src-address-list=Controlled_IPs time=0h-08h,sun,mon,tue,wed,thu,fri,sat action=drop

    Assim trafego inteiro de qualquer IP que está na address-list "Controlled_IPs" vai ser dropado, nos horário especificados, das 23:00:00 até as 23:59:59 e das 00:00:00 até as 08:00:00.
    Infelizmente, no mikrotik não da pra colocar algo do tipo "das 23:00:00 até as 08:00:00", ele não entende que isso significa a passagem do tempo de um dia para o outro, através da meia noite, pra ele é como se foce estivesse tentando terminar uma coisa antes de inicia-la, dai tem que ter duas regras.

  20. #20

    Padrão Re: Desconectar cliente em horário específico Mikrotik Ver 6.27

    Obrigado pela dica @inquiery.
    Funcionou perfeitamente amigo.
    Abraço.

    Obrigado também @wesleyizid.
    Última edição por davidmilfont; 25-06-2015 às 23:29.