+ Responder ao Tópico



  1. #1

    Padrão Problemas com Load Balance Mikrotik

    Olá pessoal sou novo aqui no fórum e também com o sistema Mikrotik..
    Fiz um Load Blanace com 2 ADSL de 10Mb.. Tudo funcionando 100%... porém o Balance não responde ping's da rede local, e também não consigo acessar remotamente, mesmo umas das ADSL's serem de Ip fixo....

    Alguém poderia dar uma luz ?

  2. #2

    Padrão Re: Problemas com Load Balance Mikrotik

    Como assim não responde ping da rede local? Sobre acesso externo você tem que fazer uma regra para o pacote que entrar por um link sair pelo mesmo link.



  3. #3

    Padrão Re: Problemas com Load Balance Mikrotik

    Quando tento dar ping de qualquer computador da rede local para o Gateway do Balance ... Simplesmente não ha resposta...

  4. #4

    Padrão Re: Problemas com Load Balance Mikrotik

    Posta suas regras



  5. #5

    Padrão Re: Problemas com Load Balance Mikrotik

    Quando você da um ping para a sua rede local, provavelmente o pacote do ping está passando pelo mangle e sendo marcado para uma tabela de roteamento. Essa tabela de roteamento, por sua vez, não tem rotas para a sua própria rede local, mas provavelmente somente uma rota padrão para o seu gateway de internet.

    Nas suas regras de mangle, você tem que tomar cuidado para não marcar pacotes que devem ser roteados pela tabela de roteamento principal. Se você tem apenas uma subrede, digamos 192.168.0.0/24, basta que nas regras de mangle, você de um jeito de não marcar quando o destino for 192.168.0.0/24. Se você tem várias subredes, cria uma address list e usa ele nas regras para não marcar quando o destino for um endereço dessa address list.

  6. #6

    Padrão Re: Problemas com Load Balance Mikrotik

    Segue as Regras Berghetti;

    ip firewall mangle
    add action=mark-connection chain=prerouting in-interface=ether5 \
    new-connection-mark=link1_conn per-connection-classifier=\
    both-addresses:2/0
    add action=mark-connection chain=prerouting in-interface=ether5 \
    new-connection-mark=link2_conn per-connection-classifier=\
    both-addresses:2/1
    add action=mark-routing chain=prerouting connection-mark=link1_conn \
    in-interface=ether5 new-routing-mark=link1_routing
    add action=mark-routing chain=prerouting connection-mark=link2_conn \
    in-interface=ether5 new-routing-mark=link2_routing
    add action=mark-connection chain=prerouting in-interface=pppoe-out1 \
    new-connection-mark=link1Down_conn
    add action=mark-connection chain=prerouting in-interface=pppoe-out2 \
    new-connection-mark=link2Down_conn
    add action=mark-connection chain=prerouting in-interface=ether5 \
    new-connection-mark=Up_conn
    add action=mark-packet chain=prerouting connection-mark=link1Down_conn \
    new-packet-mark=down_1_packet
    add action=mark-packet chain=prerouting connection-mark=link2Down_conn \
    new-packet-mark=down_2_packet
    add action=mark-packet chain=prerouting connection-mark=Up_conn \
    new-packet-mark=Up_packet
    add action=mark-packet chain=prerouting connection-bytes=5242880-41943040 \
    new-packet-mark=TrafegoMedio_conn protocol=tcp
    add action=mark-packet chain=prerouting connection-bytes=0-5242880 \
    new-packet-mark=TrafegoLeve_conn protocol=tcp
    add action=mark-packet chain=prerouting connection-bytes=41943040-734003200 \
    new-packet-mark=TrafegoMedio2_conn protocol=tcp
    add action=mark-packet chain=prerouting connection-bytes=734003200-3221225472 \
    new-packet-mark=TrafegoPesado_conn protocol=tcp
    /ip firewall nat
    add action=masquerade chain=srcnat
    add action=dst-nat chain=dstnat in-interface=pppoe-out1 protocol=tcp \
    to-addresses=172.16.10.8 to-ports=9622
    add action=dst-nat chain=dstnat in-interface=pppoe-out1 protocol=tcp \
    to-addresses=172.16.10.8 to-ports=8829

    /ip route
    add distance=1 gateway=pppoe-out1 routing-mark=link1_routing
    add distance=1 gateway=pppoe-out2 routing-mark=link2_routing

    /queue tree
    add max-limit=20M name=Download packet-mark=down_1_packet,down_2_packet \
    parent=global priority=1 queue=default
    add max-limit=1M name=Up packet-mark=Up_packet parent=global priority=1 \
    queue=default
    add name=TrafegoLeve packet-mark=TrafegoLeve_conn parent=Download priority=1 \
    queue=default
    add name=TrafegoMedio packet-mark=TrafegoMedio_conn parent=Download priority=\
    2 queue=default
    add name=TrafegoMedio2 packet-mark=TrafegoMedio2_conn parent=Download \
    priority=3 queue=default
    add name=TrafegoPesado packet-mark=TrafegoPesado_conn parent=Download queue=\
    default



  7. #7

    Padrão Re: Problemas com Load Balance Mikrotik

    Segue as regras Berghetti, tenho um balance com QoS;

    /ip firewall mangle
    add action=mark-connection chain=prerouting in-interface=ether5 \
    new-connection-mark=link1_conn per-connection-classifier=\
    both-addresses:2/0
    add action=mark-connection chain=prerouting in-interface=ether5 \
    new-connection-mark=link2_conn per-connection-classifier=\
    both-addresses:2/1
    add action=mark-routing chain=prerouting connection-mark=link1_conn \
    in-interface=ether5 new-routing-mark=link1_routing
    add action=mark-routing chain=prerouting connection-mark=link2_conn \
    in-interface=ether5 new-routing-mark=link2_routing
    add action=mark-connection chain=prerouting in-interface=pppoe-out1 \
    new-connection-mark=link1Down_conn
    add action=mark-connection chain=prerouting in-interface=pppoe-out2 \
    new-connection-mark=link2Down_conn
    add action=mark-connection chain=prerouting in-interface=ether5 \
    new-connection-mark=Up_conn
    add action=mark-packet chain=prerouting connection-mark=link1Down_conn \
    new-packet-mark=down_1_packet
    add action=mark-packet chain=prerouting connection-mark=link2Down_conn \
    new-packet-mark=down_2_packet
    add action=mark-packet chain=prerouting connection-mark=Up_conn \
    new-packet-mark=Up_packet
    add action=mark-packet chain=prerouting connection-bytes=5242880-41943040 \
    new-packet-mark=TrafegoMedio_conn protocol=tcp
    add action=mark-packet chain=prerouting connection-bytes=0-5242880 \
    new-packet-mark=TrafegoLeve_conn protocol=tcp
    add action=mark-packet chain=prerouting connection-bytes=41943040-734003200 \
    new-packet-mark=TrafegoMedio2_conn protocol=tcp
    add action=mark-packet chain=prerouting connection-bytes=734003200-3221225472 \
    new-packet-mark=TrafegoPesado_conn protocol=tcp
    /ip firewall nat
    add action=masquerade chain=srcnat
    add action=dst-nat chain=dstnat in-interface=pppoe-out1 protocol=tcp \
    to-addresses=172.16.10.8 to-ports=9622
    add action=dst-nat chain=dstnat in-interface=pppoe-out1 protocol=tcp \
    to-addresses=172.16.10.8 to-ports=8829

    /ip route
    add distance=1 gateway=pppoe-out1 routing-mark=link1_routing
    add distance=1 gateway=pppoe-out2 routing-mark=link2_routing

    /queue tree
    add max-limit=20M name=Download packet-mark=down_1_packet,down_2_packet \
    parent=global priority=1 queue=default
    add max-limit=1M name=Up packet-mark=Up_packet parent=global priority=1 \
    queue=default
    add name=TrafegoLeve packet-mark=TrafegoLeve_conn parent=Download priority=1 \
    queue=default
    add name=TrafegoMedio packet-mark=TrafegoMedio_conn parent=Download priority=\
    2 queue=default
    add name=TrafegoMedio2 packet-mark=TrafegoMedio2_conn parent=Download \
    priority=3 queue=default
    add name=TrafegoPesado packet-mark=TrafegoPesado_conn parent=Download queue=\
    default

  8. #8

    Padrão Re: Problemas com Load Balance Mikrotik

    Obrigado pela dica inquiery, mais como disse sou novato, rsrsrsrs... onde e como seria feita essa marcação para não marcar quando o destino for o Gateway???



  9. #9

    Padrão Re: Problemas com Load Balance Mikrotik

    você usa uma RB para fazer o balanceamento e a distribuição interna, ou usa duas RB, uma para balance outra para distribuir para a rede?
    Código :
     ip firewall mangle add action=accept chain=prerouting disabled=no src-address=COLOQUE A FAIXA DE IP DA SUA REDE
    tenta coloca essa regra no topo do mangle.

  10. #10

    Padrão Re: Problemas com Load Balance Mikrotik

    Uso uma Rb para balanceamento e distribuição interna através de DHCP...
    Então cara coloquei essa regra e permanece sem resposta... o estranho é que quando desativo as rotas das ADSL a RB volta a responder os ping's... Segue o print como fica com as rotas ativas e com ela desativadas, e gateway é esse mesmo 172.16.10.5.

    Clique na imagem para uma versão maior

Nome:	         com rota.png
Visualizações:	44
Tamanho: 	87,1 KB
ID:      	59940Clique na imagem para uma versão maior

Nome:	         sem rotas.png
Visualizações:	29
Tamanho: 	95,8 KB
ID:      	59941



  11. #11

    Padrão Re: Problemas com Load Balance Mikrotik

    Pessoal, a forma como estava sendo feita a marcação das rotas e conexões estavam erradas...