Página 1 de 3 123 ÚltimoÚltimo
+ Responder ao Tópico



  1. Boa noite pessoal!


    Tenho um probleminha aqui que me incomoda há um tempo. Tenho um DDNS que funciona muito bem, mas com ele, só consigo acessar externamente a RB do Load balance.


    Esquematizando, minha rede é assim:
    Link em bridge 1 \
    Link em bridge 2 - >> Load Balance (RB 750 192.168.88.1/30) >> Central (RB 450 g 192.168.88.2) >> Omntik e outras transmissoras.
    Link em bridge 3 /


    Acessando de fora, por outra internet eu consigo acessar somente ao load balance, seja pelo Mikro Winbox pro (celular), WINBOX ou pelo navegador www.. Não sei o porque, já tentei de tudo, as regras lá estão como encontrei na net... Mas não funciona.


    Detalhe, se eu tiver conectado a minha rede e usar um ddns com as determinadas portas para acessar, eu consigo entrar em qualquer RB dentro da minha rede (usando o ddns mesmo ou ip). Porque será?




    Segue as regras que coloquei aqui


    No Load Balance tem:


    Código :
    /ip firewal add action=dst-nat chain=dstnat comment=\
        "////////// Acesso RB Central - WINBOX" dst-port=1001 protocol=tcp \
        to-addresses=192.168.88.2 to-ports=1001


    Na "Central" tem:
    Código :
    /ip firewal add action=dst-nat chain=dstnat comment=\
        "////////// Acesso RB Central - WINBOX" dst-port=1001 protocol=tcp \
        to-addresses=192.168.88.2 to-ports=8291


    Detalhe, utilizo bem mais a porta do API para acessar pelo celular (Tenho outra regra similar a de cima para a porta do API), mas só consigo entrar no LOAD BALANCE, quer seja em qualquer lugar, principalmente na faculdade.


    Habilitei os Logs da regra nat e fica aparecendo essa mensagem aqui nos logs toda vez que tento entrar, nas duas RB's, vejam nas imagens anexadas, uma é o que aparece no balance e a outra na central. (lembrando que nesse exemplo das imagens, tentava acessar pelo API do celular.
    Clique na imagem para uma versão maior

Nome:	         1. Erro ao acessar - Loa Balance.PNG
Visualizações:	76
Tamanho: 	14,9 KB
ID:      	59919Clique na imagem para uma versão maior

Nome:	         2. Erro ao acessar - central.PNG
Visualizações:	63
Tamanho: 	14,0 KB
ID:      	59920
    Utilizo o webmikrotik, quando preciso que eles acessem minha rb Central (servidor), não conseguem também, só por telmac.

    Excluir várias regras que tinha, mesmo assim não funciona...

    O que é esse Len 60 que aparece no log? e pq depois de pppoe out 1 aparece isso: (none)?? será que falta algo nas regras?

    Aguardo e prontamente já agradeço o espaço.

  2. Tentei aqui Arthur, mas não dá certo mesmo.
    Estranho é que aparece nos logs tanto do Load quanto o da Central uma tentativa de acesso, mas não loga. É como se houvesse alguma espécie de bloqueio por conexões externas, mas não acho nada aqui.

    Será que tenho que marcar alguma conexão de saída ou sei lá?

    Há alguma oção no mikrotik que faz bloqueio de acessos externos?

    O que será que estou fazendo de errado, hein? Lembrando que se eu tiver conectado pelo wifi na rede e usar o DDNS eu consigo acesso. É como se o acesso fosse permitido somente por dentro da RB central.... (já que meu roteador wifi está conectado lá por PPOE e também usando wifi de algum cliente eu consigo acesso pelo link do DDNS também). Ou seja, só de dentro da rede.



  3. A primeira regra que você postou você redireciona a porta 1001 para o IP da "RB Central", porém para a mesma porta 1001. Depois você tem outra regra na "RB Central" com dstnat da porta 1001 para 8291. Porque você não deleta essa regra da RB Central e redireciona a porta 1001 na entrada do Load Balance para a porta 8291 da RB Central diretamente?

    Posta o resultado do comando:

    Código :
    /ip firewall mangle print

    Da RB do Load Balance.

  4. Bom dia!

    Obrigado pela resposta! Fiz o que você falou, mudei a porta do dst-nat e apaguei a regra na rb "central", mas mesmo assim não obtive êxito.

    Tô fazendo os testes pela porta API (acesso pelo celular), pois assim ponho no 3g e testo o acesso (Fiz as mesmas regras do winbox para a porta API também). Não funcionou ainda. Detalhe, como eu disse, se eu ligar o wifi do celular e acessar peo DDNS funciona direitinho, mas quando desligo o wifi e tento acessar pelo 3g, não dá. Já o load balance não estou tendo problema algum.

    Seguem as regras que estão no Mangle do balance:

    Código :
     /ip firewall mangle printFlags: X - disabled, I - invalid, D - dynamic 
     0    chain=prerouting action=accept protocol=tcp dst-port=8291 log=no 
          log-prefix="" 
     
     
     1    ;;; 1 - Primeira fase
          chain=prerouting action=accept src-address=192.168.88.0/30 
          dst-address=192.168.88.0/30 log=no log-prefix="" 
     
     
     2    ;;; 2 Marcar conex es - Link 15 MB
          chain=prerouting action=mark-connection new-connection-mark=conn1 
          passthrough=yes in-interface=pppoe-out1 connection-mark=no-mark log=no 
          log-prefix="" 
     
     
     3    ;;; *********Link 5 MB
          chain=prerouting action=accept src-address=192.168.88.0/30 
          dst-address=10.0.20.0/24 log=no log-prefix="" 
     
     
     4    ;;; 2 Marcar conex es - Link 5 MB
          chain=prerouting action=mark-connection new-connection-mark=conn3 
          passthrough=yes in-interface=Link do Preto  connection-mark=no-mark 
          log=no log-prefix="" 
     
     
     5    ;;; 2 Marcar conex es - Link 10 MB
          chain=prerouting action=mark-connection new-connection-mark=conn2 
          passthrough=yes in-interface=pppoe-out2 connection-mark=no-mark log=no 
          log-prefix="" 
     
     
     6    ;;; 3 - Policy_Router
          chain=prerouting action=jump jump-target=policy_router 
          in-interface=Balance Out connection-mark=no-mark log=no log-prefix="" 
     
     
     7    ;;; 4 - Trafic 15 MB
          chain=prerouting action=mark-routing new-routing-mark=link1_trafic 
          passthrough=yes src-address=192.168.88.0/30 connection-mark=conn1 
          log=no log-prefix="" 
     
     
     8    ;;; 4 - Trafic Link do link 5 MB
          chain=prerouting action=mark-routing new-routing-mark=link3_trafic 
          passthrough=yes src-address=192.168.88.0/30 connection-mark=conn3 
          log=no log-prefix="" 
     
     
     9    ;;; 4 - Trafic 10 MB
          chain=prerouting action=mark-routing new-routing-mark=link2_trafic 
          passthrough=yes src-address=192.168.88.0/30 connection-mark=conn2 
          log=no log-prefix="" 
     
     
    10    ;;; 5 - Marcar Rotas 15 MB
          chain=output action=mark-routing new-routing-mark=link1_trafic 
          passthrough=yes connection-mark=conn1 log=no log-prefix="" 
     
     
    11    ;;; Marcar Rotas Link  5 MB
          chain=output action=mark-routing new-routing-mark=link3_trafic 
          passthrough=yes connection-mark=conn3 log=no log-prefix="" 
     
     
    12    ;;; Marcar Rotas 10 MB
          chain=output action=mark-routing new-routing-mark=link2_trafic 
          passthrough=yes connection-mark=conn2 log=no log-prefix="" 
     
     
    13    ;;; Link 15 MB
          chain=policy_router action=mark-connection new-connection-mark=conn1 
          passthrough=yes dst-address-type=!local 
          per-connection-classifier=both-addresses:6/0 log=no log-prefix="" 
     
     
    14    chain=policy_router action=mark-connection new-connection-mark=conn1 
          passthrough=yes dst-address-type=!local 
          per-connection-classifier=both-addresses:6/1 log=no log-prefix="" 
     
     
    15    chain=policy_router action=mark-connection new-connection-mark=conn1 
          passthrough=yes dst-address-type=!local 
          per-connection-classifier=both-addresses:6/2 log=no log-prefix="" 
     
     
    16    ;;; Link 5 MB 
          chain=policy_router action=mark-connection new-connection-mark=conn3 
          passthrough=yes dst-address-type=!local 
          per-connection-classifier=both-addresses:6/5 log=no log-prefix="" 
     
     
    17    ;;; Link 10 MB
          chain=policy_router action=mark-connection new-connection-mark=conn2 
          passthrough=yes dst-address-type=!local 
          per-connection-classifier=both-addresses:6/3 log=no log-prefix="" 
     
     
    18    chain=policy_router action=mark-connection new-connection-mark=conn2 
          passthrough=yes dst-address-type=!local 
          per-connection-classifier=both-addresses:6/4 log=no log-prefix=""

    Quer que eu envie as que estão no mangle da "rb central" também?



  5. Você faz o mascaramento na RB Balance ou na RB Central?






Tópicos Similares

  1. Respostas: 4
    Último Post: 13-12-2017, 15:10
  2. VPN depois do Load Balance PCC é possivel?
    Por claudinhohw no fórum Servidores de Rede
    Respostas: 1
    Último Post: 16-11-2013, 10:23
  3. Site não abre depois do load ballance
    Por AlefSS no fórum Redes
    Respostas: 13
    Último Post: 29-07-2013, 15:24
  4. Respostas: 11
    Último Post: 06-11-2011, 21:47
  5. Respostas: 1
    Último Post: 05-06-2008, 22:34

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L