+ Responder ao Tópico



  1. #1

    Unhappy Rb 750 DDNS Via ADSL Velox nao autentica o DDNS

    Pessoal ja olhei milhares de topicos e videos e nao conseguir resolver a conexao remota da minha RB, atualmente ela esta discando o PPPOE pro modem adsl que esta em bridged, e a RB esta recebendo o IP externo, eu consigo acessar a pagina ddns pela rede local mais por outra rede nao consigo acesso... meu script.

    # No-IP User account info
    :local noipuser "[email protected]"
    :local noippass "******"


    # Set the hostname or label of network to be updated.
    # Hostnames with spaces are unsupported. Replace the value in the quotations below with your host names.
    # To specify multiple hosts, separate them with commas.
    :local noiphost "testando.zapto.org"


    # Change to the name of interface that gets the dynamic IP address
    :local inetinterface "2 - Velox"


    #------------------------------------------------------------------------------------
    # No more changes need


    :global previousIP


    # get the current IP address from the internet (in case of double-nat)
    /tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
    :local result [/file get dyndns.checkip.html contents]


    # parse the current IP result
    :local resultLen [:len $result]
    :local startLoc [:find $result ": " -1]
    :set startLoc ($startLoc + 2)
    :local endLoc [:find $result "</body>" -1]
    :local currentIP [pick $result $startLoc $endLoc]
    # :log info "UpdateDynDNS: currentIP = $currentIP"


    :if ($currentIP != $previousIP) do={
    :log info "No-IP: Current IP $currentIP is not equal to previous IP, update needed"
    :set previousIP $currentIP


    # The update URL. Note the "\3F" is hex for question mark (?). Required since ? is a special character in commands.
    :local url "http://dynupdate.no-ip.com/nic/update\3Fmyip=$currentIP"
    :local noiphostarray
    :set noiphostarray [:toarray $noiphost]
    :foreach host in=$noiphostarray do={
    :log info "No-IP: Sending update for $host"
    /tool fetch url=($url . "&hostname=$host") user=$noipuser password=$noippass mode=http dst-path=("no-ip_ddns_update-" . $host . ".txt")
    :log info "No-IP: Host $host updated on No-IP with IP $currentIP"
    }
    } else={
    :log info "No-IP: Previous IP $previousIP is equal to current IP, no update needed"
    }
    } else={
    :log info "No-IP: $inetinterface is not currently running, so therefore will not update."
    }




    Eu consigo acesso na minha propria rede pelo endereço ddns porem externo não dá,, alguem pode me ajudar...


    no log esta assim:


    https://under-linux.org/attachment.p...810497&thumb=1


    Uso modem ADSL e está em bridged, a RB esta discando e recebendo o IP externo....

    por favor se alguem ajudar agradeço!!!

  2. #2

    Ingresso
    Oct 2014
    Localização
    MS
    Posts
    697
    Posts de Blog
    1

    Padrão Re: Rb 750 DDNS Via ADSL Velox nao autentica o DDNS

    Você testou direto pelo IP se tem acesso externo?

  3. #3

    Padrão Re: Rb 750 DDNS Via ADSL Velox nao autentica o DDNS

    Jovem, nas versões recente tipo 6.23 já contamos com o Cloud ou DDNs da Mikrotik, marca a caixa, aplica, OK.
    Depois só anotar o endereço!

  4. #4

    Padrão Re: Rb 750 DDNS Via ADSL Velox nao autentica o DDNS

    Citação Postado originalmente por RobsonCostta Ver Post
    Jovem, nas versões recente tipo 6.23 já contamos com o Cloud ou DDNs da Mikrotik, marca a caixa, aplica, OK.
    Depois só anotar o endereço!
    Isso ai , a dica Robson é a o modo mais pratico !

  5. #5

    Padrão Re: Rb 750 DDNS Via ADSL Velox nao autentica o DDNS

    Eu uso assim e funciona!

    Código :
    :global ddnsuser "usuario"
    :global ddnspass "senha"
    :global ddnshost "xxxxx.changeip.net"
    :global ifaceddns "intarface PPPoE"
    :global lastddnsip
    :global lastgat
     
     
     
     
    ##################################################################################
     
     
     
     
    :if ([:len [/interface find name=$ifaceddns]] = 0 ) do={ :log info "DDNS: Interface $ifaceddns nao encontrada, verifique."} else={
     
     
     
     
    :global ifaceip [/ip address get [find interface=$ifaceddns] address]
    :global ddnsip $ifaceip
     
     
     
     
    :if ([ :typeof $ddnsip ] = "nothing" ) do={
    :log info ("DDNS: Sem IP na interface " . $ifaceddns . ", verifique.")
    } else={
    :if ($ddnsip != $lastddnsip) do={
    :log info "DDNS: Setando gateway para $ifaceddns"
    :put [/ip route set [ find comment="CHANGEIP" ] gateway=$ifaceddns]
    :log info "DDNS: Atualizando, aguarde..."
    :log info [ :put [/tool dns-update name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ]
    :global lastddnsip $ddnsip
    } else={ 
    :log info "DDNS: Sem modificacao."
    }
    }
     
     
     
     
    }
    Última edição por Anderson28; 15-07-2015 às 13:08. Razão: Correção