+ Responder ao Tópico



  1. #1

    Padrão Mikrotik - Ativar e desativar Hotspot por horário

    Prezados, boa tarde!

    Tenho um Mikrotik RB750, estou querendo uma ajuda para ativar e desativar o Hotspot em determinados horários automaticamente.

    Ex: Durante o fds , por 3 horas eu não quero que o hotspot esteja ativado. Poderia fazer isso manualmente, mas minha dúvida é: Consigo um escript pra ligar e desligar o Hotspot nos dias e horários programados?

    Abraços
    Marcos

  2. #2

    Padrão Re: Mikrotik - Ativar e desativar Hotspot por horário

    Buenas @marcosg

    Sim, poderia ser por script.

    Mas, você também poderia simplesmente criar uma regra de filtro para dar drop no trafego do range de IPs do hotspot nos horários que você não quer que funcione.

    Não serve?



  3. #3
    Avatar de dpetry
    Ingresso
    Jun 2015
    Localização
    Cabo frio - Rio de Janeiro
    Posts
    181

    Padrão Re: Mikrotik - Ativar e desativar Hotspot por horário

    @marcosg

    Cria um script desativando e ativando e escolha os horários para rodar no scheduler.


    --
    Dpetry

  4. #4

    Padrão Re: Mikrotik - Ativar e desativar Hotspot por horário

    Inquiery, obrigado!
    Mas na verdade eu fiz a pergunta de forma errada. O padrão é sem hotspot é apenas por algumas horas em determinados dias que vou ativá-lo.

    Acho que a ideia do dpetry vai funcionar melhor.
    Dpetry, poderia me dar um exemplo desse script?

    Estou aprendendo ainda nesse equipamento. Qual o comando para o hotspot ficar on/ off

    Agradeço a ajuda.

    Abraços
    Marcos



  5. #5
    Avatar de dpetry
    Ingresso
    Jun 2015
    Localização
    Cabo frio - Rio de Janeiro
    Posts
    181

    Padrão Re: Mikrotik - Ativar e desativar Hotspot por horário

    @marcosg,

    Segue abaixo os scripts e os scheduler's, que você precisa para habilitar e desabilitar seu hotspot:

    Scripts:
    (HABILITA HOTSPOT)

    /system script add name=habilitar_hotspot source=": foreach i in=[/ip hotspot find] do={/ip hotspot enable \$i}"

    (DESABILITA HOTSPOT)

    /system script add name=habilitar_hotspot source=": foreach i in=[/ip hotspot find] do={/ip hotspot disable \$i}"

    (PROGRAMAÇÂO PARA HABILITAR HOTSPOT)

    /system scheduler add interval=1d name="Habilitar Hotspot" on-event=habilitar_hotspot policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive start-date=jan/10/1970 start-time=17:03:00

    (PROGRAMAÇÂO PARA DESABILITAR HOTSPOT)

    /system scheduler add interval=1d name="Desabilitar Hotspot" on-event=desabilitar_hotspot policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive start-date=jan/10/1970 start-time=17:06:00


    No scheduler vc terá que efetuar algumas mudanças:

    Start-time = Horário que você quer que o script rode.
    Start-date = Dia que vc quer que o script comece a rodar


    No interval do scheduler eu coloquei 1d, pois será o intervalo que você mencionou que acontecerá as ativações e desativações.

    Configure um servidor de NTP na sua mk, para que a data e hora fique sempre atualizada.


    Qualquer duvida estamos aii!!

    --
    Dpetry!

  6. #6

    Padrão Re: Mikrotik - Ativar e desativar Hotspot por horário

    Muito bom!
    Obrigado mesmo!

    Vou testar e posto os resultado

    Abraços
    Marcos



  7. #7
    Avatar de dpetry
    Ingresso
    Jun 2015
    Localização
    Cabo frio - Rio de Janeiro
    Posts
    181

    Padrão Re: Mikrotik - Ativar e desativar Hotspot por horário

    Okay, Abraços!!

  8. #8

    Padrão Re: Mikrotik - Ativar e desativar Hotspot por horário

    Já testei e funcionou na boa!

    Só corrigi o script para desabilitar.

    Valew mesmo!

    Essa regra com scripts é padrão para qualquer função que queremos habilitar e desabilitar?

    Abracos
    Marcos



  9. #9
    Avatar de dpetry
    Ingresso
    Jun 2015
    Localização
    Cabo frio - Rio de Janeiro
    Posts
    181

    Padrão Re: Mikrotik - Ativar e desativar Hotspot por horário

    @marcosg,

    Mais ou menos...


    Tipo se vc quiser desabilitar todos os pppoe-server da sua mk o script seria:


    /system script add name=desabilitar_hotspot source=": foreach i in=[/interface pppoe-server server find] do={//interface pppoe-server server disable \$i}"


    Ele faz a procura se existe algum e desabilita todos que existirem.

    --
    Dpetry!