+ Responder ao Tópico



  1. #1

    Padrão Bloqueio de palavras dentro do Site - Mikrotik

    Pessoal, alguém sabe alguma regra no mikrotik ou squid que eu consiga bloquear palavras dentro de sites? Por exemplo, preciso bloquear todas as palavras "sexo" dentro de qualquer site que for acessado.
    Obs: Não quero bloquear a URL, somente a palavra dentro do site...

    Fico no aguardo,

    Valew...

  2. #2

    Padrão Re: Bloqueio de palavras dentro do Site - Mikrotik

    Amigo pesquisa regex por layer 7 creio que funcione.



  3. #3
    Avatar de dpetry
    Ingresso
    Jun 2015
    Localização
    Cabo frio - Rio de Janeiro
    Posts
    181

    Padrão Re: Bloqueio de palavras dentro do Site - Mikrotik

    @fredericoafd

    Cria uma Address Lists com a faixa que vc quer bloquear :

    /ip firewall address-list
    add address=192.168.0.1/24 disabled=no list=FAIXA_IP

    *(Se forem ip's diferentes, é só ir adicionando os ip's e colocando com o mesmo nome)

    Crie uma regra no Layer7 da mikrotik:

    /ip firewall layer7-protocol
    add name=SEXO regexp="^.+(sexo).*\$"

    *(vai adicionando outras com palavras diferentes)


    e Cria uma regra no firewall filter:

    /ip firewall filter
    add action=reject chain=forward comment="BLOQUEIA SITES" disabled=no layer7-protocol=SEXO protocol=tcp reject-with=tcp-reset src-address-list=FAIXA_IP


    Espero ter ajudado.

    --
    Dpetry!

  4. #4

    Padrão Re: Bloqueio de palavras dentro do Site - Mikrotik

    olá dpetry, fico agradecido pela resposta... mas o que eu gostaria era de bloquear apenas as palavras do site e não todo o site, por exemplo... Onde tiver a palavra "sexo", o site não carrega. obrigado.



  5. #5
    Avatar de dpetry
    Ingresso
    Jun 2015
    Localização
    Cabo frio - Rio de Janeiro
    Posts
    181

    Padrão Re: Bloqueio de palavras dentro do Site - Mikrotik

    @fredericoafd

    Então acho q é mais fácil.


    Cria uma Address Lists com a faixa que vc quer bloquear :

    /ip firewall address-list
    add address=192.168.0.1/24 disabled=no list=FAIXA_IP

    *(Se forem ip's diferentes, é só ir adicionando os ip's e colocando com o mesmo nome)

    só criar uma regra assim:

    /ip firewall filter
    add action=drop chain=forward content=sexo disabled=no src-address-list=FAIXA_IP

    *(Só ir mudando a palavra no content)


    --
    Dpetry!

  6. #6

    Padrão Re: Bloqueio de palavras dentro do Site - Mikrotik

    Desta forma a regra bloqueou o site todo... quando solicito o carregamento do site, o site não carrega...



  7. #7
    Avatar de dpetry
    Ingresso
    Jun 2015
    Localização
    Cabo frio - Rio de Janeiro
    Posts
    181

    Padrão Re: Bloqueio de palavras dentro do Site - Mikrotik

    @fredericoafd,

    Mais não é isso que você quer? rsrs'


    --
    Dpetry!

  8. #8

    Padrão Re: Bloqueio de palavras dentro do Site - Mikrotik

    Não, eu gostaria que o site carregasse mas somente onde estiver a palavra "sexo"(por exemplo), não carregar.



  9. #9
    Avatar de dpetry
    Ingresso
    Jun 2015
    Localização
    Cabo frio - Rio de Janeiro
    Posts
    181

    Padrão Re: Bloqueio de palavras dentro do Site - Mikrotik

    Vish querido aii não sei se existe essa possibilidade....



    --
    Dpetry!

  10. #10

    Padrão Re: Bloqueio de palavras dentro do Site - Mikrotik

    Acho que da forma que quer nao vai rolar.
    Ao bloquear uma palavra dentro do site vc tem que definir o que vai ser bloqueado se vai ser o ip do cliente ou o site, nao tem como bloquear apenas o texto.
    Eu desconheço como bloquear o texto de dentro do site.



  11. #11

    Padrão Re: Bloqueio de palavras dentro do Site - Mikrotik

    Boa tarde, o bloqueio utilizando o Content ele funciona assim ou mais ou menos assim ele pesquisa no código de fonte do site se sua ação for da um drop automaticamente o site não abre ou seja eu acho meio que impossível.

  12. #12

    Padrão

    Citação Postado originalmente por mariojulho Ver Post
    Boa tarde, o bloqueio utilizando o Content ele funciona assim ou mais ou menos assim ele pesquisa no código de fonte do site se sua ação for da um drop automaticamente o site não abre ou seja eu acho meio que impossível.
    OK amigo, muito obrigado!