+ Responder ao Tópico



  1. Galera procurei por ai e não achei, mais um script pro nosso MK. Esse script é simples você pode automatiza-lo para que não tenha que ficar comentando todos os usuarios, coloque para rodar de x em x tempos e assim que for ativado o make-static ele adicionará o hostname no coments

    Código :
     
    /ip dhcp-server lease
    :foreach MR in=[find dynamic=no]  do={
        :local hostN [get $MR host-name];
        :local ipAdd [get $MR address];
        :if ( [:len $hostN] > 1) do={ 
            #/ip dhcp-server lease set $MR comment=$hostN;  
            #testando o script
            :put $hostN;
        } else={
            #/ip dhcp-server lease set $MR comment=$hostN;  
            :put "sem hostname: $ipAdd";
        }
    }

  2. deixa eu ver se entendi, com este script, colocando ele em uma RB que tem o dhcp ativo, ele pega o micro que esta usando o IP e renomeia?



  3. Ele salva o hostname no comentário

  4. Citação Postado originalmente por Arthur Bernardes Ver Post
    Faltou complementar que ele fixa o IP do cliente no Leases.
    Bem lembrado, mais avisei em outras palavras:
    assim que for ativado o make-static ele adicionará o hostname no coments






Tópicos Similares

  1. Mikrotik Script - comment = hostname
    Por mauquinhos no fórum Redes
    Respostas: 0
    Último Post: 14-08-2015, 13:36
  2. Respostas: 0
    Último Post: 20-11-2013, 08:18
  3. Respostas: 6
    Último Post: 17-10-2012, 08:53
  4. Respostas: 10
    Último Post: 20-08-2012, 09:58
  5. Respostas: 8
    Último Post: 02-01-2009, 10:58

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L