Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Olá.

    Estou com um problema na minha empresa. Tenho uma RB1100 apenas para fazer load balance de 3 links de 50mbps e controlar a velocidade dos usuarios (não bloqueamos acesso a nenhum site, politicas liberais da empresa), porém são 250 funcionarios e 200 terminais (alguns são compartilhados por mais de 1 funcionario) e agora surgiu a ideia de fazer algo para mandar mensagens para todos (sobre reuniões gerais, novos procedimentos da empresa, manutenção periodica da rede. Coisa que tem que ser enviada para todos os funcionarios). Metade desses funcionarios não tem email da empresa, então pensamos em uma pagina de aviso para que apareça quando ele abre o navegador com um botão que o permita seguir com a navegação (ou no caso de manutenção que a pagina permaneça até a manutenção terminar).
    Montei um ubuntu server com apache para enviar essas mensagens, só que por motivos de falta de espaço o mesmo não pode ficar junto a RB e sim em outra sala do outro lado do galpão. Na verdade esse servidor só seria ligado quando houvesse a necessidade de mandar mensagem coletiva, fora isso permaneceria desligado.
    O meu problema é o seguinte: Existe como configurar isso no Mikrotik? Ex da topologia: RB IP 192.168.x.1 - terminais 192.168.x.10 a 192.168.x.210 - servidor apache 192.168.x.250
    Existe alguma regra no Mikrotik em que quando desativada os funcionarios naveguem normalmente e quando ativada ele seja redirecionado para esse servidor apache para receber a pagina de aviso e depois navegue normalmente? Lembrando que o servidor não está conectado diretamente a RB e sim do outro lado do galpão.

    PS: Ou existe como eu mandar essa pagina de aviso diretamente da RB (esquecendo e desligando o server apache) mas sem usar hotspot? Eu apenas uso ip fixo e queue para limitar a velocidade. Existe alguma regra na qual ativada manda a pagina de aviso e desativada libera a navegação normalmente?

    Desde já agradeço a todos os colegas que puderem ajudar.

  2. Olá,

    vc pode continuar com o seu servidor de apache respondendo com a pagina de aviso pela porta http.

    na sua mikrotik onde está o DHCP server, vc cria duas regras, uma para direcionar tudo que sair da sua rede vindo da faixa do dhcp para a porta http e outra para a porta https.

    aqui estão as regras:

    Http:

    Código :
     
    /ip firewall nat 
    add action=dst-nat chain=dstnat dst-port=80 in-interface=Interface_Interna protocol=tcp src-address=Faixa_da_rede to-addresses=IP_do_Server_Apache to-ports=80

    Https:

    Código :
     
    /ip firewall nat 
    add action=netmap chain=dstnat dst-port=443,445 in-interface=Interface_Interna protocol=tcp src-address=Faixa_da_rede to-addresses=IP_do_Server_Apache to-ports=80


    Espero ter ajudado!



  3. Citação Postado originalmente por dpetry Ver Post
    Olá,

    vc pode continuar com o seu servidor de apache respondendo com a pagina de aviso pela porta http.

    na sua mikrotik onde está o DHCP server, vc cria duas regras, uma para direcionar tudo que sair da sua rede vindo da faixa do dhcp para a porta http e outra para a porta https.

    aqui estão as regras:

    Http:

    Código :
     
    /ip firewall nat 
    add action=dst-nat chain=dstnat dst-port=80 in-interface=Interface_Interna protocol=tcp src-address=Faixa_da_rede to-addresses=IP_do_Server_Apache to-ports=80

    Https:

    Código :
     
    /ip firewall nat 
    add action=netmap chain=dstnat dst-port=443,445 in-interface=Interface_Interna protocol=tcp src-address=Faixa_da_rede to-addresses=IP_do_Server_Apache to-ports=80


    Espero ter ajudado!
    Olá @dpetry, se colocasse a porta 80 e a 443 na mesma regra?!

    Lembro de ter visto algo sobre isso, de não funcionar com várias portas, você confirma isso? Ja passou por isso?

  4. Citação Postado originalmente por berghetti Ver Post
    Olá @dpetry, se colocasse a porta 80 e a 443 na mesma regra?!

    Lembro de ter visto algo sobre isso, de não funcionar com várias portas, você confirma isso? Ja passou por isso?


    Olá @berghetti,

    Já passei sim, a unica forma que achei após vários testes para conseguir redirecionar https, foi fazendo da forma explicada.



  5. Citação Postado originalmente por dpetry Ver Post
    Olá,

    vc pode continuar com o seu servidor de apache respondendo com a pagina de aviso pela porta http.

    na sua mikrotik onde está o DHCP server, vc cria duas regras, uma para direcionar tudo que sair da sua rede vindo da faixa do dhcp para a porta http e outra para a porta https.

    aqui estão as regras:

    Http:

    Código :
     
    /ip firewall nat 
    add action=dst-nat chain=dstnat dst-port=80 in-interface=Interface_Interna protocol=tcp src-address=Faixa_da_rede to-addresses=IP_do_Server_Apache to-ports=80

    Https:

    Código :
     
    /ip firewall nat 
    add action=netmap chain=dstnat dst-port=443,445 in-interface=Interface_Interna protocol=tcp src-address=Faixa_da_rede to-addresses=IP_do_Server_Apache to-ports=80


    Espero ter ajudado!

    Eu agradeço muito pela ajuda, porém me surgiu uma duvida.
    Posso aplicar essas regras sem estar usando dhcp? Como disse, eu uso ip fixo (devido a alguns espertinhos tentar levar seu notebook de casa e conectar em algum dos switchs espalhados pelo galpão. A navegação é liberada, mas somente nos terminais de trabalho porque tambem bloqueio downloads, daí mtos espertinhos com internet ruim em casa tentam levar seus notebooks para baixarem mais rapido la. Desativo todo o acesso as configurações, ao cmd e ao PowerShell dos terminais, então não conseguem verificar qual a faixa de ip. A faixa que citei anteriormente foi só um exemplo, mas a minha faixa de ip está uma bem incomum, então o cara teria que penar para descobrir qual é).

    E pergunto tambem a todos os colegas: Existe como fazer isso usando a propria pagina de aviso do Mikrotik mas sem usar hotspot e dhcp? Porque seria melhor ainda se eu pudesse eliminar esse servidor.

    Mais uma vez agradeço a ajuda de todos.






Tópicos Similares

  1. Respostas: 9
    Último Post: 21-11-2011, 12:12
  2. Manual de referencia ótimo do Mikrotik 2.9
    Por jeanfrank no fórum Redes
    Respostas: 2
    Último Post: 04-05-2009, 14:56
  3. Manual de referencia ótimo do Mikrotik 3.x
    Por jeanfrank no fórum Redes
    Respostas: 2
    Último Post: 02-05-2009, 19:01
  4. Pegar pagina inicial do cliente sem hotspot e pppoe
    Por cleciorodrigo no fórum Redes
    Respostas: 4
    Último Post: 27-01-2008, 17:12
  5. Servidor de hospedagem atrás do MIKROTIK
    Por MarceloGOIAS no fórum Redes
    Respostas: 13
    Último Post: 02-07-2007, 01:04

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L