+ Responder ao Tópico



  1. #1

    Post The DUDE duvida?

    Bom dia galera!

    Gostaria de saber do pessoal que tem mais experiencia em relação a Dude, Alguém poderia me dizer, se o dude consegue monitorar comutação de portas ? ether's.

    Obrigado a todos que puderem ajudar!
    Tenham um ótimo fim de semana!

  2. #2
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.094
    Posts de Blog
    15

    Padrão Re: The DUDE duvida?

    Explica melhor a sua necessidade.



  3. #3

    Padrão Re: The DUDE duvida?

    interhome

    É o seguinte, tenho aparelhos que estavam comutando a porta, então se na porta passa 50 mega, com essa comutação ele passa 10 mega, isso pode ser pelo fato de cabos ruins e conectores mal feito, eu estou querendo saber se tem como monitorar isso pelo DUDE.
    Obrigado

  4. #4
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.094
    Posts de Blog
    15

    Padrão Re: The DUDE duvida?

    Não esquentei a cabeça em fazer no dude. Pois tínhamos resolvido essa questão direto no Mikrotik. Segue o script abaixo. No mínimo serve de partida.


    #Script ETHERNET-Check v0.2
    #
    #Lista as ethernet que estao com velocidades negociadas igual u (10Mbps)
    #
    # Autor: Andre Andrade <[email protected]>
    # 15/08/2012 - 23:25pm
    #Colaborador Maurício de lima <[email protected]>
    #20/08/2012 - 10:52am
    #
    #Instrucoes de uso:
    # -- Adicionar o codigo completo em SYSTEM >> SCRIPTS
    # -- Por padrao o script nao vai derrubar nenhuma interface.
    # -- O script pode ser executado pelo botao "run script" ou via linha de comando.
    # "/ system script run <nome do script>
    # -- Testado nas versoes 5.13
    #
    #Informacoes:
    #
    #Variável v -> valor que sera usado para rastreamento entre as interfaces ATIVAS.




    :global v
    :global data [/system clock get date]
    :global hora [/system clock get time]
    :global host [/system identity get name]
    :foreach i in=[ /interface ethernet find running] do={
    :local intname [ / interface ethernet get $i name ];
    #:log warning (" Interface: " . $intname);




    /interface ethernet monitor $intname once do={ :set v $rate }
    :if ($v = "10Mbps") do={
    :log error message="interface $intname esta em 10Mbps";
    /tool e-mail send subject="Interface em 10Mbps em $host em $data ($hora)" [email protected] body="Corrigir interface LAN ($intname) que esta em 10Mbits" tls=yes
    };
    };



  5. #5

    Padrão Re: The DUDE duvida?

    interhome Não é querendo abusa, da sua sabedoria...
    Alem do e-mail você não sabe se tem como enviar um sms para um determinado numero ?

    Obrigado

  6. #6
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.094
    Posts de Blog
    15

    Padrão Re: The DUDE duvida?

    É possível sim. Primeiro coloque para rodar o sms. Depois me avisa que fazemos juntos.
    Abraço



  7. #7

    Padrão Re: The DUDE duvida?

    Já tenho um sistema rodando, torpedus.com.br, utilizamos ele para rodar do The dude

  8. #8
    André Andrade*MikrotikRio Avatar de interhome
    Ingresso
    Oct 2008
    Localização
    Brasil.
    Posts
    1.094
    Posts de Blog
    15

    Padrão Re: The DUDE duvida?

    Me adiciona no Skype inter-homesolucoes



  9. #9

    Padrão Re: The DUDE duvida?

    Bom dia JeffersonSato!

    Para que você consiga monitorar essa mudança você deverá no the dude criar uma "FUNCTION" e nessa function programar através da sintaxe do script solicitar para que essa função faça a coleta (pooling) via SNMP da informação de Duplex qual você necessita.

    Também será necessário você identificar a OID SNMP no equipamento mikrotik qual contém essa informação de duplex. No próprio the-dude, na parte lateral existe a MIBII-Tree que permite que você execute comandos snmpwalk e faça consulta de OID's que você precisar.

    Após criar a função, basta você atrelar a uma probe e a uma notificação para que você seja avisado quando haver ocorrências de alteração de duplex nas interfaces monitoradas.

    Att

    Rafael Themístocles
    [Consultor em Redes e Telecomunicações/NGN Network Project Engineer]
    http://www.telmetrics.com.br
    E-mail: [email protected]
    [email protected]
    Skype: rafaelthemistocles

    Citação Postado originalmente por JeffersonSato Ver Post
    Bom dia galera!

    Gostaria de saber do pessoal que tem mais experiencia em relação a Dude, Alguém poderia me dizer, se o dude consegue monitorar comutação de portas ? ether's.

    Obrigado a todos que puderem ajudar!
    Tenham um ótimo fim de semana!