+ Responder ao Tópico



  1. #1

    Padrão Dyndns rb 750 v. 6.32.2

    boa noite,

    Alguém teria um script para atualizar ip do dynDns que funcione na versão 6.32.2 do mk? já tentei varias e até agora nenhuma deu certo.

    Grato..

  2. #2

    Padrão Re: Dyndns rb 750 v. 6.32.2

    Amigo, a mikrotik desenvolveu ip/cloud já para essa finalidade.



  3. #3

    Padrão Re: Dyndns rb 750 v. 6.32.2

    Ola bom dia. Como amigo acima falou, IP, Cloud resolveria seu problema, porem se mesmo assim quiser usar, a minha esta na 6.33.1 e roda com esse:
    Código :
    :local ddnsuser "USER"
    :local ddnspass "SENHA"
    :local theinterface "LINK-INTERFACE"
    :local ddnshost "dominio.dyndns.org"
    :local ipddns [:resolve $ddnshost];
    :local ipfresh [ /ip address get [/ip address find interface=$theinterface ] address ]
    :if ([ :typeof $ipfresh ] = nil ) do={
       :log info ("DynDNS: No ip address on $theinterface .")
    } else={
       :for i from=( [:len $ipfresh] - 1) to=0 do={ 
          :if ( [:pick $ipfresh $i] = "/") do={ 
        :set ipfresh [:pick $ipfresh 0 $i];
          } 
    }
     
    :if ($ipddns != $ipfresh) do={
        :log info ("DynDNS: IP-DynDNS = $ipddns")
        :log info ("DynDNS: IP-Fresh = $ipfresh")
       :log info "DynDNS: Update IP needed, Sending UPDATE...!"
        :local str "/nic/update?hostname=$ddnshost&myip=$ipfresh&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG"
        /tool fetch address=members.dyndns.org src-path=$str mode=http user=$ddnsuser password=$ddnspass dst-path=("/DynDNS.".$ddnshost)
        :delay 1
        :local str [/file find name="DynDNS.$ddnshost"];
        /file remove $str
        :global ipddns $ipfresh
      :log info "DynDNS: IP alterado para $ipfresh!"
        } else={
         :log info "DynDNS: Nao Necessita Ser Alterado";
        }
    }


    Ai depois só criar o agendamento para ele rodar no intervalo desejado.

  4. #4

    Padrão Re: Dyndns rb 750 v. 6.32.2

    Amigos, boa tarde. Primeira postagem aqui. TEnho passado pelo mesmo problema e não consigo um script que realmente funcione na minha RB 941 2nd Router OS 6.32.2. A questão é que se eu tentar via IP/Cloud, recebo a msg ERROR: NO INTERNET CONNECTION. Destaco que tenho 2 links NetVirtua com um LoadBalance Ativo (marcações, rotas, etc). Vocês tem alguma dica que possa me ajudar? Obrigado!



  5. #5

    Padrão Re: Dyndns rb 750 v. 6.32.2

    Vcs querem esse script só para acesso remoto?
    Só só fazer direcionamento de portas.
    Qualquer coisa deixem seus WhatsApp.

  6. #6

    Padrão Re: Dyndns rb 750 v. 6.32.2

    Prezado TacioFerreira, pensa num webserver / ftp server. essa é a grande necessidade. Conexao remota também, mas no meu caso, preciso rodar um webserver na minha rede de casa, de tal forma que eu possa acessar remotamente para gerenciar equipamentos por exemplo. A ideia seria colocar em cada WAN um script atualizando um endereço (por exemplo vcvix1.ddns.net e vcvix2.ddns.net). Entendeu?