Página 7 de 9 PrimeiroPrimeiro ... 23456789 ÚltimoÚltimo
+ Responder ao Tópico

  1. Sinceramente creio que a intenção da empresa é fazer os clientes pagarem assistência. Se não fosse esse o motivo o Suporte da Intelbras passaria o procedimento realizado nas assistências. Mk, Ubnt e até outras marcas menos vagabundas (aparentemente) que a intelbras liberam TFTP e seus procedimentos de recuperação. Pq a intelbras não faz a mesma coisa?

    Antes poderiam até falar 'O barato que saia caro'... Agora optar por WON5000 é "O menos caro que realmente não compensa".

    Levando em consideração que outro produto da intelbras que uso é switch e tem outras marcas com o mesmo preço e muito bons vou abandonar toda e qualquer solução intelbras por achar uma empresa muito desrespeitosa com seus clientes.

  2. Não precisa alterar a codificação, apenas a velocidade: 64000
    Fiz o upload da versão 4, mas deu "bad Magic number"
    Vou fazer novos testes.
    O firmware possui um pequeno cabeçalho que acredito ser o magic number. Se você remover esse cabeçalho e cortar o arquivo no final do enchimento que tem vários FF FF FF FF(em hex), terá um arquivo de 1MB exato.
    Essa primeira parte acredito que seja o kernel e a segunda seja root_fs.
    O bootloader é uboot, mas é capado...
    Enviei por tftp também só o kernel, mas também não bootou...
    Vou tentar pegar uma boa e fazer uns dumps pelo dd. Espero que a Intelbras ajude e libere o firmware para recovery.
    Caso contrário, descobriremos um jeito.
    Boa sorte



  3. O jeito que "tem que dar" que todo mundo já sabe, é tirar a Rom e colocar num gravador externo.

    Não tenho nenhuma pra mexer, mas qual é aquele CI de Rom, de 16 pinos, que fica pra cima do chipset? Só achei foto de longe, parece escrito MXIO.

    E de baixo do cabo do conector SMA, não está escrito RX, TX, GND e 3,3V? Se estiver, é por lá que se conecta via serial/TTL pra enviar/copiar o firmware, com um adaptador tipo
    http://produto.mercadolivre.com.br/M...pl2303-ttl-_JM

    Os pontos a verificar, só achei foto ruim no google:
    Clique na imagem para uma versão maior

Nome:	         wom5000.jpg
Visualizações:	96
Tamanho: 	157,8 KB
ID:      	62635


    Eu não acho isso o fim do mundo, pra recuperar roteador doméstico de mesa, de R$ 90, sempre precisamos fazer isso, conectar via serial, ttl ou jtag, pra enviar firmware.
    (Alias, os primeiros DD-WRT nos Linksys não tinha como enviar via web, só via cabo jtag, mas mesmo assim ele cresceu, apareceu o Tomato, Open-WRT e etc, também nessa levada de conectar via cabo jtag. A troca de firmware somente via ethernet acho que tem uns 5 ou 6 anos que virou regra, antes até modem ADSL de R$ 50 precisava disso pra uma mísera troca de VPI/VCI (Aqueles que vem travado pra uma operadora))

  4. Citação Postado originalmente por rubem Ver Post
    O jeito que "tem que dar" que todo mundo já sabe, é tirar a Rom e colocar num gravador externo.

    Não tenho nenhuma pra mexer, mas qual é aquele CI de Rom, de 16 pinos, que fica pra cima do chipset? Só achei foto de longe, parece escrito MXIO.

    E de baixo do cabo do conector SMA, não está escrito RX, TX, GND e 3,3V? Se estiver, é por lá que se conecta via serial/TTL pra enviar/copiar o firmware, com um adaptador tipo
    http://produto.mercadolivre.com.br/M...pl2303-ttl-_JM

    Os pontos a verificar, só achei foto ruim no google:
    Clique na imagem para uma versão maior

Nome:	         wom5000.jpg
Visualizações:	96
Tamanho: 	157,8 KB
ID:      	62635


    Eu não acho isso o fim do mundo, pra recuperar roteador doméstico de mesa, de R$ 90, sempre precisamos fazer isso, conectar via serial, ttl ou jtag, pra enviar firmware.
    (Alias, os primeiros DD-WRT nos Linksys não tinha como enviar via web, só via cabo jtag, mas mesmo assim ele cresceu, apareceu o Tomato, Open-WRT e etc, também nessa levada de conectar via cabo jtag. A troca de firmware somente via ethernet acho que tem uns 5 ou 6 anos que virou regra, antes até modem ADSL de R$ 50 precisava disso pra uma mísera troca de VPI/VCI (Aqueles que vem travado pra uma operadora))
    Realmente o uso do programador daria certo, mas clonaria os MACs(o que não deve ser tão impossível de alterar).
    A seta de cima são os conectores RS232. Estou usando um PL-2303HX para me comunicar com eles.
    Esse é o meu log após a atualização mal sucedida para o firmware 6 beta 2:

    Código:
    ============================================
    Ralink UBoot Version: 3.6.0.0
    --------------------------------------------
    ASIC 3883_MP (MAC to 100SW Mode)
    DRAM_CONF_FROM: EEPROM
    DRAM_SIZE: 128 Mbits SDR
    DRAM_TOTAL_WIDTH: 16 bits
    TOTAL_MEMORY_SIZE: 16 MBytes
    Flash component: SPI Flash
    Date:Dec 14 2011  Time:02:23:19
    ============================================
    icache: sets:512, ways:4, linesz:32 ,total:65536
    dcache: sets:256, ways:4, linesz:32 ,total:32768
    
     ##### The CPU freq = 500 MHZ ####
     estimate memory size =32 Mbytes
    
    Please choose the operation:
       1: Load system code to SDRAM via TFTP.
       2: Load system code then write to Flash via TFTP.
       3: Boot system code via Flash (default).
       4: Entr boot command line interface.
       7: Load Boot Loader code then write to Flash via Serial.
       9: Load Boot Loader code then write to Flash via TFTP.                     0
    
    3: System Boot system code via Flash.
    ## Booting image at bc050000 ...
    raspi_read: from:50000 len:40
    .   Image Name:   Linux Kernel Image
       Created:      2015-10-02  13:28:25 UTC
       Image Type:   MIPS Linux Kernel Image (lzma compressed)
       Data Size:    3571648 Bytes =  3.4 MB
       Load Address: 80000000
       Entry Point:  80233000
    raspi_read: from:50040 len:367fc0
    .......................................................   Verifying Checksum ... Bad Data CRC
    A seta do meio eu acredito a ser a pinagem JTAG, isso explica a falta de resistores como nas Ubiquiti.
    E sim, a última seta é a memória SPI.
    A minha é uma 25Q03213(32Mb, ou seja, 4MB).
    Farei mais testes hoje a tarde.



    ------


    edit: Tentando bootar OpenWRT 15.10
    Código:
    [    0.000000] SoC Type: Ralink RT3883 ver:1 eco:5
    [    0.000000] bootconsole [early0] enabled
    [    0.000000] CPU0 revision is: 0001974c (MIPS 74Kc)
    [    0.000000] Linux version 3.18.20 (buildbot@builder1) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r46450) ) #1 Fri Sep 4 19:35:23 CEST 2015
    [    0.000000] SoC Type: Ralink RT3883 ver:1 eco:5
    [    0.000000] bootconsole [early0] enabled
    [    0.000000] CPU0 revision is: 0001974c (MIPS 74Kc)
    [    0.000000] Linux version 3.18.20 (buildbot@builder1) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r46450) ) #1 Fri Sep 4 19:35:23 CEST 2015
    [    0.000000] SoC Type: Ralink RT3883 ver:1 eco:5
    [    0.000000] bootconsole [early0] enabled
    [    0.000000] CPU0 revision is: 0001974c (MIPS 74Kc)
    [    0.000000] Linux version 3.18.20 (buildbot@builder1) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r46450) ) #1 Fri Sep 4 19:35:23 CEST 2015
    Isso se repete indefinidamente quando se escolhe a opção 1 no bootloader.
    O arquivo utilizado foi openwrt-15.05-ramips-rt3883-uImage.bin

  5. Curioso, isso tá igual os Asus, mesmo com um RT3050 diz que o chipset é um RT3883!

    Agora sobre o "Bad data CRC", erro no checksum pelo visto, isso pra mim é culpa de velocidade errada na porta serial. No caso de MK, as vezes dá isso quando usa algo menor que 128Kbps (Enquanto em RB mais velha tem que usar é 9,6K, vai entender). Lembro de ver essa mensagem algumas vezes.






Visite: BR-Linux ·  VivaOLinux ·  Dicas-L