Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1

    Padrão Como bloquear aplicativo do Youtube

    Boa noite, pessoal do under-linux

    Já tentei de várias bloquear o aplicativo do youtube, mas está bloqueado apenas as paginas no navegador.

    A única forma de bloquear que achei foi por ip mas quando consegui bloquear bloqueou também o gmail.


    Se alguém tiver alguma sugestão agradeço

  2. #2

    Padrão Re: Como bloquear aplicativo do Youtube

    Se tiver firewall na rede, pode bloquear por layer 7.



  3. #3

    Padrão Re: Como bloquear aplicativo do Youtube

    Bom dia, como hoje a maioria dos conteúdos mais acessados estão em https, tais como, youtube, facebook, twitter e etc, o mais interessante é saber o destino das conexões que o Youtube fecha para entregar o conteúdo. Temos que ficar de olho, pois como existem os caches (GGC - Google Global Cache), as conexões não são feitas diretamente para a ASN do Youtube.
    De qualquer forma, feche as seguintes redes por regras de forward do Mikrotik ou qualquer outro firewall.
    Seguem as regras em (export compact) do MK.

    O bloco de endereços oficial do Youtube é --> AS43515 Google Ireland Limited

    /ip firewall address-list
    add address=208.117.236.0/24 list=AS43515
    add address=208.117.242.0/24 list=AS43515
    add address=208.65.152.0/22 list=AS43515
    add address=208.117.224.0/19 list=AS43515
    add address=208.117.234.0/24 list=AS43515
    add address=208.117.254.0/24 list=AS43515
    add address=208.117.238.0/24 list=AS43515
    add address=208.117.239.0/24 list=AS43515
    add address=208.117.252.0/24 list=AS43515
    add address=216.239.60.0/24 list=AS43515
    add action=drop chain=forward dst-address-list=AS43515

  4. #4

    Padrão Re: Como bloquear aplicativo do Youtube

    Citação Postado originalmente por FMVC10 Ver Post
    Se tiver firewall na rede, pode bloquear por layer 7.
    Bom dia FMVC10, obrigado por responder, esqueci de mencionar, mas por layer 7, funciona muito bem para o facebook e para as páginas do YouTube, o aplicativo do YouTube no android não bloqueia.

    O Firewall é o Mikrotik.



  5. #5

    Padrão Re: Como bloquear aplicativo do Youtube

    Citação Postado originalmente por ebelotto Ver Post
    Bom dia, como hoje a maioria dos conteúdos mais acessados estão em https, tais como, youtube, facebook, twitter e etc, o mais interessante é saber o destino das conexões que o Youtube fecha para entregar o conteúdo. Temos que ficar de olho, pois como existem os caches (GGC - Google Global Cache), as conexões não são feitas diretamente para a ASN do Youtube.
    De qualquer forma, feche as seguintes redes por regras de forward do Mikrotik ou qualquer outro firewall.
    Seguem as regras em (export compact) do MK.

    O bloco de endereços oficial do Youtube é --> AS43515 Google Ireland Limited

    /ip firewall address-list
    add address=208.117.236.0/24 list=AS43515
    add address=208.117.242.0/24 list=AS43515
    add address=208.65.152.0/22 list=AS43515
    add address=208.117.224.0/19 list=AS43515
    add address=208.117.234.0/24 list=AS43515
    add address=208.117.254.0/24 list=AS43515
    add address=208.117.238.0/24 list=AS43515
    add address=208.117.239.0/24 list=AS43515
    add address=208.117.252.0/24 list=AS43515
    add address=216.239.60.0/24 list=AS43515
    add action=drop chain=forward dst-address-list=AS43515
    Vou tentar e posto o resultado, obrigado.

  6. #6

    Padrão Re: Como bloquear aplicativo do Youtube

    Acredito q a melhor opçao seria por ip, acredito que com proxy nao funcionaria.



  7. #7

    Padrão Re: Como bloquear aplicativo do Youtube

    Como estão as suas regras de layer 7?

  8. #8

    Padrão Re: Como bloquear aplicativo do Youtube

    FMVC10, é assim que coloquei no layer 7 quando tentei e não funcionou

    Name=youtube
    Regexp= ^.+(youtube.com).*$



  9. #9

    Padrão Re: Como bloquear aplicativo do Youtube

    Citação Postado originalmente por Arthur Bernardes Ver Post
    Por que não usa proxy?
    Arthur, o proxy não funciona sobre a porta 80 ???

    O youtube é https, porta 443

  10. #10

    Padrão Re: Como bloquear aplicativo do Youtube

    Arthur Bernades, se existe uma forma de bloquear https pelo web proxy do mikrotik por favor posta aí pra gente.

    Desde já agradeço a participação no meu post



  11. #11

    Padrão Re: Como bloquear aplicativo do Youtube

    Citação Postado originalmente por Arthur Bernardes Ver Post
    O proxy transparente que dá erro se redirecionar a porta 443, se usar configurado ou WPAD, consegue sim usar proxy.
    No caso vc diz aquela forma de proxy que tem que configurar manual em cada computador para funcionar o proxy?

  12. #12

    Padrão

    Citação Postado originalmente por bissolatimarcelo Ver Post
    FMVC10, é assim que coloquei no layer 7 quando tentei e não funcionou

    Name=youtube
    Regexp= ^.+(youtube.com).*$
    Teste com essa regexp:
    Código :
    ^.*(youtube.).+$
    Aqui funcionou com essa. Abre o aplicativo normalmente, mas na hora de reproduzir um vídeo ele bloqueia.

    Como está a sua regra de firewall bloqueando?
    Tem proxy na rede?
    Última edição por FMVC10; 12-01-2016 às 13:05.



  13. #13

    Padrão Re: Como bloquear aplicativo do Youtube

    Citação Postado originalmente por FMVC10 Ver Post
    Teste com essa regexp:
    Código :
    ^.*(youtube).+$
    Aqui funcionou com essa. Abre o aplicativo normalmente, mas na hora de reproduzir um vídeo ele bloqueia.

    Como está a sua regra de firewall bloqueando?
    Tem proxy na rede?
    Já testei com o Regxp: ^.*(youtube).+$

    Minha regra no Filter Rules é essa:

    add action=drop chain=forward disabled=no layer7-protocol=youtube
    No navegador bloqueia, mas no aplicativo do youtube roda normalzinho nem ameaça bloquear.

  14. #14

    Padrão Re: Como bloquear aplicativo do Youtube

    Ebelotto, estou testando agora com os ip's que me passou, mas nem no navegador bloqueia o youtube bloqueando esses ip's.

    Será que é eu que estou fazendo alguma coisa errada?

    Agradeço a colaboração.



  15. #15

    Padrão Re: Como bloquear aplicativo do Youtube

    Citação Postado originalmente por ebelotto Ver Post
    Bom dia, como hoje a maioria dos conteúdos mais acessados estão em https, tais como, youtube, facebook, twitter e etc, o mais interessante é saber o destino das conexões que o Youtube fecha para entregar o conteúdo. Temos que ficar de olho, pois como existem os caches (GGC - Google Global Cache), as conexões não são feitas diretamente para a ASN do Youtube.
    De qualquer forma, feche as seguintes redes por regras de forward do Mikrotik ou qualquer outro firewall.
    Seguem as regras em (export compact) do MK.

    O bloco de endereços oficial do Youtube é --> AS43515 Google Ireland Limited

    /ip firewall address-list
    add address=208.117.236.0/24 list=AS43515
    add address=208.117.242.0/24 list=AS43515
    add address=208.65.152.0/22 list=AS43515
    add address=208.117.224.0/19 list=AS43515
    add address=208.117.234.0/24 list=AS43515
    add address=208.117.254.0/24 list=AS43515
    add address=208.117.238.0/24 list=AS43515
    add address=208.117.239.0/24 list=AS43515
    add address=208.117.252.0/24 list=AS43515
    add address=216.239.60.0/24 list=AS43515
    add action=drop chain=forward dst-address-list=AS43515
    Ebelotto, estou testando agora com os ip's que me passou, mas nem no navegador bloqueia o youtube bloqueando esses ip's.

    Será que é eu que estou fazendo alguma coisa errada?

    Agradeço a colaboração.

  16. #16

    Padrão Re: Como bloquear aplicativo do Youtube

    Simplesmente pelo motivo q conexoes criptrografadas nao entra no proxy, l7 nao daria certo tambem, como bloquear ou identificar o q tem dentro de algo criptrografado, ate onde tenho conhecimento nao da.



  17. #17

    Padrão Re: Como bloquear aplicativo do Youtube

    deson00, o bloqueio do facebook funciona no layer 7 muito bem, só basta testar aí e vai ver.

    O youtube nos navegadores, também dá certo bloqueando pelo layer 7.

    Não bloqueia no aplicativo do youtube no android.

  18. #18

    Padrão Re: Como bloquear aplicativo do Youtube

    Tente bloquear input também.



  19. #19

    Padrão Re: Como bloquear aplicativo do Youtube

    A melhor alternativa acho que é checar per Torch da interface que está conectada à internet e verificar onde estão sendo feitas as conexões. Como havia dito, existem muitos GGCs espalhados e suas conexões podem ter destino diferente do AS do Youtube. Todas as vezes que o Google acolhe um pedido de instalação de GGC, ele solicita que seja entregue uma rede /24 do AS do parceiro solicitante e isso faz com que as conexões provavelmente não estejam terminando nos IPs que eu havia mencionado.

  20. #20

    Padrão Re: Como bloquear aplicativo do Youtube

    Citação Postado originalmente por ebelotto Ver Post
    A melhor alternativa acho que é checar per Torch da interface que está conectada à internet e verificar onde estão sendo feitas as conexões. Como havia dito, existem muitos GGCs espalhados e suas conexões podem ter destino diferente do AS do Youtube. Todas as vezes que o Google acolhe um pedido de instalação de GGC, ele solicita que seja entregue uma rede /24 do AS do parceiro solicitante e isso faz com que as conexões provavelmente não estejam terminando nos IPs que eu havia mencionado.
    Obrigado pela explicação!!!