+ Responder ao Tópico



  1. #1

    Padrão Balanceamento

    Bom amigos tenho 2 Links de 10 Mb, e queria saber se é possível no mikrotik, balancear os links, da forma quê eu definisse os acessos.

    Ex: Quando o acesso fosse para Facebook, Youtube, Uol, etc... fossem somente pelo link 01
    e quando fizessem download fosse para link 02.

    ou então dividi as requisições , ex: quando um link estivesse usando a banda total, dividisse a banda com o link 02.


    Gostaria da ajuda de vocês

  2. #2

    Padrão Re: Balanceamento

    Sim,é possível,mas você já configurou o balance primeiro?



  3. #3

    Padrão Re: Balanceamento

    A função do balance é esta, como o proprio nome já diz, ele balanceia a carga entre os 2 links, utilizando ambas as bandas para isto, possuo aqui um com 2 LINKS e fica em torno de 40/40 em ambos e na principal, no caso saida, fica em 80 chegando até a 90 (ambos os links de 50 Megas).

    Já a primeira coisa que você me disse creio que é sim possivel fazer, pois em alguns load balances certos sites não abrem e para eles abrirem criam regras para o IP do site passar só por um link, porém isto seria bem chato já que você deveria criar uma regra para cada site. Pelo que vi aqui esta opção fica em: /ip firewall address-list.

  4. #4

    Padrão Re: Balanceamento

    Citação Postado originalmente por edmilson2709 Ver Post
    A função do balance é esta, como o proprio nome já diz, ele balanceia a carga entre os 2 links, utilizando ambas as bandas para isto, possuo aqui um com 2 LINKS e fica em torno de 40/40 em ambos e na principal, no caso saida, fica em 80 chegando até a 90 (ambos os links de 50 Megas).

    Já a primeira coisa que você me disse creio que é sim possivel fazer, pois em alguns load balances certos sites não abrem e para eles abrirem criam regras para o IP do site passar só por um link, porém isto seria bem chato já que você deveria criar uma regra para cada site. Pelo que vi aqui esta opção fica em: /ip firewall address-list.
    você faz o balance em mikrotik ou usa o load balance TP LINK ?



  5. #5

    Padrão Re: Balanceamento

    Acredito q o q vc quer é distribuiçao de link chamado de HTB ou multiplos gateway.
    para isso vc vai usar os menu mangle e router, no mangle vc marca a conexao e define a rota para a marcaçao no menu ip router, desmarcando postrouth da regra.

  6. #6

    Padrão Re: Balanceamento

    Citação Postado originalmente por Maximum Ver Post
    você faz o balance em mikrotik ou usa o load balance TP LINK ?
    Utilizo a propria MK para fazer o balance.
    Tenho aqui as regras já prontas, não sei se vai lhe servir, porém para mim serviu perfeitamente, à seguir estão elas:

    /ip address
    add address=192.168.13.1/24 network=192.168.13.0 broadcast=192.168.13.255 interface=Local
    add address=192.168.0.2/24 network=192.168.0.0 broadcast=192.168.0.255 interface=WAN1
    add address=192.168.12.2/24 network=192.168.12.0 broadcast=192.168.12.255 interface=WAN2


    /ip firewall mangle
    add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
    add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn
    add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
    add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2


    add chain=prerouting dst-address=192.168.0.0/24 action=accept in-interface=Local
    add chain=prerouting dst-address=192.168.12.0/24 action=accept in-interface=Local


    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes


    add chain=prerouting connection-mark=WAN1_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN1
    add chain=prerouting connection-mark=WAN2_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN2


    /ip route
    add dst-address=0.0.0.0/0 gateway=192.168.0.1 routing-mark=to_WAN1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=192.168.12.1 routing-mark=to_WAN2 check-gateway=ping


    add dst-address=0.0.0.0/0 gateway=192.168.0.1 distance=1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=192.168.12.1 distance=2 check-gateway=ping


    /ip firewall nat
    add chain=srcnat out-interface=WAN1 action=masquerade
    add chain=srcnat out-interface=WAN2 action=masquerade

    Mude todos os IPS e as interfaces à seu melhor ver, no caso o que você utiliza na sua rede. Esta que fiz é para 2 LINKS, se quiser + só adicionar mais regras iguais as anteriores, no mesmo esquema, não esqueça de mudar os IPS e as suas interfaces. LOCAL = Por onde vai sair seu link WAN1 = 1º link WAN2= 2º link, nos locais dos links coloque os GATEWAY DO link, no caso o que você utiliza para acessar o seu modem/roteador.
    Última edição por edmilson2709; 13-03-2016 às 00:14.



  7. #7

    Padrão Re: Balanceamento

    Citação Postado originalmente por edmilson2709 Ver Post
    Utilizo a propria MK para fazer o balance.
    Tenho aqui as regras já prontas, não sei se vai lhe servir, porém para mim serviu perfeitamente, à seguir estão elas:

    /ip address
    add address=192.168.13.1/24 network=192.168.13.0 broadcast=192.168.13.255 interface=Local
    add address=192.168.0.2/24 network=192.168.0.0 broadcast=192.168.0.255 interface=WAN1
    add address=192.168.12.2/24 network=192.168.12.0 broadcast=192.168.12.255 interface=WAN2


    /ip firewall mangle
    add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
    add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn
    add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
    add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2


    add chain=prerouting dst-address=192.168.0.0/24 action=accept in-interface=Local
    add chain=prerouting dst-address=192.168.12.0/24 action=accept in-interface=Local


    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
    add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes


    add chain=prerouting connection-mark=WAN1_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN1
    add chain=prerouting connection-mark=WAN2_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN2


    /ip route
    add dst-address=0.0.0.0/0 gateway=192.168.0.1 routing-mark=to_WAN1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=192.168.12.1 routing-mark=to_WAN2 check-gateway=ping


    add dst-address=0.0.0.0/0 gateway=192.168.0.1 distance=1 check-gateway=ping
    add dst-address=0.0.0.0/0 gateway=192.168.12.1 distance=2 check-gateway=ping


    /ip firewall nat
    add chain=srcnat out-interface=WAN1 action=masquerade
    add chain=srcnat out-interface=WAN2 action=masquerade

    Mude todos os IPS e as interfaces à seu melhor ver, no caso o que você utiliza na sua rede. Esta que fiz é para 2 LINKS, se quiser + só adicionar mais regras iguais as anteriores, no mesmo esquema, não esqueça de mudar os IPS e as suas interfaces. LOCAL = Por onde vai sair seu link WAN1 = 1º link WAN2= 2º link, nos locais dos links coloque os GATEWAY DO link, no caso o que você utiliza para acessar o seu modem/roteador.
    Esse balance ele utiliza os dois links ao mesmo tempo ?

  8. #8

    Padrão Re: Balanceamento

    Citação Postado originalmente por Maximum Ver Post
    Esse balance ele utiliza os dois links ao mesmo tempo ?
    Sim, puxa de ambos os links. Seja 2 ou mais.