+ Responder ao Tópico



  1. #1

    Padrão Wifi desconectando (após fechar smartphone) e sempre pedindo autenticação após reconectar

    Boa tarde colegas,
    Comprei recentemente o Routerboard Rb 951ui-2nd L4, para poder estudar mais o universo Mikrotik, usando minha casa e meus familiares como laboratório. Consegui seguir de forma bastante fácil e intuitiva as funções do Mikrotik. Já tenho internet na casa, com DHCP Client, DHCP Server, Hotspots, perfis diferentes de kbps, Usuários, tudo funcionando certinho ao conectar na rede. O problema é que, se eu "fecho" meu smartphone, e o deixo parado por um curo período de tempo, ao "abri-lo" novamente e tentar conectar, é solicitado novamente para que eu me autentique na web, a autenticação do hotspot.

    Tenho pessoas em casa que não tem paciência nem instrução suficiente para ficar se autenticando todo instante. Gostaria de saber se é possível eu por um período maior para se autenticar, e de forma seletiva, por exemplo, Usuário A, só precisar se autenticar daqui a 30 dias, já o usuário B ter 24 horas pare revogar seu acesso e solicitar novamente.

    Já fui em idle session, uptime, tanto no hotspot como em outro local, mas não obtive sucesso.

    Eu dei uma pesquisada no fórum antes de postar, não encontrei nada a respeito do assunto, mas pode ser que eu tenha passado batido, me perdoem se já existe um tópico do tipo e eu não tenha visto.

    Desde já agradeço a atenção de todos.
    Abraço,
    Joaquim Guedes.

  2. #2

    Padrão Re: Wifi desconectando (após fechar smartphone) e sempre pedindo autenticação após reconectar

    Como estão as configurações Session timeout, Idle timeout e Keepalive timeout no perfil do usuário do hotspot?

    Veja as explicações destes parâmetros na wiki: http://wiki.mikrotik.com/wiki/Manual...r#User_Profile



  3. #3
    Avatar de Nilton Nakao
    Ingresso
    Sep 2013
    Localização
    Carlos Chagas, Minas Gerais
    Posts
    907

    Padrão Re: Wifi desconectando (após fechar smartphone) e sempre pedindo autenticação após reconectar

    Uso dois roteadores; um 3Com que serve para autenticar a internet(Wan, celular ou adsl) mas sem wireless e um roteador comum conectado na Lan via PoE mas em AP. À priori tudo deveria funcionar normalmente, mas não; às vezes era o meu PC, outras o Note, Outras o celular mas estes nem todos conseguiam a conexão. Por azar, o roteador velho pifou então tinha que me virar com o que tinha mesmo. Desativei o DHCP, deixando todos em modo privilegiado ou estático. Pensei em usar PPPoE, mas nos celulares precisaria de baixar o aplicativo, e se tiver um visitante?

  4. #4

    Padrão Re: Wifi desconectando (após fechar smartphone) e sempre pedindo autenticação após reconectar

    Opa!
    Esses são meus perfis de hotspot:
    Flags: * - default
    0 * name="default" hotspot-address=0.0.0.0 dns-name="" html-directory=hotspot rate-limit="" http-proxy=0.0.0.0:0 smtp-server=0.0.0.0 login-by=cookie,http-chap
    http-cookie-lifetime=3d split-user-domain=no use-radius=no

    1 name="hotspotRB" hotspot-address=192.168.10.1 dns-name="" html-directory=hotspot rate-limit="" http-proxy=0.0.0.0:0 smtp-server=0.0.0.0
    login-by=http-chap,http-pap,trial split-user-domain=no trial-uptime=1d/1d trial-user-profile=default use-radius=no

    2 name="hotspotwifiRB" hotspot-address=10.0.0.1 dns-name="" html-directory=hotspot rate-limit="" http-proxy=0.0.0.0:0 smtp-server=0.0.0.0
    login-by=http-chap,http-pap,trial split-user-domain=no trial-uptime=1d/1d trial-user-profile=default use-radius=no

    3 name="hsprofwifiDlink" hotspot-address=192.168.0.254 dns-name="" html-directory=hotspot rate-limit="" http-proxy=0.0.0.0:0 smtp-server=0.0.0.0
    login-by=http-chap,http-pap,trial split-user-domain=no trial-uptime=1d/1d trial-user-profile=default use-radius=no
    =========================================
    Idle Timeout ta assim: 1d 00:00:00
    Keepalive Timeout ta assim: 1d 00:00:00
    Informações coletadas nem IP->Hotspot->Guia Servers->MeuHotspotAtual
    =========================================

    Reparei que na guia "User profile", onde criei os perfils de control de banda. Clicando em um dos perfils de usuário, no qual já configurei pra cada usuário em seu perfil, também tem "Idle Timeout" e o "Keepalive Timeout". Como os usuários estão em seus determinados perfis, é aqui onde configuro esse tempo de vida?
    Por exemplo, aqui nos perfis ta assim:
    Idle Timeout ta assim: none
    Keepalive Timeout ta assim: 00:01:00
    Status Autorefresh ta assim: 00:01:00

    Vou ler sim o artigo. Mais uma vez, grato pela atenção.