Página 1 de 5 12345 ÚltimoÚltimo
+ Responder ao Tópico



  1. Eu encontrei diversos tutoriais de VPN, uns usam tunel eoip, outros usam tunel gre. Entao eu decidi trazer esse tutorial que é deferente de todos que eu encontrei na internet, e é a maneira mais rápida e fácil de criar VPN PPTP.
    Essas configurações são usadas em diversos clientes do provedor de onde eu trabalho e ta mais que testada e aprovada.

    Tutorial VPN PPTP
    Criação de VPN entre matriz e 2 filiais de uma empresa usando servidores Mikrotik nas três pontas.
    Levando em consideração a seguinte estrutura:

    Matriz:
    Rede Local: 192.168.0.0/24
    Ip local do Servidor DHCP do mikrotik: 192.168.0.1
    Ip Internet da Matriz: 201.200.200.200

    Filial 1:
    Rede Local: 192.168.1.0/24
    Ip local do Servidor DHCP do mikrotik: 192.168.1.1
    Ip Internet da Filial 1: 189.50.71.33

    Filial 2:
    Rede Local: 192.168.2.0/24
    Ip local do Servidor DHCP do mikrotik: 192.168.2.1
    Ip Internet da Filial 2: 187.85.13.67

    VPN:
    faixa 192.168.0.0/16
    Gateway: 192.168.0.1

    Filial 1 ip de vpn: 192.168.1.1
    Filial 2 ip de vpn: 192.168.2.1


    CONFIGURAÇÕES
    No meu exemplo, tanto a matriz quanto as filiais já estão com internet e já tem servidor dhcp fornecendo ips para os computadores e dispositivos conectados a elas, abaixo segue as configurações necessárias para colocar a VPN em funcionamento:

    Matriz:

    1- Ativar o serviço de VPN.

    /interface pptp-server server
    set enabled=yes

    2- Em ppp secret, vamos criar o login de acesso das filiais, seta os IPs e preencher o campo routes, lembrando de escolher o serviço pptp

    o ip local das filiais é o IP da matriz (192.168.0.1)
    o ip remoto da filial 1 é (192.168.1.1) routes=192.168.1.0/24 (range de ips da filial 1)
    o ip remoto da filial 2 é (192.168.2.1) routes=192.168.2.0/24 (range de ips da filial 2)

    /ppp secret
    add local-address=192.168.0.1 name= vpn_filial1 password= vpn_filial1 remote-address=\
    192.168.1.1 routes=192.168.1.0/24 service=pptp
    /ppp secret
    add local-address=192.168.0.1 name= vpn_filial2 password= vpn_filial2 remote-address=\
    192.168.2.1 routes=192.168.2.0/24 service=pptp

    3- por padrão todo mikrotik vem identificado como mikrotik, então vamos mudar essa identificação, onde vamos colocar o nome de Matriz.

    /system identity
    set name=Matriz

    Pronto, simples e prático!
    As Rotas das filiais vão subir no momento em que elas fizerem login na VPN, então aqui na matriz não vamos precisar criar regras em ip routes.


    Agora vamos para a configuração das Filiais:

    Filial 1:

    1- Configurar o pptp cliente na nossa filial 1, onde o usuário e password vai ser os que criamos na matriz, e no campo connect vamos colocar o ip de internet da matriz (201.200.200.200)

    /interface pptp-client
    add connect-to=201.200.200.200 disabled=no mrru=1600 name=vpn_filial1 password=\
    vpn_filial1 user=vpn_filial1

    2- Configurar a rota para a filial 1 ter acesso a rede interna de todos os participantes desta VPN:

    Rota de acesso ao serviço de vpn para a Filial 1:
    Aqui dizendo que pela conexão do pptp cliente (vpn_filial1), nos vamos chegar a rede interna de todos participantes dessa VPN, onde resumimos que a faixa (192.168.0.0/16) é a faixa de ips dessas redes internas que queremos alcançar.

    /ip route
    add comment="rota_vpn" distance=1 dst-address=192.168.0.0/16 gateway= vpn_filial1

    Por fim mudamos a identificação para VPN_filial1

    /system identity
    set name= VPN_filial1

    Filial 2:
    1- Configurar o pptp cliente na nossa filial 2, onde o usuário e password vai ser os que criamos na matriz, e no campo connect vamos colocar o ip de internet da matriz (201.200.200.200)

    /interface pptp-client
    add connect-to=201.200.200.200 disabled=no mrru=1600 name=vpn_filial2 password=\
    vpn_filial2 user=vpn_filial2

    2- Configurar a rota para a filial 2 ter acesso a rede interna de todos os participantes desta VPN:

    Rota de acesso ao serviço de vpn para a Filial 2:
    Aqui dizendo que pela conexão do pptp cliente (vpn_filial2), nos vamos chegar a rede interna de todos participantes dessa VPN, onde resumimos que a faixa (192.168.0.0/16) é a faixa de ips dessas redes internas que queremos alcançar.

    /ip route
    add comment="rota_vpn" distance=1 dst-address=192.168.0.0/16 gateway= vpn_filial2

    por fim mudamos a identificação para VPN_filial2

    /system identity
    set name= VPN_filial2


    Espero ter ajudado, essa é a minha contribuição, afinal aqui no under-linux eu aprendi muita coisa e em gratidão deixo esse tutorial
    Última edição por Alex20cf; 11-05-2016 às 08:07.

  2. Parabéns pela contribuição



  3. Muito bom mesmo, vou até salvar aqui rsrsr. Abraço!

  4. Citação Postado originalmente por Arthuzitow Ver Post
    Muito bom mesmo, vou até salvar aqui rsrsr. Abraço!
    Valeu, estamos aí pra ajudar. aqui agente ganha conhecimento sem precisar comprar, então porque eu iria vender isso no under-linux, tem muitos que vem aqui pra vender ao invés de ajudar, a na hora que eles precisam de ajuda com algo, eles querem de graça.



  5. Citação Postado originalmente por FMANDU Ver Post
    Parabéns pela contribuição
    muito obrigado, nosso forum ta precisando disso !
    contribuições sem nenhuma cobrança.
    outro dia precisei de uma ajuda quando eu tava aprendendo load balance, e teve gente querendo vender o serviço de load balance ao invés de me responder onde eu tava errando pra que eu pudesse aprender.






Tópicos Similares

  1. vpn pptp + restrição de hosts
    Por dimago no fórum Servidores de Rede
    Respostas: 1
    Último Post: 29-07-2009, 07:36
  2. Configuração de VPN
    Por jair no fórum Segurança
    Respostas: 0
    Último Post: 13-06-2003, 20:33
  3. Software de VPN
    Por A-Marcio no fórum Segurança
    Respostas: 2
    Último Post: 21-05-2003, 16:31
  4. Impressão SMB através de VPN
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 12-02-2003, 14:09
  5. Autenticação de usuários de VPN PPTP no linux
    Por no fórum Servidores de Rede
    Respostas: 0
    Último Post: 06-02-2003, 11:23

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L