+ Responder ao Tópico



  1. #1

    Padrão Controle Banda por MAC Queues

    Galerinha bom dia,

    é possivel fazer controle de banda de um cliente pelo mac do mesmo dentro do QUEUES ?

  2. #2

    Padrão Re: Controle Banda por MAC Queues

    Anderson, e possível sim. No caso vc pretende controlar a banda pra um vários clientes?
    A melhor maneira de fazer isso é usando o winbox, fica mais fácil até de entender.


    Enviado via XT1040 usando UnderLinux App



  3. #3

    Padrão Re: Controle Banda por MAC Queues

    Isso no Winbox mesmo so preciso saber aonde coloco o MAC no QUEUES, so vi o local de colocar o IP.

    Olhe ai : http://prntscr.com/b6e3w1

  4. #4

    Padrão Re: Controle Banda por MAC Queues

    Isso mesmo, vc cadastra o IP, existe sim uma opção onde vc cadastra o Mac. Consigo te ajudar mais, porém a noite.
    Pode ser?
    Obrigado.


    Enviado via XT1040 usando UnderLinux App



  5. #5

    Padrão Re: Controle Banda por MAC Queues

    Quero trocar o IP pelo MAC, entendeu ?

  6. #6

    Padrão Re: Controle Banda por MAC Queues

    Acredito que você não conseguirá isso.
    Visto que um esta em Layer2 o outro em Layer3.
    Controle de queres é em layer3.

    Você conseguirá criar a Police no ip.



  7. #7

    Padrão Re: Controle Banda por MAC Queues

    tbm imaginava isso

  8. #8

    Padrão Re: Controle Banda por MAC Queues

    No Queues; Aba General - Name = nome do cliente / Target address = Ip do cliente, logo abaixo seta a velocidade. Aba Advanced - Interface = escolha a interface do cliente.
    No Dhcp Server; Aba Leases - clica no sinal de + e em Address coloca o mesmo ip do queues, Mac address coloca o MAC do cliente, Server escolha o servidor, em comment coloca o nome do cliente.
    Assim você amarra o ip ao mac para cada cliente, setando a velocidade para aquele IP.



  9. #9

    Padrão Re: Controle Banda por MAC Queues

    Ele não quer fazer Mac ip. Ele queria limitar banda por Mac.
    Não há essa possibilidade..

  10. #10

    Padrão Re: Controle Banda por MAC Queues

    É, também pelo pouco que conheco de MK, não tem como limitar banda somente pelo MAC, controla-se pelo IP e amarra o MAC ao IP. Somente pelo MAC, se existe ainda não vi nem ouvi falar.



  11. #11

    Padrão Re: Controle Banda por MAC Queues

    Realmente so por mac nao tem como, obrigado viu.

  12. #12

    Padrão Re: Controle Banda por MAC Queues

    Buenas.

    Tem como controlar pelo MAC, mas não sei porque isso seria interessante. E além do mais, como não existe ferramenta nenhuma que faça esse tipo de controle automaticamente, você tem configurar tudo manualmente no ROS.

    Para alcançar esse resultado, você vai ter que usar o mangle, e poderia fazer algo assim:

    Código :
    /ip firewall mangle add chain=prerouting connection-mark=no-mark src-mac-address=XX:XX:XX:XX:XX:XX action=mark-connection new-connection-mark=Conexao_MAC_XX
    /ip firewall mangle add chain=prerouting connection-mark=Conexao_MAC_XX action=mark-packet new-packet-mark=Pacote_MAC_XX

    Assim, quando vier um pacote proveniente do MAC especificado, a conexão vai ser marcada. Com a conexão marcada, basta marcar os pacotes referentes a essas conexões que terão marca Conexao_MAC_XX.

    No Queue, você pode adicionar uma regra para limitar a banda dos pacotes marcados, algo assim:

    Código :
    /queue simple add target=0.0.0.0/0 packet-marks=Pacote_MAC_XX max-limit=1M/2M



  13. #13

    Padrão Re: Controle Banda por MAC Queues

    esse contrele por MAC é melhor do que por IP, porque se caso alguem setar outro IP fixo na placa de rede, ele ira burlar o controle

  14. #14

    Padrão Re: Controle Banda por MAC Queues

    Citação Postado originalmente por luc1anocruz Ver Post
    esse contrele por MAC é melhor do que por IP, porque se caso alguem setar outro IP fixo na placa de rede, ele ira burlar o controle
    Se o seu sistema aceita uma falha grotesca dessa, não é por Mac que vai resolver. Tá tudo errado e muito.



  15. #15

    Padrão Re: Controle Banda por MAC Queues

    eu nao uso autenticação ppoe, eh mikrotik em casa, e empresto a internet para os vizinhos, e controle pelo DHCP a velocidade