+ Responder ao Tópico



  1. #1

    Padrão Pedido de Ajuda como enviar arquivos pro microtik em new terminal via FTP

    Bom a dia a todos

    Venho através deste solicitar dos participantes desta comunidade como faço para enviar os dois comandos abaixo para o New Terminal no Microtik, eu sei que seu copiar e colar dá tudo certo mas preciso saber E APRENDER como fazer esse procedimento via FTP

    /ip hotspot user profile
    add name=plano128k/256k rate-limit=128k/256k

    /ip hotspot user
    add limit-uptime=1h name=#aly password=megcou profile=plano128k/256k

    Desde já agradeço a colaboração dos que sabem e compartilham seus conhecimento para ajudar quem precisa

  2. #2

    Padrão Re: Pedido de Ajuda como enviar arquivos pro microtik em new terminal via FTP

    via ftp não amigo, ftp era se vc fosse enviar algum script e depois rodar, para rodar estes comandos você pode execultar este comando via telnet. pode até criar um script em arquivos de lotes de msdos ( . bat )



  3. #3

    Padrão Re: Pedido de Ajuda como enviar arquivos pro microtik em new terminal via FTP

    Amigo se não for muito encômodo, você teria um Tuto-exemplo ou me dar um link onde tem
    Na verdade eu Desenvolvi um aplicativo em Microsoft acesses Visual Basic Para Gerar Usuários e senhas e o cartão com os dados para disponibilizar para venda pré pago.

    Então estou cadastrando no microtik manualmente os dados do cartão e eu gostaria de enviar esses usuários para /ip hotspot user tudo de uma vez, deu pra entender melhor agora, eu tenho experiência e conhecimento na programação Access mais rede e servidores devido a grande necessidade de agilizar e simplificar estou aprendendo agora.

  4. #4

    Padrão Re: Pedido de Ajuda como enviar arquivos pro microtik em new terminal via FTP

    vou criar aqui e te posto, poste também esse arquivo do access, isso ajudaria bastante várias pessoas no forúm, abraços posto já !!!



  5. #5

    Padrão

    MENU-AUTOMATIZA.rar segue em anexo o arquivo bat com o script, meu script usa ftp para enviar arquivo e ssh para execultar o comando, se voçê digitar a opção 1 ele vai execultar o comando no mikrotik, se selecionar a opção 2 ele envia o arquivo se selecionar a opção 3 ele envia o arquivo e depois execulta o comando que voçê quiser, veja se é isso que voçê quer, nesse meu script voçê pode salvar o arquivo em formato src enviar para o mikrotik e depois fazer o export do arquivo no mikrotik, abraços se deu certo dê um joinha aê.

  6. #6

    Padrão Re: Pedido de Ajuda como enviar arquivos pro microtik em new terminal via FTP

    Amigo em primeiro lugar obrigado por estar me ajudando, vou abrir ele analisar e ver a compatibilidade com o sistema, voltarei a falar com você o mais breve possível não se preocupa eu postarei o sistema assim que estiver pronto, a gora não adianta postar porque ele não concluído dentro do projetado, mas diante mão veja o print do sistema abaixo:
    https://under-linux.org/image/png;ba...AAAElFTkSuQmCC


    Pois por aí você veja ainda estou indo manualmente pro microtik para cadastrar a geração desse arquivos tenho que abrir o microtik e inseri-los manualmente se haver uma forma mais fácil de clicar e exportar direto para o novo terminal pronto acabou o trabalhão

    Abraços



  7. #7

    Padrão Re: Pedido de Ajuda como enviar arquivos pro microtik em new terminal via FTP

    Amigo detalhe por gentileza os tres numeros
    Se eu clicar
    1 ele vai execultar o comando no mikrotik e Vai fazer oque?

    2 ele envia o arquivo se selecionar, vai me dar a opção de selecionar o arquivo em? pastas

    3 ele envia o arquivo, vai me dar opção pra onde eu quero enviar o arquivo

    Nessas três opções terei uma tela extra, para mim saber por onde estou andando ou não

    Ainda não o executei pois estou com o microtik totalmente configurado e funcionando com um monte de clientes logados e estou com medo de algo dar errado

  8. #8

    Padrão

    RAIJE
    Amigo detalhe por gentileza os tres numeros
    Se eu clicar
    1 ele vai execultar o comando no mikrotik e Vai fazer oque? (execulta qualquer comando que vc quiser)

    2 ele envia o arquivo se selecionar, vai me dar a opção de selecionar o arquivo em? (qualquer local que vc quiser é só colocar o caminho)

    3 ele envia o arquivo, vai me dar opção pra onde eu quero enviar o arquivo (envia para o mk e depois execulta o comando que vc quiser)


    na opção 3 do script vc manda um arquivo .src e depois manda com comando exporta o que tem nele.
    abra o arquivo e leia o script que você vera o que cada comando faz, abraços.