+ Responder ao Tópico



  1. Bom Dia caros amigos do forum

    Quero tirar um duvida com vocês, só novo na parte de Mikrotik.

    Bom o meu problema e o seguinte, aqui na empresa nos temos 3 links de internet ligados direto um em cada proxy squid, e tenho um RB 2011i, eu gostaria de tirar esses modem direto dos proxy pois quando da algum problema eu tenho que acessar cada proxy pra poder acessar cada modem, pois eles não estão ligado no switch da rede local, pois tivemos problemas na empresa de funcionários estar usando ips direto do modem burlando o proxy, e a minha unica alternativa rápido foi isso tirar todos os modem da rede local e pluga um em cada porta do proxy.

    Agora a duvida, como faço para ligar todos os link no Mikrotik um em cada porta, e amarrar os MAC das placa de rede de cada proxy, para que apenas o proxy possa se conectar, pois assim terei todos no mikrotik onde conseguirei, gerencia melhor sem precisa, acessar proxy por proxy pra acessar modem por modem.

    Nao quero fazer um Load Balance, quero apenas que o mikrotik gerencia cada link, levando eles para cada porta do proxy.

  2. Se você tem 3 Squids na rede, e cada um ligado um link, a única forma que consigo pensar que você está fazendo a divisião de carga em cada link é que você tem 3 subredes, e o Squid é o gateway de cada uma delas, é isso?

    Você pode ligar os 3 links direto na RB, e criar 3 tabelas de roteamento, uma para cada subrede.

    Digamos que seja assim:

    Squid 1 IP: 192.168.1.1/24
    Squid 2 IP: 192.168.2.1/24
    Squid 3 IP: 192.168.3.1/24

    Os cabos que vão ligados nos Squids, você muda para a Routerboard, e nas portas da Routerboard que ligar os cabos dos Squids, coloca o IP do Squid referente aquele cabo. Digamos que você tenha colocado o cabo da intranet do squid 1 na porta ether1 da Routerboard, você coloca na porta 1 da routerboard o IP 192.168.1.1/24, colocando o cabo do Squid 2 na porta ether2, coloca o IP na ether2 192.168.2.1/24 e a mesma coisa com o cabo do Squid 3.

    Digamos agora que os modens estão nas portas ether4, ether5 e ether6, que que os IPs sejam assim:

    Modem 1 -> ether4
    IP: 10.0.0.2/24
    Gateway: 10.0.0.1

    Modem 2 -> ether5
    IP: 10.1.1.2/24
    Gateway: 10.1.1.1/24

    Modem3 -> ether6
    IP: 10.2.2.2/24
    Gateway: 10.2.2.1

    Então você cria 3 tabelas de roteamento, mais ou menos assim:

    Código :
    /ip route add dst-address=0.0.0.0/0 gateway=10.0.0.1 routing-mark=Link1
    /ip route add dst-address=0.0.0.0/0 gateway=10.1.1.1 routing-mark=Link2
    /ip route add dst-address=0.0.0.0/0 gateway=10.2.2.1 routing-mark=Link3

    Esses Routing-mark são para criar tabelas de roteamento nomeadas, ou seja, apenas pacotes que sejam marcados para serem roteados por essas tabelas de roteamento irão para esse gateway.

    Agora, para você direcionar cada subrede para o link certo, ja que não precisa fazer balanceamento, a forma mais facil é usar iprules, algo assim:

    Código :
    /ip route rule add src-address=192.168.1.0/24 action=lookup table=Link1
    /ip route rule add src-address=192.168.2.0/24 action=lookup table=Link2
    /ip route rule add src-address=192.168.3.0/24 action=lookup table=Link3

    Assim, a subrede 192.168.1.0/24 vai usar a tabela de roteamento chamada Link1, a qual o gateway padrão é 10.0.0.1. A subrede 192.168.2.0/24 vai usar a tabela de roteamento chamada Link2, a qual o gateway é 10.1.1.1 e a subrede 192.168.3.0/24 a tabela chamada Link3 com o gateway 10.2.2.1.

    Neste cenario estamos excluindo o Squid da jogada. Se quiser colocar o Squid devolta, você não vai mais precisar de 3, somente 1. A não ser que tenha algum motivo alem de cache para ter 3. No caso, basta usar NAT para redirecionar só a porta 80 para o Squid que conectar na RB (e talvez a 443 caso você use). Claro, para isso vai ter que reconfigurar o IP do Squid, para não ficar na mesma rede atual a qual vai conflitar com a intranet.






Tópicos Similares

  1. Configuraçã do mikrotik com link dedicado
    Por grooveman no fórum Redes
    Respostas: 4
    Último Post: 20-05-2017, 08:30
  2. Trunk Vlan Mikrotik com link Puro
    Por Netdigit no fórum Redes
    Respostas: 3
    Último Post: 12-05-2011, 12:45
  3. Configurar o Mikrotik com Link Via Satélite
    Por vanskymaster no fórum Redes
    Respostas: 6
    Último Post: 19-05-2008, 12:28
  4. Respostas: 7
    Último Post: 07-03-2008, 23:10
  5. Mikrotik com D-Link G520, etc
    Por Elliott no fórum Redes
    Respostas: 8
    Último Post: 04-03-2007, 17:19

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L