+ Responder ao Tópico



  1. Bom dia Senhores! Estou tendo problemas para fazer funcionar acesso remoto atrás de loadbalance de dois DVRS em um cliente empresarial. Já fiz a liberação e o redirecionamento das portas em meu core e na rb do cliente, funciona normalmente, porém quando ativo o segundo link (o da Oi) para de funcionar o acesso remoto aos dois dvrs dele. Já fiz uma regra para que o dvr saísse apenas pelo meu link. Mas algo está faltando, pois não funciona com os dois links ativos ao mesmo tempo. O que poderá ser? Desde já agradeço à todos da comunidade!

  2. /ip firewall nat
    add action=dst-nat chain=dstnat comment="Redirecionamento Intelbras" dst-port=37777 log-prefix="" protocol=tcp to-addresses=13.xx.xx.205 to-ports=37777
    add action=masquerade chain=srcnat log-prefix="" out-interface=pppoe-out1
    add action=masquerade chain=srcnat log-prefix="" out-interface=OI

    /ip route
    add check-gateway=ping distance=1 gateway=pppoe-out1 routing-mark="rota 1"
    add check-gateway=ping distance=1 gateway=192.168.0.1 routing-mark="rota 2"
    add check-gateway=ping distance=1 gateway=pppoe-out1 routing-mark=sembalance
    add check-gateway=ping distance=2 gateway=pppoe-out1
    add check-gateway=ping distance=3 gateway=192.168.0.1

    /ip firewall address-list
    add address=13.xx.xx.167 comment="DVR JFL" list=sembalance
    add address=13.xx.xx.205 comment="DVR Intelbras" list=sembalance

    /ip firewall mangle
    add action=mark-routing chain=prerouting dst-address-type=!local log-prefix="" new-routing-mark="rota 1" passthrough=no per-connection-classifier=both-addresses:2/0
    add action=mark-routing chain=prerouting dst-address-type=!local log-prefix="" new-routing-mark="rota 2" passthrough=no per-connection-classifier=both-addresses:2/1
    add action=mark-routing chain=prerouting comment="Sem Balance" disabled=yes log-prefix="" new-routing-mark=sembalance passthrough=no src-address-list=sembalance



  3. Up

  4. Boa noite colega, tudo bem?

    Você já fez a garantia de entrada e saída? Me envia uma MP caso tenha interesse nesse serviço!



  5. Citação Postado originalmente por MrGravetto Ver Post
    Boa noite colega, tudo bem?

    Você já fez a garantia de entrada e saída? Me envia uma MP caso tenha interesse nesse serviço!
    Boa noite, não entendi sua pergunta. Essa garantia de entrada e saída ajudaria a resolver meu problema?

  6. Poderia resolver, o que ocorre é que a conexão é estabelecida por link, sendo assim se ele for por um link e retornar por outro será apresentado algum erro, dessa forma você deve garantir que o que entrar pelo LINK A sai também pelo LINK A e o que entrar pelo LINK B saia pelo LINK B.



  7. Já fiz desta forma. No servidor tem uma regra para que este cliente utilize apenas o link 1 (Sem Balance), e no cliente (Load balance com Rb 750GL) tem outra regra, esta informando que os DVRs DEVERÃO sair apenas pelo link 1 (o meu), utilizar o da Oi apenas quando o meu estiver indisponível, como mostram as regras que postei no começo... Mas mesmo assim não está indo.

  8. IPs dos seus DVRs são 13.x.x.x?



  9. Sim.

  10. Bom dia,

    A tabela mangle é lida de cima para baixo.. a sua mark-routing sembalance tem que estar antes das outras 2 regras, ficando assim;

    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="Sem Balance" disabled=no log-prefix="" new-routing-mark=sembalance passthrough=no src-address-list=sembalance
    add action=mark-routing chain=prerouting dst-address-type=!local log-prefix="" new-routing-mark="rota 1" passthrough=no per-connection-classifier=both-addresses:2/0
    add action=mark-routing chain=prerouting dst-address-type=!local log-prefix="" new-routing-mark="rota 2" passthrough=no per-connection-classifier=both-addresses:2/1



  11. Citação Postado originalmente por patrickdias Ver Post
    Bom dia,

    A tabela mangle é lida de cima para baixo.. a sua mark-routing sembalance tem que estar antes das outras 2 regras, ficando assim;

    /ip firewall mangle
    add action=mark-routing chain=prerouting comment="Sem Balance" disabled=no log-prefix="" new-routing-mark=sembalance passthrough=no src-address-list=sembalance
    add action=mark-routing chain=prerouting dst-address-type=!local log-prefix="" new-routing-mark="rota 1" passthrough=no per-connection-classifier=both-addresses:2/0
    add action=mark-routing chain=prerouting dst-address-type=!local log-prefix="" new-routing-mark="rota 2" passthrough=no per-connection-classifier=both-addresses:2/1

    Bom dia @patrickdias !!! Farei essa modificação agora e mais
    tarde posto os resultado... Obrigado!

  12. Fiz a mudança e funcionou de cara! Obrigado pela ajuda!!!!






Tópicos Similares

  1. Por que quando ativo a Bridge a maquina some?
    Por FabricioViana no fórum Redes
    Respostas: 10
    Último Post: 12-04-2008, 16:58
  2. olha o erro quando ativo o proxy transparente
    Por ederamboni no fórum Redes
    Respostas: 2
    Último Post: 24-09-2007, 12:36
  3. Quando ativo a bridge o MK perde comunicação
    Por fabiocatelani no fórum Redes
    Respostas: 4
    Último Post: 15-06-2007, 16:57
  4. Squid cai quando ativo o proxy transparente no Firewall
    Por tiagoalgodas no fórum Servidores de Rede
    Respostas: 3
    Último Post: 04-04-2007, 02:09
  5. squid usando apenas segundo link
    Por jabsnet no fórum Servidores de Rede
    Respostas: 1
    Último Post: 04-04-2006, 09:42

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L