Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. Boa tarde,


    Preciso monitora a quantidade de estações conectadas em um AP(torre) em tempo real, Ex: Routerboard-912 (Mikrotik). Não sei por onde começá, por favor me ensina a pesca.


    Utilizando o comando: "snmpwalk -v 2c -c public <host IP>" tenho retorno normal, consigo enxerga 27 estações conectadas(registradas na interface wireless da AP) e seus respectivos mac, quero que o zabbix me traduza a quantidades de clientes que estão conectados em tempo real.
    Terei que fazer algum script para isso, ou so usando o zabbix: chave + oid conseguirei realiza essa façanha,



    _Sou iniciante nesse mundo zabbix, aceitei o desafio em que a empresa a qual estou me disponibilizou, comprei o livro de A a Zabbix, bom já evoluir muito, mais também tenho muitas duvidas, já perdi algumas noites de sono tentando resolve alguns pepinos e erros.



    _Debian 8.3 + Zabbix 3.0.5

  2. Não sei se entendi bem o que você quer.

    Na interface wireless no winbox, em registration mostra quantos clientes estão conectados...

    Agora, nem todos estarão navegando. Alguns só pelo fato do rádio cliente estar ligado já aparece no winbox em registration. Para ver quem realmente está usando a conexão em dado momento eu configuro o registration em "show columns" para aparecer na tabela. Assim fico sabendo quem realmente está usando e quem está só ligado.



  3. Citação Postado originalmente por 1929 Ver Post
    Não sei se entendi bem o que você quer.

    Na interface wireless no winbox, em registration mostra quantos clientes estão conectados...

    Agora, nem todos estarão navegando. Alguns só pelo fato do rádio cliente estar ligado já aparece no winbox em registration. Para ver quem realmente está usando a conexão em dado momento eu configuro o registration em "show columns" para aparecer na tabela. Assim fico sabendo quem realmente está usando e quem está só ligado.
    A intenção e a integração com o zabbix, quero que o zabbix identifica e mostre, desejo monta um mapa,

  4. Pesquisando sobre me mostraram a solução
    dentro do mikrotik utilizando o comando: interface wireless print oid
    Terei como resultado

    tx-rate=.1.3.6.1.4.1.14988.1.1.1.3.1.2.47
    rx-rate=.1.3.6.1.4.1.14988.1.1.1.3.1.3.47
    ssid=.1.3.6.1.4.1.14988.1.1.1.3.1.4.47
    bssid=.1.3.6.1.4.1.14988.1.1.1.3.1.5.47
    client-count=.1.3.6.1.4.1.14988.1.1.1.3.1.6.47
    frequency=.1.3.6.1.4.1.14988.1.1.1.3.1.7.47
    band=.1.3.6.1.4.1.14988.1.1.1.3.1.8.47
    noise-floor=.1.3.6.1.4.1.14988.1.1.1.3.1.9.47
    overall-ccq=.1.3.6.1.4.1.14988.1.1.1.3.1.10.47 '


    O que preciso meu caso e o (client-count=.1.3.6.1.4.1.14988.1.1.1.3.1.6.47)

    Que vai resulta a quantidade de clientes conectado na painel.
    Clique na imagem para uma versão maior

Nome:	         Sem título.png
Visualizações:	63
Tamanho: 	32,6 KB
ID:      	66690



  5. Entendi.

    Despercebi o Zabbix na sua necessidade.

    Muito legal.

    E nesta sua aplicação precisa mostrar os conectados mas inativos ou vai mostrar só os que estiveram ativos em determinado momento?

  6. Citação Postado originalmente por ab5x2 Ver Post
    Para ele não interessa quem está usando ou não, mas quantos clientes estão conectados no AP, aqui tenho algo semelhante, para se ter uma noção de quantos clientes conectados no AP.
    Entendo...vai depender de para que finalidade as informações serão utilizadas.

    Mas se fosse eu, me interessaria em quantos estão ativos... senão a leitura poderia ser falsa, ou não?

    Por exemplo, é comum alguém dizer que tem 30 50 ou mais usuários num rádio. Mas na realidade quantos estão realmente consumindo banda e processamento do rádio?



  7. Só os que estiveram ativos em tempo real, a intenção mesmo e saber quando devemos coloca um nova painel, não temos a intenção de coloca mais que 30 clientes em uma painel, isto é para ter um controle mais fácil.

  8. Citação Postado originalmente por 1929 Ver Post
    Entendo...vai depender de para que finalidade as informações serão utilizadas.

    Mas se fosse eu, me interessaria em quantos estão ativos... senão a leitura poderia ser falsa, ou não?

    Por exemplo, é comum alguém dizer que tem 30 50 ou mais usuários num rádio. Mas na realidade quantos estão realmente consumindo banda e processamento do rádio?
    E uma coisa a sí pensa, mais a nivel de provedor não seria tão importante, o consumo total da AP ja bastaria



  9. Citação Postado originalmente por Treme Ver Post
    E uma coisa a sí pensa, mais a nivel de provedor não seria tão importante, o consumo total da AP ja bastaria
    para o consumo total do AP não ficaria mais fácil um gráfico gerado pelo próprio Mikrotik?

  10. Eu coloquei no The Dude com o comando:
    /interface pppoe-server print count-only
    Eu tenho um PPPoE server por painel então poderia fazer:
    /interface pppoe-server print count-only where service="PainelA"

    Mas com certeza usar snmp é melhor que SSH ou API.

    Eu a algum tempo queria avaliar o quanto de banda entre as torres eu ganharia se centraliza-se as queues.

    pra isso fiz o seguinte script:

    Código :
    /queue simple
    :global downpackets 0
    :global downdropped 0
    :set downpackets 0
    :set downdropped 0
    :foreach i in=[find] do={:set downdropped ($downdropped + [:pick [get $i dropped] ([:find [get $i dropped] "/" -1] + 1) 999 ])}
    :foreach i in=[find] do={:set downpackets ($downpackets + [:pick [get $i packets] ([:find [get $i packets] "/" -1] + 1) 999 ])}
    :foreach i in=[find] do={:put [:pick [get $i dropped] ([:find [get $i dropped] "/" -1] + 1) 999 ]}
    :put $downdropped
    :foreach i in=[find] do={:put [:pick [get $i packets] ([:find [get $i packets] "/" -1] + 1) 999 ]}
    :put $downpackets
    :put (((($downdropped * 1000) / $downpackets )))

    Acho que isso pode ser adaptado pra saber quantos clientes estão realmente consumindo.



  11. Clique na imagem para uma versão maior

Nome:	         probe.PNG
Visualizações:	35
Tamanho: 	13,8 KB
ID:      	66707

  12. @eduardomazolini, fiz os procedimentos e não deu certo. Alguma sugestão?






  13. Tenta o comando /ppp active print count-only

  14. pera ai, acho que passe despercebido, é pra eu colocar aquele script citado anteriormente? e depois esse comando? nos probes?

  15. Citação Postado originalmente por eduardomazolini Ver Post
    Eu coloquei no The Dude com o comando:
    /interface pppoe-server print count-only
    Eu tenho um PPPoE server por painel então poderia fazer:
    /interface pppoe-server print count-only where service="PainelA"

    Mas com certeza usar snmp é melhor que SSH ou API.

    Eu a algum tempo queria avaliar o quanto de banda entre as torres eu ganharia se centraliza-se as queues.

    pra isso fiz o seguinte script:

    Código :
    /queue simple
    :global downpackets 0
    :global downdropped 0
    :set downpackets 0
    :set downdropped 0
    :foreach i in=[find] do={:set downdropped ($downdropped + [:pick [get $i dropped] ([:find [get $i dropped] "/" -1] + 1) 999 ])}
    :foreach i in=[find] do={:set downpackets ($downpackets + [:pick [get $i packets] ([:find [get $i packets] "/" -1] + 1) 999 ])}
    :foreach i in=[find] do={:put [:pick [get $i dropped] ([:find [get $i dropped] "/" -1] + 1) 999 ]}
    :put $downdropped
    :foreach i in=[find] do={:put [:pick [get $i packets] ([:find [get $i packets] "/" -1] + 1) 999 ]}
    :put $downpackets
    :put (((($downdropped * 1000) / $downpackets )))

    Acho que isso pode ser adaptado pra saber quantos clientes estão realmente consumindo.
    Como posso inserir isso no dude? apenas os comandos citados não deu certo, preciso colocar algo a mais

  16. Eu também gostaria de saber, não sou tão experiente no TheDude como consigo extrair do Zabbix, mas queria aprender isso.

  17. Pelo que o video demonstrou ele faz isso apenas nos equipamentos que usam o sistema RouterOS, o AirOS da ubiquiti, não encontrei uma maneira ainda

  18. O Script foi coisa minha. E exemplo, não é pra usar. Faz o que está no vídeo.
    O vídeo mostra do dude pra uma RouterOS.

  19. Tenho para the dude ubnt, clientes conectados, uptime e canal usado chegando na loja posto.

    Para mk tenho clientes conectados e uptime, me falta o do canal ainda.

  20. @JonasMT, ficaremos no aguardo, já tentei muitas maneiras de monitorar a quantidade de estações conectadas, mais todas sem sucesso






Tópicos Similares

  1. Respostas: 6
    Último Post: 08-04-2014, 07:44
  2. Respostas: 28
    Último Post: 09-03-2014, 19:35
  3. Respostas: 6
    Último Post: 03-10-2011, 07:50
  4. Respostas: 3
    Último Post: 08-12-2007, 02:20
  5. Link de 8 megas em um router cisco 2610XM
    Por opala no fórum Redes
    Respostas: 7
    Último Post: 26-07-2006, 12:58

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L