+ Responder ao Tópico



  1. #1
    teso2600
    Bom dia a todos. Estou usando o conectiva Linux 7.0 com kernel 2.4.5-9cl, o
    computador em questão é um Pentium 166 com 64 mb de ram e tem duas placas de
    rede. uma eth0 com o ip 192.168.2.29 (mascara 255.255.255.0) a outra eth1 ip
    10.1.1.1 (mascara 255.255.0.0) ambas funcionando com eth1 consigo "pingar"
    para a rede 10.1.0.0 sem problemas tenho uma máquina windows usando o samba,
    postgres e apache da máquina Linux sem problemas e pela eth0 consigo acessar
    a internet também sem problemas através do gateway 192.168.2.1 (esta máquina
    eu não tenho acesso para configurar nada.). O problema e que não consigo
    acessar da máquina windows (10.1.1.2) a internet, não consigo pingar para a
    máquina 192.168.2.1 da máquina windows. Segui os passos que estão no site da
    Conectiva que são os seguintes:

    Ativar o repasse de pacotes no arquivo /etc/sysconfig/network colocando a
    seguinte linha:

    FORWARD_IPV4="yes"

    Habilitar as rotas no servidor da seguinte forma:

    route add -net 192.168.2.0 netmask 255.255.255.0 gw 192.168.2.29 ( alterei
    esta linha de acordo com a minha rede, será que o erro esta aqui?).

    route add -net 10.1.0.0 netmask 255.255.0.0 gw 10.1.1.1 (idem anterior).

    Ao verificar que isto não funcionava tentei usar o ipchains como vi
    numtutorial na net da seguinte forma:

    ipchains -A forward -J MASQ -i eth0 -s 10.1.0.0/255.255.0.0 -d 0.0.0.0

    E obtive o seguinte erro:

    ipchains: protocol not available

    Detalhe é que alterei esta linha do ipchains de várias formas e sempre
    obtive a mesma mensagem de erro.

    Desculpe-me pelo post gigante, mas se alguem puder me ajudar agradeço.

  2. #2
    <TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE>
    On 2002-03-27 16:11, teso2600 wrote:
    Bom dia a todos. Estou usando o conectiva Linux 7.0 com kernel 2.4.5-9cl, o
    computador em questão é um Pentium 166 com 64 mb de ram e tem duas placas de
    rede. uma eth0 com o ip 192.168.2.29 (mascara 255.255.255.0) a outra eth1 ip
    10.1.1.1 (mascara 255.255.0.0) ambas funcionando com eth1 consigo "pingar"
    para a rede 10.1.0.0 sem problemas tenho uma máquina windows usando o samba,
    postgres e apache da máquina Linux sem problemas e pela eth0 consigo acessar
    a internet também sem problemas através do gateway 192.168.2.1 (esta máquina
    eu não tenho acesso para configurar nada.). O problema e que não consigo
    acessar da máquina windows (10.1.1.2) a internet, não consigo pingar para a
    máquina 192.168.2.1 da máquina windows. Segui os passos que estão no site da
    Conectiva que são os seguintes:

    Ativar o repasse de pacotes no arquivo /etc/sysconfig/network colocando a
    seguinte linha:

    FORWARD_IPV4="yes"

    Habilitar as rotas no servidor da seguinte forma:

    route add -net 192.168.2.0 netmask 255.255.255.0 gw 192.168.2.29 ( alterei
    esta linha de acordo com a minha rede, será que o erro esta aqui?).

    route add -net 10.1.0.0 netmask 255.255.0.0 gw 10.1.1.1 (idem anterior).

    Ao verificar que isto não funcionava tentei usar o ipchains como vi
    numtutorial na net da seguinte forma:

    ipchains -A forward -J MASQ -i eth0 -s 10.1.0.0/255.255.0.0 -d 0.0.0.0

    E obtive o seguinte erro:

    ipchains: protocol not available

    Detalhe é que alterei esta linha do ipchains de várias formas e sempre
    obtive a mesma mensagem de erro.

    Desculpe-me pelo post gigante, mas se alguem puder me ajudar agradeço.

    </BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE>



    Vamos lá use
    #echo 1 > /proc/sys/net/ipv4/ip_forward

    para habilitar o forward no seu linux, outra coisa vc so precisa criar uma rota se o seu linux não estiver conectado a alguma das suas redes, no caso ele esta conectado nas duas redes.
    vc pode colocar o comando acima no arquivo rc.local do dir /etc/rc.d

    qualquer duvida <a href="mailto:wlreis@tendtudo.com.br">wlreis@tendtudo.com.br</a>


    FANTASMA



  3. #3
    paulogrifo
    pelo seu comentário de erro vc não está com o módulo do ipchains carregado
    use:

    echo 1 > /proc/sys/net/ipv4/ip_forward
    insmod ipchains
    /sbin/modprobe ip_masq_ftp
    /sbin/modprobe ip_masq_quake
    /sbin/modprobe ip_masq_irc
    /sbin/modprobe ip_masq_user
    /sbin/modprobe ip_masq_raudio
    echo "Mascarando endereços internos"
    ipchains -P forward DENY
    ipchains -A forward -s $LOCAL -j MASQ

    paulo
    <IMG SRC="images/forum/smilies/icon_razz.gif">






Tópicos Similares

  1. Firewall Roteador
    Por devlinmaxx no fórum Segurança
    Respostas: 5
    Último Post: 19-12-2002, 16:03
  2. ROTEADOR NAT 486
    Por no fórum Servidores de Rede
    Respostas: 1
    Último Post: 22-11-2002, 08:53
  3. Roteador
    Por ergs no fórum Servidores de Rede
    Respostas: 1
    Último Post: 20-11-2002, 16:52
  4. Logs de roteadores
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 18-11-2002, 14:37
  5. Roteador
    Por ediguedes no fórum Servidores de Rede
    Respostas: 1
    Último Post: 02-10-2002, 23:48

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L