+ Responder ao Tópico



  1. #1
    Visitante

    Padrão Apache 1.3.27 + PHP 2.4.3 + Interbase 6 + Conectiva 8

    Olá. Estou tendo problemas para configurar o acesso ao interbase com o PHP.
    Já recompilei o PHP, o Apache, mas continuo recebendo mensagem do tipo ibase_connect().

    Outra coisa. Peguei dois roteiros, e em cada um deles o PHP.INI deveria ser colocado em uma pasta diferente.

    Alguém poderia me ajudar.

    André

  2. #2
    BrunoC
    Visitante

    Padrão Apache 1.3.27 + PHP 2.4.3 + Interbase 6 + Conectiva 8

    Bem, ao iniciar o processo de instalação, você deve dizer pro PHP onde está o interbase assim: ./configure --with-apache=/caminho/pro/source/apache-1.3.27 -with-interbase=DIR (o default é /usr/interbase)

    depois de instalado, faça os procedimentos do apache. Quando terminar de compilar, dê um httpd -l para ver se o mod_php4 está lá.. (caso você tenha compilado com ele).

    O php.ini deve ser colocado no /usr/local/lib/



  3. #3
    Mr_Mind
    Visitante

    Padrão Apache 1.3.27 + PHP 2.4.3 + Interbase 6 + Conectiva 8

    Instale o apache bem configurado habilitando o suporte a DSO´s. OK tdo bem
    Agora o PHP, ./configure --with-apxs=/usr/sbin/apxs (este costuma ser o dir dessa aplicaçao) --with-interbase=DIR (em q dir e´ a directoria em q esta instalado o interbase)
    make && make install , e o PHP ja esta´!Nao esqueça de adicionar o modulo no httpd.conf e declarar o mime type do PHP.
    No php.ini voce deve declarar a extensao para trabalhar com o interbase. Por exemplo para trabalhar com mysql voce carrega o mysql.so. Procure por la´ e adicione a do interbase.leia o install do PHP e veja onde colocar o seu php.ini e como.

    Convem que ja tenha o interbase instalado, claro <IMG SRC="images/forum/smilies/icon_biggrin.gif">

    Um abraço

    se ainda assim persistir o problema verifique a sua instalaçao do Interbase e se esta correndo e aceitando conexoes =)

    _________________
    After all ... we&acute;re all alike!!

    <font size=-1>[ Editado por Mr_Mind On Date 25-10-2002 em 12:26 ]</font>

  4. #4
    Visitante

    Padrão Apache 1.3.27 + PHP 2.4.3 + Interbase 6 + Conectiva 8

    Olá,

    Quando tento recompilar o php4, dá erro ...strub.lo... recursive... Resumindo, executando um make clean antes do ./configure, tudo bem. O problema agora é que o apache não inicia, reclamando de vários módulos ".so". Acho que terei de remover o apache e o php4 do conectiva8 e recomeçar. Poderia me ajudar nisso?

    Obrigado



  5. #5
    Mr_Mind
    Visitante

    Padrão Apache 1.3.27 + PHP 2.4.3 + Interbase 6 + Conectiva 8

    instale o conectiva 8 com Apache mas sem suporte a PHP ... depois leia o meu post anterior esquecendo a parte d instalar o apache com DSO&acute;s.

    Abraços <IMG SRC="images/forum/smilies/icon_biggrin.gif">

    _________________
    <i>After all ... we&acute;re all alike!!</i>

    <font size=-1>[ Editado por Mr_Mind On Date 30-10-2002 em 13:13 ]</font>