+ Responder ao Tópico



  1. #1

    Padrão problemas na autenticação do ncsa_auth no Red Hat 7.3

    galera,
    uso o rh 7.3 e estou com um probleminha: quando abro o browser é solicitado que eu coloque um nome de usuário e senha para acessar internet conforme a acl proxy_auth REQUIRED adicionada no squid.conf.
    Preencho os dois campos e quando o browser carrega a pagina pela primeira vez dá erro como se estivesse off line, e o mais estranho é que quando teclo F5 para carregar a mesma página ele carrega normalmente.
    O que sera que faz com que o browser nao carregue logo na primeira vez antes do F5?

    minha acl:

    ...
    acl autentica proxy_auth REQUIRED
    acl rede1 192.168.1.0/24
    acl rede2 192.168.0.0/24
    acl hora_acesso time 08:00-18-00
    acl palavras_negadas url_regex -i "/etc/squid/palavras.conf"
    acl sites_negados dstdomain -i "/etc/squid/sites.conf"
    ...
    ...
    http_access deny sites_negados
    http_access deny palavras_negadas
    http_access allow autentica
    http_access allow rede1
    http_access allow rede2 hora_acesso
    http_access deny all

    Obrigado!!

  2. #2
    dark_exs
    Visitante

    Padrão problemas na autenticação do ncsa_auth no Red Hat 7.3

    Veja a versão do squid, se é a última tive pb com a versão que veio com o Conectiva 8. baixe a nova versão 2.5 do squid compilei e funcionou bem.
    Crei que já tenha em rpm tb, se vc preferir.

    <IMG SRC="images/forum/icons/icon21.gif">



  3. #3

    Padrão problemas na autenticação do ncsa_auth no Red Hat 7.3

    blz, vou tentar então. <IMG SRC="images/forum/icons/icon_wink.gif">

  4. #4

    Padrão problemas na autenticação do ncsa_auth no Red Hat 7.3

    Fala ae kra,

    Este problema q vc estah tendo q naum carrega a pagina pela primeira vez, tendo q em seguida pressionar a tecla F5 ou digitar o URL novamente, posso te afirmar q naum tem nada a ver com o Squid ou com o programa de autenticação NCSA_AUTH.

    O verdadeiro problema, eh q vc estah utilizando o browser Internet Explorer 6 com Service Pack 1 instalado, entaum o q acontece: qdo vc instala o SP1, por algum motivo (acho q eh bug) ele gera este tipo de problema de autenticação, e naum eh somente no browser, mas tb na nova versao do Messenger 5.0 q naum consegue autenticar pela primeira vez, somente na segunda.

    Estou ainda com este mesmo problema la no meu trabalho, pois trabalho na Petrobras e ainda naum descobrir como resolver isso, pode ser um bug no MALDITO!!! SP1, essa Microsoft eh uma Merda mesmo... lança essas porra de patch&acute;s (correções) que soh fodem o seu sistema.

    A solução q posso te passar de imediato eh q vc reinstale o browser Internet Explorer 6 mas, sem o SP1 certo?? q com certeza a autenticação no Squid vai funcionar blz!!!

    Lembrando!!! naum eh problema com o NCSA_AUTH e sim o navegador.

    Qualquer coisa, me chame aki no forum ou no ICQ 98818827,

    Boa Sorte, <IMG SRC="images/forum/icons/icon_wink.gif">

    Elvis



  5. #5
    Visitante

    Padrão problemas na autenticação do ncsa_auth no Red Hat 7.3

    Tabém estou com o mesmo problema.
    Quando fui atualizar o squid para versão 2.5 tive este problema.
    Eu restaurei a versão anterior e o IE SP1 funcionou perfeitamente.
    Acho que o problema esta no Squid e não o IE. ja que com a versão anterior do Squid o IE SP1 funciona.

    O que eu não fiz ainda é aplicar os paths da versão 2.5 Recomendo a todos

    Se alguem solucionar por favor poste a solução aqui.

    Marcelo

  6. #6

    Padrão problemas na autenticação do ncsa_auth no Red Hat 7.3

    Tb tive esse problema e EH O IE...
    eu to com meu squid rodando a um tempão.... qdo atualizei o navegador da galera começou com esse problema



  7. #7

    Padrão problemas na autenticação do ncsa_auth no Red Hat 7.3

    <TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE>
    On 2002-11-12 17:57, Anonymous wrote:
    Tabém estou com o mesmo problema.
    Quando fui atualizar o squid para versão 2.5 tive este problema.
    Eu restaurei a versão anterior e o IE SP1 funcionou perfeitamente.
    Acho que o problema esta no Squid e não o IE. ja que com a versão anterior do Squid o IE SP1 funciona.

    O que eu não fiz ainda é aplicar os paths da versão 2.5 Recomendo a todos

    Se alguem solucionar por favor poste a solução aqui.

    Marcelo
    </BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE>

    Fala ae Marcelo,

    Kra eh estranho ter funcionado, pois tb usei as versoes anteriores do Squid 2.4 STABLE6 e 7, e o problema ainda continua.
    Continuo achando q o problema eh no browser, sabe o pq???
    Pq qdo eu testo num IE sem SP1 a pagina carrega blz, logo de kra !!! Ae neste mesmo "browser" instalo o SP1, e ae pinta o problema.

    Entao eu pergunto: Serah mesmo q o problema eh no Squid???
    Acho q naum !!!

    Mas de qualquer forma, se vc descobrir seja la qual for o problema, poste aki pra galera OK ??

    Valew,

  8. #8
    Visitante

    Padrão problemas na autenticação do ncsa_auth no Red Hat 7.3

    Estou com o mesmo problema, aconteceu depois que instalei o IE SP1 na minha maquina. Nas outras máquinas, sem o SP1 do IE6 funciona blz.
    O bug está no IE6 SP1.
    Utilizo o CL 8.0 com squid-2.4.7-1U8_3cl.

    ---------------------------
    folow the white rabit!
    <IMG SRC="images/forum/icons/icon21.gif">



  9. #9

    Padrão problemas na autenticação do ncsa_auth no Red Hat 7.3

    Tanto isso eh verdade que eu testei com os navegadores:
    1 - Opera
    2 - Netscape
    3 - Mozilla
    4 - Konqueror

    e só da esse problema no IE mesmo.... <IMG SRC="images/forum/icons/icon_frown.gif">

  10. #10
    Visitante

    Padrão problemas na autenticação do ncsa_auth no Red Hat 7.3

    Elvis,

    Desculpe, mas não mencionei minha versão anterior.
    Estou usando a versão 2.2 STABLE 4
    Nesta versão eu posso garantir que o IE SP1 funciona perfeitamente.

    Mesmo assim adiando que assim que eu obtiver uma solução para este problema posto aqui no forum.


    Marcelo




  11. #11
    AndrewAmorimdaSilva
    Visitante

    Padrão problemas na autenticação do ncsa_auth no Red Hat 7.3

    Galera, tenho o mesmo problema com o IE 6 SP!
    Façam teste, desabilite o suporte o SSL no navegar e funciona....o problema é com o SSL....

    Tentem e postem aqui....

  12. #12
    dark_exs
    Visitante

    Padrão problemas na autenticação do ncsa_auth no Red Hat 7.3

    Querem uma boa solução.
    Selecione os arquivos do IE6, pressione a tecla DELETE e confirma. Vc ajudou a fazer um computador melhor... Hehehehehe.

    Está bem que a Micro$oft tente fazer com que todos utilizem seus aplicativos, agora nós usarmos ou não e outra coisa diferente de outra coisa. <IMG SRC="images/forum/icons/icon_eek.gif">
    <IMG SRC="images/forum/icons/icon_mad.gif">
    Devemos utilizar coisa alternativas, O Netscape 7, está legal eu utilizo ele. Tem pagina que não funciona, por que a maioria dos caras que fazem as paginas pensam só em duas coisas "IE* | Micro$oft" | "Micro$oft | IE*", quando eu pego uma coisa desse tipo, escrevo um e-mail (lógico com educação), e faço a minha reclamação. Se a maoiria fizer a mesma coisa, utilizar browser alternativos e mostrar para essa turma de puxa-saco de Micro$oft, <IMG SRC="images/forum/icons/icon_mad.gif"> que eles tem que partir para outra alternativa, para atender a todos sem discriminação, logo-logo, os pb serão poucos para nós e maiores para a Micro$oft. <IMG SRC="images/forum/icons/icon_mad.gif">


    Desculpe o desabafo! <IMG SRC="images/forum/icons/icon_cool.gif">
    Até...
    <IMG SRC="images/forum/icons/icon21.gif">



  13. #13

    Padrão problemas na autenticação do ncsa_auth no Red Hat 7.3

    aí elvis,

    é verdade. O problema é so no ie6 sp1.
    Tinha ele aqui instalado na minha maquina (com win2000) e so reparei a instalação anterior (voltei para ie6) e funcionou bacana.
    Pô, e eu quebrando a cabeça aqui no squid.conf.

    Valeu brother. <IMG SRC="images/forum/icons/icon_biggrin.gif">

  14. #14
    Mr_Mind
    Visitante

    Padrão problemas na autenticação do ncsa_auth no Red Hat 7.3

    mas sem o suporte SSL pode dar barraca em sites sobre HTTPS!

    dark_exs muito bem, todos deveriam seguir o seu exemplo!! <IMG SRC="images/forum/icons/icon_wink.gif">



  15. #15
    Visitante

    Padrão problemas na autenticação do ncsa_auth no Red Hat 7.3

    Bom pessoal,
    para mim o problema esta resolvido

    Quando li a mensagem do AndrewAmorimdaSilva falando sobre problema com ssl. Resolvi explorar este assunto.

    Recompilei o squid com --enable-ssl

    (.configure --enable-ssl --enable-linux-netfilter --enable-basic-auth-helpers=ncsa)

    Pronto. Estou utilizando o squid-2.5.STABLE1 com o IE6 SP1

    Marcelo