+ Responder ao Tópico



  1. #1
    Visitante

    Padrão Modem só da ocupado ! O que fazer ??

    Tenho um modem HSP 56 AMR PCTel e uso Conectiva 8.
    Compilei o drive pctel 0.9.6 como no tutorial, ocorreu tudo certo, instalei o modulo (insmod pctel e inmod ptserial).

    Mas quando mando o Kpp dar sinal no modem ele acusa o seguinte:

    . No caminho /dev/modem ou /dev/ttyS0 :
    Modem pronto
    Desculpe, mas o modem não responde

    . No caminho /dev/ttyS1 ou /dev/ttyS2 :
    Procurando modem
    Desculpe, o modem está ocupado

    . Nos demais caminhos:
    Desculpe mas não consegui localizar o modem

    O que está havendo ? será que não deu resultado este drive, está ocorrendo algum erro, ou falta eu fazer mais alguma coisa depois de dar o insmod ??
    Alguém pode me ajudar ?

    Valeu

  2. #2

    Padrão Modem só da ocupado ! O que fazer ??

    tb tive um problema parecido com o Conectiva.... soh q foi no Conectiva 3 hehehe isso era um problema de comunicao com o Modem... da uma olhada nas configuração como está a comunicação com o Modem,etc... ou melhor posta todas as configuracoes do modem aki



  3. #3
    Visitante

    Padrão Modem só da ocupado ! O que fazer ??

    O Kppp estah configurado para o modem assim:

    Dispositivo de Modem: /dev/modem
    Controle de Fluxo: CRTSCTS
    Terminador de Linha: CR
    Velocidade de Ligação: 57600

  4. #4

    Padrão Modem só da ocupado ! O que fazer ??

    Vc jah tentou alterar o controle de fluxo?



  5. #5
    garan
    Visitante

    Padrão Modem só da ocupado ! O que fazer ??

    Tambem tenho este mesmo sistema e modem , mas nao tive problema, a versao do drive do pctel , e a
    9.2 e nao tive problema , veja se o modulo esta carregado , exclua a configuracao do kpp e faca novamante. falou!!!

  6. #6
    Visitante

    Padrão Modem só da ocupado ! O que fazer ??

    Jah tentei mudar o controle de fluxo mas nao deu em nada...
    Vou tentar pegar o drive 0.9.2 entao...



  7. #7
    brunomarcelo
    Visitante

    Padrão Modem só da ocupado ! O que fazer ??

    veja bem... ttyS0/1/2/3 sao portas seriais pre-definidas com irq´s e i/o´s especificos...

    vc pode muda-las com o setserial... mas n acho isso mto ortodoxo... (acho gambiarra msm)

    da uma olhada no readme do driver q la deve indica qual a ttyS? a ser usada...
    o driver "cria" uma porta serial especial no /dev durante o "make install", agora eu so n me lembro se é a ttyS15 ou a ttyS9

    [ Esta mensagem foi editada por: brunomarcelo em 18-11-2002 23:24 ]