+ Responder ao Tópico



  1. #1
    Visitante

    Padrão Erro Iniciando o Squid

    No meu servidor central que roda DNS o squid funciona normal

    agora eu configurei um outro sevidor que irá apenas compartilhar a internet ADSL, ele nao tem DNS e nada

    quando eu tento rodar o squid da o seguinte erro
    Nov 25 10:05:26 ServLinux (squid): ipcache_init: DNS name lookup tests failed.

    procurei e nao achei nada no squid.conf

    alguem poderia me ajudar

    Obrigado

  2. #2

    Padrão Erro Iniciando o Squid

    tente colocar isso no seu squid.conf

    visible_hostname seudominio.com.br



  3. #3
    uDiVan
    Visitante

    Padrão Erro Iniciando o Squid

    deu certo cara ! ! !

  4. #4
    Danielvb
    Visitante

    Padrão Erro Iniciando o Squid

    Também tive o mesmo problema com isso e também resolvi assim ... <IMG SRC="images/forum/icons/icon_wink.gif">



  5. #5
    Visitante

    Padrão Erro Iniciando o Squid

    coloquei

    visible_hostname onofrebarbosa.com.br

    e ainda continua dando o mesmo erro

  6. #6
    _MANCHESTER_
    Visitante

    Padrão Erro Iniciando o Squid

    O seu problema deve ser no /etc/resolv.conf
    da uma verificada la

    se continuar dando problema

    inicie o squid assim
    squid -D

    ai ele ignora essa directiva e funciona normal

    Qualquer coisa manda mensagem ae



  7. #7

    Padrão Erro Iniciando o Squid

    1 - o squid -D faz ele rodar como DAEMON num tem nda a ver com ignorar nda...

    2 - vc num pode simplesmente colocar um nome qq no visible_hostname.... num posso te dizer oq ele faz exatamente mas dependendo do dominio q vc colocar ele da pau... tenta colocar como localhost.localdomain

  8. #8
    uDiVan
    Visitante

    Padrão Erro Iniciando o Squid

    1 - Sua variavel hostname esta definida certa ??
    2 - A internet esta funcionando na maquina local ??
    3 - Esta maquina esta apontando para qual servidor de nomes ??



  9. #9
    uDiVan
    Visitante

    Padrão Erro Iniciando o Squid

    Quando na instalação vc naum define o hostname ou o apelido na inicializacao do squid ele pode dar problemas.
    Como nosso caro amigo avisou vc tera que definir a variavel visible_hostname no squid.conf ou setar a variavel hostname da sua maquina local.

    <IMG SRC="images/forum/icons/icon_wink.gif">

  10. #10
    _MANCHESTER_
    Visitante

    Padrão Erro Iniciando o Squid

    <TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE>
    On 2002-11-25 14:11, 1c3_m4n wrote:
    1 - o squid -D faz ele rodar como DAEMON num tem nda a ver com ignorar nda...
    </BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE>

    Eu tive um problema assim a um tempao atras e procurei na pagina do squid, e no FAQ ta assim

    To disable this feature, use the -D command line option

    eu imaginei que o -D desativava alguma coisa.

    Me desculpe pelo erro



  11. #11
    uDiVan
    Visitante

    Padrão Erro Iniciando o Squid

    E ai rapaz . . . deu certo ????

    Aguardando respostas <IMG SRC="images/forum/icons/icon_eek.gif">

  12. #12
    Visitante

    Padrão Erro Iniciando o Squid

    Como vao? Tenho o squid funcionando com restrição a lista de sites e palavras especificas. Somente navega qem tem senha, (autenticação). Gostaria de saber se alguem sabe fazer restrição por usuario, por ex. o usuario X pode acessar www.teste.com e o Y não. Alguem ja conseguiu fazer isso?
    Se possivel enviem a resposta tbm para [email protected]
    []&acute;s
    Allan Patrick



  13. #13
    Toti
    Visitante

    Padrão Erro Iniciando o Squid

    <TABLE BORDER=0 ALIGN=CENTER WIDTH=85%><TR><TD><font size=-1>Quote:</font><HR></TD></TR><TR><TD><FONT SIZE=-1><BLOCKQUOTE>
    On 2002-11-25 14:11, 1c3_m4n wrote:
    1 - o squid -D faz ele rodar como DAEMON num tem nda a ver com ignorar nda...

    2 - vc num pode simplesmente colocar um nome qq no visible_hostname.... num posso te dizer oq ele faz exatamente mas dependendo do dominio q vc colocar ele da pau... tenta colocar como localhost.localdomain
    </BLOCKQUOTE></FONT></TD></TR><TR><TD><HR></TD></TR></TABLE>

    Bheee.. Resposta errada. O problema eh que o squid quando eh startado, tenta resolver alguns hosts para ver se tem os dns funcionando. Se o link internet nao estiver ativo quando o squid eh iniciado, esse erro acontece <IMG SRC="images/forum/icons/icon_wink.gif"> Isso acontece muito na inciacao do servidor. Se o link nao estiver ativo, o squid morre. Para desativar isso, se USA SIM a chave -D. Olhe:

    # squid --help
    <corta>
    -D Disable initial DNS tests.
    <continua>

    Eh so colocar essa chave que o squid nao olha o dns, e roda <IMG SRC="images/forum/icons/icon_wink.gif">
    [ ]`s
    Toti

  14. #14
    Danielvb
    Visitante

    Padrão Erro Iniciando o Squid

    se Não der certo tente colocar

    visible_hostname dns

    foi assim que resolvi o meu problema <IMG SRC="images/forum/icons/icon_wink.gif">



  15. #15
    Danielvb
    Visitante

    Padrão Erro Iniciando o Squid

    E AI CARA JÁ FOI RESOLVIDO O SEU PROBLEMA????