+ Responder ao Tópico



  1. #1
    thiagog
    ola pessoal como faco para atualizar uma versao do glibc*** do red hat 7.2 ?
    estou precisando atualizar para instalar o PROFTPD- ultima versao

    ---------------------- ERRO------------------------------------
    [root@poodle tmp]# ls
    glibc-2.3.1-6.i386.rpm glibc-common-2.3.1-6.i386.rpm logpacotes.txt proftpd-1.2.6-fr2.i386.rpm x86-compat-libs-7.2-1.i386.rpm
    [root@poodle tmp]# rpm -uvh glibc-2.3.1-6.i386.rpm
    -uvh: unknown option
    [root@poodle tmp]# rpm -Uvh glibc-2.3.1-6.i386.rpm
    error: failed dependencies:
    glibc-common = 2.3.1-6 is needed by glibc-2.3.1-6
    glibc > 2.2.4 conflicts with glibc-common-2.2.4-13
    glibc = 2.2.4 is needed by glibc-devel-2.2.4-13
    [root@poodle tmp]# rpm -Uvh glibc-common-2.3.1-6.i386.rpm
    error: failed dependencies:
    rpmlib(PartialHardlinkSets) <= 4.0.4-1 is needed by glibc-common-2.3.1-6
    glibc < 2.3.1 conflicts with glibc-common-2.3.1-6
    glibc-common = 2.2.4-13 is needed by glibc-2.2.4-13
    [root@poodle tmp]#

    --------------------------------------------------------------------------------

    att.

    thiagog
    noivo@ucb.br

  2. #2
    Futuremax
    Tenta isso:

    rpm -Uvh *glib*

    Ele checará as dependencias e se todos forem *glib* ele vai instalar, se não der certo ele vai pedir outro pacote, é só instalar esse outro e pronto....

    Falow?? <IMG SRC="images/forum/icons/icon_wink.gif">



  3. #3
    Celio
    Eu sempre uso o APT para atualizar e checkar por atualizações das libs e outros, o bom é que ele checa e resolve dependencias, se precisar de algo mais ele baixa e instala tb pra vc, fala quanto vai precisar de downloadear e etc. <IMG SRC="images/forum/icons/icon_wink.gif">

    http://apt-rpm.tuxfamily.org/ APT no RED HAT
    http://lists.freshrpms.net/pipermail...ry/000363.html Sources para o 7.2.

    apt-get update
    apt-get install glibc

    E depois é só olhar os rpms serem instalados/atualizados sozinhos <IMG SRC="images/forum/icons/icon_wink.gif">






Tópicos Similares

  1. Erro rodando Tibia versao linux
    Por Eduab no fórum Sistemas Operacionais
    Respostas: 0
    Último Post: 04-04-2009, 18:55
  2. Erro no squid após atualização para versão 2.6
    Por lfernandosg no fórum Servidores de Rede
    Respostas: 4
    Último Post: 06-09-2007, 13:38
  3. Cometi um erro atualizando o kernell
    Por alexandresamorim no fórum Servidores de Rede
    Respostas: 4
    Último Post: 17-08-2005, 07:32
  4. erro ao instalar GLIB - COMMON - 2.3.3-74
    Por Adolfo no fórum Sistemas Operacionais
    Respostas: 1
    Último Post: 01-07-2005, 10:41
  5. Erro ao atualizar Kernel versão 2.4.18-14 para 2.4.19
    Por lessandronp no fórum Servidores de Rede
    Respostas: 3
    Último Post: 30-06-2003, 00:37

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L