+ Responder ao Tópico



  1. #1
    Visitante

    Padrão Como configurar teclado no X

    Eae galera, eu estou com um probleminha, estou usando o Red Hat 7.1, configurei meu teclado via prompt pelo kbdconfig, mas quando inicializo o X (KDE), meu teclado nao segue a mesma configuracao (Notem a falta de cedilha e acentos, hehehe), qual sera o problema, obrigado.

  2. #2
    Mr_Mind
    Visitante

    Padrão Como configurar teclado no X

    1º: no painel d controlo do KDE podes escolher a lingua q desejas usar!!!!
    2º: precisas d ter instalado o pacote de portugues do KDE (ja deve estar)
    3º: se ainda assim nao houver acentos etc, aconselho-te a configurares o X a mao, editando o /etc/X11/XF86Config e alterando as propriedads do teclado
    <IMG SRC="images/forum/icons/icon_wink.gif">



  3. #3
    Visitante

    Padrão Como configurar teclado no X

    Vc poderia me indicar algum material para configuracao manual do X, obrigado.

  4. #4
    Kernel_Panic
    Visitante

    Padrão Como configurar teclado no X

    Ja tive um problema parecido e resolvi com o comando ( setup ) ou no proprio ( linuxconf ) ! ! !
    <IMG SRC="images/forum/icons/icon_wink.gif">



  5. #5
    Visitante

    Padrão Como configurar teclado no X

    Kernel_Panic, eu tentei configurar pelo linuxconf, na guia Xkeybordconf, mas so existe 1 layout de teclado, como eu adiciono mais layouts, ex: abnt2 ??? Obrigado.

  6. #6
    Mr_Mind
    Visitante

    Padrão Como configurar teclado no X

    edita a mao nao tem nada q saber!

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "keyboard"
    Option "XkbRules" "xfree86"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "pt"
    EndSection

    o meu exemplo ...



  7. #7
    Kernel_Panic
    Visitante

    Padrão Como configurar teclado no X

    Naum tenho certeza mais tenta instalar o pacote xkeymaps ! ! ! ok ! ! !

  8. #8
    Visitante

    Padrão Como configurar teclado no X

    Mr_Mind, eu editei o arquivo do jeito que vc aconselhou, e deu tudo certo, menos uma coisa, a tecla back spacce não está funcionando, vc sabe como arrumar???? a tecla back space funciona identica a tecla delete. Obrigado..



  9. #9
    Mr_Mind
    Visitante

    Padrão Como configurar teclado no X

    isso acontece onde? numa consola aberta certo? ai teras d configurar essa consola.
    ou entao procura no man do xf86config um map diferente d pt para brasileiro. tipo ... br ou pt_BR e altera na tua conf do X

  10. #10
    Administrador Avatar de Fernando
    Ingresso
    Jul 2001
    Localização
    Campinas Area
    Posts
    4.996
    Posts de Blog
    4

    Padrão Como configurar teclado no X

    Pro BackSpace funcionar voce deve fazer o seguinte:

    Edite (crie) o arquivo: ~/.Xmodmap e acrescente a linha:

    keycode 22 = BackSpace

    Feito isso, salve o arquivo e edite o ~/.xinitrc (se nao existir, crie) e adicione a linha:

    xmodmap .Xmodmap

    Entre e saia do KDE e veja se funciona.


    []&acute;s
    Fernando