+ Responder ao Tópico



  1. #1

    Padrão smb.conf help!!!!

    Ola , estou realmente injuriado!


    pois tenho exatamente essa configuracao rodando em outro servidor!
    so que nesse nao funfa!
    pq?
    meu /home/hosts/hosts.samba esta perfeito!
    meu /etc/hosts tambem esta perfeito!

    agora pergunto?
    pq isso nao funciona???

    ele me da a mensagem de que o servidor nao esta configurado para transações! (esta msg aparece no ambiente de rede das estações win).

    testparm ta rolando perfeito , nao me fala de nenhum erro!

    oq pode ser isso?



    meu smb.conf segue abaixo:


    #NOTA: execute o comando "testparm" para verificar erros de sintaxe
    # neste arquivo
    #
    #======================= Global Settings ==========
    [global]

    workgroup = meuserver.com.br
    server string = Servidor Samba
    include = /home/hosts/hosts.samba
    printcap name = /etc/printcap
    load printers = no
    printing = bsd

    # Cria um arquivo de log separado de ate 50Kb para cada maquina da rede
    # log file = /var/log/samba/log.%m
    # max log size = 50k

    security = share

    # Melhora a performance do servidor
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

    # Browser Control Options:
    # set local master to no if you don´t want Samba to become a master
    # browser on your network. Otherwise the normal election rules apply
    local master = yes

    # OS Level determines the precedence of this server in master browser
    # elections. The default value should be reasonable
    os level = 68

    # Domain Master specifies Samba to be the Domain Master Browser. This
    # allows Samba to collate browse lists between subnets. Don´t use this
    # if you already have a Windows NT domain controller doing this job
    domain master = yes

    # Preferred Master causes Samba to force a local browser election on startup
    # and gives it a slightly higher chance of winning the election
    preferred master = yes

    # DNS Proxy - tells Samba whether or not to try to resolve NetBIOS names
    # via DNS nslookups. The built-in default for versions 1.9.17 is yes,
    # this has been changed in version 1.9.18 to no.
    dns proxy = no
    comment = Servidor Linux
    netbios name = Linux
    null passwords = no
    wins support = no
    dead time = 0
    debug level = 0

    #============================ Share Definitions ==============================
    #[homes]
    # comment = Home Directories
    # browseable = no
    # writable = yes
    # public = no
    # only user = yes
    # available = yes
    # user =
    # valid users =
    # max connections = 1
    # valid users = yes

    # printer!
    #[printers]
    # comment = All Printers
    # path = \\maquina-29\hp
    # browseable = yes
    # public = yes

    # Set public = yes to allow user ´guest account´ to print
    # guest ok = yes
    # writable = yes
    # printable = yes

    # This one is useful for people to share files

    [Public]
    comment = Diretorio publico
    path = /
    force create mode = 0777
    force directory mode = 0777
    public = yes
    browseable = yes
    available = yes
    guest ok = yes
    writable = yes

    [cd-rom]
    comment = CD-Rom do Servidor
    path = /mnt/cdrom
    read only = yes
    browseable = yes
    only user = no
    guest only = no
    writable = no
    available = yes
    public = yes

    <IMG SRC="images/forum/icons/icon_frown.gif"> <IMG SRC="images/forum/icons/icon_frown.gif">


    []os

    MAJOR

  2. #2
    Moderador Avatar de Bruno
    Ingresso
    Nov 2002
    Localização
    Guarapuava-PR
    Posts
    3.925
    Posts de Blog
    1

    Padrão smb.conf help!!!!

    cara a configuracao é esta mesma
    vc ta tentando rodar o smb como root



  3. #3

    Padrão smb.conf help!!!!

    Pô benatto......


    hauhahuahuhuhu

    lor Manowww hehehehe

    to sim !!!!

    HELLLLLLLPPPPPPPPPP!!!!!!


    []os


    MAJOR


    <IMG SRC="images/forum/icons/icon27.gif"> <IMG SRC="images/forum/icons/icon27.gif"> <IMG SRC="images/forum/icons/icon27.gif"> <IMG SRC="images/forum/icons/icon27.gif"> <IMG SRC="images/forum/icons/icon27.gif">

  4. #4
    Administrador Avatar de Fernando
    Ingresso
    Jul 2001
    Localização
    Campinas Area
    Posts
    4.996
    Posts de Blog
    4

    Padrão smb.conf help!!!!

    Tente adicionar a seguinte linha nos shares:

    valid users = usuario1, usuario2, usuario3

    Onde cada usuario eh o que esta no cliente windows.

    []&acute;s
    Fernando



  5. #5

    Padrão smb.conf help!!!!

    certo Psy , + isso ja nao é feito pelo meu hosts.samba ???!!!!
    <IMG SRC="images/forum/icons/icon_confused.gif">

    o problema e que esse smb.conf funciona , + nao esta funcionando nessa maquina que acabei de reinstalar , apenas apliquei meu backup.

    Não estou entendendo pq não funciona!

    + Valeww psy!

  6. #6

    Padrão smb.conf help!!!!

    tenho testado varias configuraçãoes de rede , quando crio um outro dominio no smb.conf tipo teste.com.br

    ele me retorna a seguinte msg no ambiente de rede do win:

    teste.com.br não esta acessive.


    O computador ou compartilhamento não pode ser localizado. Certifique-se de que tenha sido digitado corretamente e tente novamente.


    ainda nao consegui resolver meu problema... =[

    Pô , não sei + oq fazer...


    MAJOR
    <IMG SRC="images/forum/icons/icon27.gif"> <IMG SRC="images/forum/icons/icon27.gif"> <IMG SRC="images/forum/icons/icon27.gif"> <IMG SRC="images/forum/icons/icon27.gif">



  7. #7
    wellington
    Visitante

    Padrão smb.conf help!!!!

    Se adcionar isso funciona?
    [global]
    workgroup = LINUX
    netbios name = REDHAT_8.0
    server string = WTU
    interfaces = 192.168.0.3/255.255.255.0

    workgroup = Seu grupo de trabalho
    server string = seu apelido
    interfaces = O IP da interface que o samba vai estar escutando.

    [ Esta mensagem foi editada por: wellington em 03-12-2002 12:30 ]

  8. #8

    Padrão smb.conf help!!!!

    quando coloco o smb.conf no memo dominio das estações win , não tenho resposta do anbiente de rede , tipo so me aparece aquele icone do Toda rede....

    nao tenho certeza dq pode estar causando isso.....

    to precisando de um super help aqui!



    MAJOR
    <IMG SRC="images/forum/icons/icon_confused.gif">



  9. #9

    Padrão smb.conf help!!!!

    vc tem qtas maquinas rodando o samba? se tiver mais de uma pode dar conflito... ai eh necessario mudar a configuração

  10. #10

    Padrão smb.conf help!!!!

    Valeww wellington , testei aqui + nao deu certo nao manowww.... <IMG SRC="images/forum/icons/icon_frown.gif">




    1c3 ,to utilizando apenas 1 maquina com smb...

    []os


    MAJOR






  11. #11

  12. #12

    Padrão smb.conf help!!!!

    ok, entaum explica melhor
    vc está usando Wuwindows pra acessar compartilhamentos do samba eh isso?
    Em q momento ele te da a msg de erro?



  13. #13
    wellington
    Visitante

    Padrão smb.conf help!!!!

    Vc definiu no cliente o GATEWAY, DNS, WORKGROUP ????

  14. #14
    Mandrake
    Visitante

    Padrão smb.conf help!!!!

    Já tentou colocar um Netbios name... para aparecer acessivel nas máquinas
    Win...???
    Verificou se o Serviço do smb está startado normalmente sem nenhum
    erro... ??
    Ou até se as configurações de rede estão normai??




  15. #15

    Padrão smb.conf help!!!!

    Então , defini tudo sim ...

    gateway ,dns ...


    oq eu quero fazer é apenas um smb que compartilhe um directorio share..

    nada + ...

    realmente como esta o meu smb.conf.

    tenho 30 clientes , e quero que eles possam acessar essa minha partição que é o public.

    o erro acontece quando coloco ele como master = yes , domain master =yes


    local master =yes


    como esta ali no smb.conf

    oq acontece na minha rede:
    some tudo!

    antes a maquina 20 enchergava a 30 ai quando rodo o smb , para tudo isso , nao tenho + como enchergar a rede!

    fico presso na minha maquina...

    e quando to master domin =no etc....

    ele me exibe a msg de erro quando tento acessar o linux , fala que o computador nao esta configurado para transações....

    afff

    sempre usei essa config e nunca me deu dor de cabeça , não estou entendendo pq ta acontecendo isso!

    []os

    MAJOR

    so perguntar que respondo!


  16. #16
    Mandrake
    Visitante

    Padrão smb.conf help!!!!

    Vc tem alguma máquina Windows rodando como PDC?
    Pq se vc tiver e colocar o Samba para ser master também..
    Eles vão viver em conflito, pois a máquina Windows não aguenta perder
    a disputa e sempre solicita uma nova... o que pode causar
    esse tipo de problema!!!



  17. #17

    Padrão smb.conf help!!!!

    negativo mandrake , nao tenho nenhuma maquina disputando poder com o linux não!!! <IMG SRC="images/forum/icons/icon_frown.gif">



    isso que vc disse eu vivenciei , com um xp e um red Hat 7.1 ...
    era ate legal ver os dois brigando!!!!! hehehehhe

    era uma coisa + ou menos assim ...

    por numero de votos o windows se elegeu o master , ai o linux falava blz.
    ai se passava um tempo , o xp esquecia... ai o Linux dava a msg..
    O linux é o master!

    e assim por diante!

    heheheheh
    eu ficava dando risada...

    + manow , não é isso que ta pegando aqui não...

    + valeu pela sugestão Mandrake!

    []os

    MAJOR

    <IMG SRC="images/forum/icons/icon27.gif"> <IMG SRC="images/forum/icons/icon27.gif"> <IMG SRC="images/forum/icons/icon27.gif"> <IMG SRC="images/forum/icons/icon27.gif"> <IMG SRC="images/forum/icons/icon27.gif"> <IMG SRC="images/forum/icons/icon27.gif">

    [ Esta mensagem foi editada por: MAJOR em 03-12-2002 14:45 ]

  18. #18

    Padrão smb.conf help!!!!

    Na sua conf ta assim:

    wins support = no

    coloque

    wins support = yes



  19. #19

    Padrão smb.conf help!!!!

    nao ...


    ainda nao é isso.... <IMG SRC="images/forum/icons/icon27.gif">


    não queria reinstalar , + acho que essa vai ser a solução..

    []os

    MAJOR

  20. #20
    wellington
    Visitante

    Padrão smb.conf help!!!!

    Teste este e veja o que acontece, modifique aonde está o wellington com as suas configurações:

    # Global parameters
    [global]
    workgroup = LINUX
    netbios name = REDHAT_8.0
    server string = WTU
    interfaces = 192.168.0.3/255.255.255.0
    encrypt passwords = Yes
    admin users = wellington
    domain logons = yes
    domain master = yes
    logon drive = H:
    os level = 99
    preferred master = yes
    security = user
    wins support = yes
    password level = 8
    username level = 8
    log file = /var/log/samba/log.%m
    max log size = 50
    socket options = TCP_NODELAY SO_SNDBUF=8192 SO_RCVBUF=8192
    domain logons = Yes
    domain master = True
    dns proxy = No
    wins support = Yes
    default service = homes
    hosts allow = 192.168.0. 127.
    [homes]
    create mode = 0600
    directory mode = 0700
    path = %H
    read only = no
    valid users = %S

    [netlogon]
    path = /home/netlogon
    # printing = cups
    # my changes
    announce as = NT Server
    announce version = 4.2
    character set = ISO8859-1
    client code page = 850
    load printers = Yes
    #my changes
    [printers]
    comment = All Printers
    path = /var/spool/samba
    guest ok = Yes
    printable = Yes
    # lpq command = /usr/bin/lpq %p

    [tom]
    comment = My Home
    path = /home/wellington
    valid users = wellington
    read only = No

    [zip]
    path = /mnt/zip100.0
    valid users = wellington
    read only = No

    [Cd-Rom]
    comment = cdrom
    path = /mnt/cdrom
    valid users = wellington