+ Responder ao Tópico



  1. #1
    Futuremax
    Visitante

    Padrão Ainda não compilou

    O problema agora esta com o apache, quando mando ele compilar para ativar o módulo do php4 ele me retorna um erro:

    Apache requires a ANSI C compiler, such as gcc

    ...

    /usr/bin/ld: cannot find -lclntsh
    collect2: ld returned 1 exit status
    make: *** [dummy] Error1

    Porém o gcc está instalado e tanto que na primeira vez ele compila e o php sozinho tb, mas só quando mando ativar o módulo php4 dá pau!!!
    Alguém sabe o que é???? <IMG SRC="images/forum/icons/icon_confused.gif">

    [ Esta mensagem foi editada por: Futuremax em 05-12-2002 09:16 ]

    [ Esta mensagem foi editada por: Futuremax em 05-12-2002 09:25 ]

  2. #2
    Kernel_Panic
    Visitante

    Padrão Ainda não compilou

    Ja que o pacote gcc está instalado, instale agora o pacote do make ! ! !



  3. #3
    Futuremax
    Visitante

    Padrão Ainda não compilou

    Tb tá instalado,
    make-3.79.1-1cl
    Socorro....... <IMG SRC="images/forum/icons/icon27.gif">

  4. #4
    Kernel_Panic
    Visitante

    Padrão Ainda não compilou

    nao sei se é o seu caso mais, ja tive um problema parecido de compilação e tive que instalar alem do gcc , make tive que instalar o pacote kgcc tbm . . . tente ai, senao for isso, nem imagino o que seja ! ! !
    <IMG SRC="images/forum/icons/icon24.gif">



  5. #5
    Futuremax
    Visitante

    Padrão Ainda não compilou

    Ok, vou tentar.... <IMG SRC="images/forum/icons/icon_eek.gif">

  6. #6

    Padrão Ainda não compilou

    provavelmente o apache num ta encontratando o executal do gcc prokura onde ele está edite o seu /etc/profile adicione ele aos PATHs existentes e tenta denovo......
    mas num se eskece de exportar o path antes de compilar denovo c naum num adianta nda



  7. #7
    Futuremax
    Visitante

    Padrão Ainda não compilou

    Qual linha altero??

  8. #8
    Futuremax
    Visitante

    Padrão Ainda não compilou

    AAAAARRRRRGGGGGGGHHHHHHH.......
    Não compila!!!!!!!!
    Já troquei o path pra /usr/bin que é onde se encontra o gcc instalei o kgcc que tb está no /usr/bin, e não funciona, SOCORRO!!!!!!
    Por favor alguém sabe de algo????? Já tentei de tudo!!!!! É pau do conectiva??? Alguém já viu isso??????? Vô pirá!!!!!! <IMG SRC="images/forum/icons/icon_razz.gif"> <IMG SRC="images/forum/icons/icon_eek.gif"> <IMG SRC="images/forum/icons/icon_confused.gif">



  9. #9

    Padrão Ainda não compilou

    huuum agora q reparei... parece q eh pau do ldconfig... naum de path
    rode somente ldconfig e caso ele de algum erro coloque ele aki, c naum depois disso restart o servico httpd

  10. #10
    Futuremax
    Visitante

    Padrão Ainda não compilou

    O ldconfig funcionou mas ainda não compila com o parametro --with-oci=/$ORACLE_HOME dá o mesmo erro ainda...
    <IMG SRC="images/forum/icons/icon_confused.gif">