+ Responder ao Tópico



  1. #1
    Visitante

    Padrão Não Compartilha

    Galera tenho um mandrake 8.1 compartilhando internet para rede local, hoje fiz uma alteração no nível de segurança e no firewall, aí perdi todo o compartilhamento.

    Editei o rc.local e adicionei a seguinte linha:
    echo 1 > /proc/sys/net/ipv4/ip_forward
    iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

    Mas não consegui refazer o compartilhamento.
    Alquém sabe o que pode ter acontecido????
    <IMG SRC="images/forum/icons/icon_eek.gif">

  2. #2

    Padrão Não Compartilha

    Limpe as regras de firewall e tente denovo!

    iptables -F
    iptables -t nat -F
    iptables -X
    iptables -X -t nat
    iptables -Z

    seu server esta pingando a internet???
    ping 200.204.0.10 ???

    tente ver se nao digitou nada errado!


    e digite

    echo 1 > /proc/sys/net/ipv4/ip_forward
    iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

    no console , e veja se ainda fica sem compartilhamento de internet!


    A nao esqueca de fazer um cadastro ai no forum!
    []os

    MAJOR


    <IMG SRC="images/forum/icons/icon_smile.gif"> <IMG SRC="images/forum/icons/icon_smile.gif">



  3. #3
    Visitante

    Padrão Não Compartilha

    Major, já executei os comandos que vc me passou mas ainda não funciona.
    Meu Server está pingando na Rede e na Internet.
    Desculpe, assim que consequir resolver este problema me cadastro no underlinux.
    Obrigado por enguanto.
    Waldir <IMG SRC="images/forum/icons/icon_mad.gif">

  4. #4
    Visitante

    Padrão Não Compartilha

    Verifique os módulos iptables com lsmod e remova todos com rmmod, depois de limpar as regras com os comandos já mesncionados pelo MAJOR e seja mais específico na hora de informar o mascarmento tipo:

    iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -o eth0 -j MASQUERADE

    onde claro deve subtituir 192.168.0.0/24 pelo endereço de sua rede e verifique se o eth0 é realmente sua interface de saída.
    <IMG SRC="images/forum/icons/icon_razz.gif">



  5. #5

    Padrão Não Compartilha

    Waldir , vc disse que fez algumas alteracoes no nivel de seguranca certo??

    vc poderia passar ele para o pessoal do forum dar uma olhada???

    talvez vc tenha digitado algo errado , sei la...

    []os

    MAJOR <IMG SRC="images/forum/icons/icon_wink.gif">

    [ Esta mensagem foi editada por: MAJOR em 10-12-2002 21:35 ]

  6. #6
    marcfee
    Visitante

    Padrão Não Compartilha

    Vc esta digitando assim

    echo 1 >/proc/sys/net/ipv4/ip_forward
    iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE

    Tenta assim
    echo "1" >/proc/sys/net/ipv4/ip_forward
    iptables -t nat -A POSTROUTING -s (sua LAN) -o ethX -j MASQUERADE

    Certifique qual é a interface correta para que vc possa aplicar essa regra



  7. #7
    Administrador Avatar de Fernando
    Ingresso
    Jul 2001
    Localização
    Campinas Area
    Posts
    4.996
    Posts de Blog
    4

    Padrão Não Compartilha

    O amigo marcfee soh se esqueceu do &acute;espaco&acute; entre o > e o /, portanto se for fazer como ele disse, nao se esqueca de por la o espaco:

    echo "1" >* */proc/sys/net/ipv4/ip_forward



  8. #8
    Administrador Avatar de Fernando
    Ingresso
    Jul 2001
    Localização
    Campinas Area
    Posts
    4.996
    Posts de Blog
    4

    Padrão Não Compartilha

    E tente sim o que ele disse, -s 192.168.0.0 (ou sua rede, no caso)



  9. #9
    Mago
    Visitante

    Padrão Não Compartilha

    Pronto galera, consegui compartilhar. Obrigado a todos pelas dicas.
    Até mais...
    <IMG SRC="images/forum/icons/icon_wink.gif">