+ Responder ao Tópico



  1. #1
    Ae lista, estou ainda com uns problemas de admin aqui (sux.. não me dou
    muito bem como admin)...
    estuo tentando configurar um dominio virtual aqui no meu trampo pra
    depois ver se eu faço a hospedagem da nossa pagina aqui e tal.
    o dominio virtual grafia.org eu até consegui fazer funcionar..
    mas o sub: pabro.grafia.org cai no mesmo lugar do grafia.org

    desculpem se minhas dúvidas são idioras.. eh q estou me batendo com o
    bind = p

    eu coloquei as seguintes entradas no namesd.conf

    --------- entradas no named.conf -----------
    zone "grafia.org" IN {
    type master;
    file "db.grafia";
    };

    zone "200.168.192.in-addr.arpa" IN {
    type master;
    file "db.192.168.200";
    };
    ---------------------------------------------



    no meu /var/named/db.grafia, tenho o seguinte:
    $TTL 43200
    @ IN SOA grafia.org. admin.grafia.org.(
    2001042901 ; serial
    3600 ; refresh
    900 ; retry
    1209600 ; expire
    43200 ; default_ttl
    )
    @ IN MX 5 grafia.org.
    @ IN NS grafia.org.
    @ IN A 192.168.200.6
    www IN A 192.168.200.6
    ns IN A 192.168.200.6
    ns1 IN A 192.168.200.5
    banido IN A 192.168.200.8
    pabro IN A 192.168.200.7
    ---------------------------------------------------------------------



    No meu db.192.168.200 tenho o seguinte:
    $TTL 43200
    @ IN SOA grafia.org. hostmaster.grafia.org.(
    2001042201 ; serial
    3600 ; refresh
    900 ; retry
    1209600 ; expire
    43200 ; default_ttl
    )
    @ IN NS ns.grafia.org.
    @ IN NS ns1.grafia.org.
    6 IN PTR www.grafia.org.
    6 IN PTR ns.grafia.org.
    5 IN PTR ns1.grafia.org.
    8 IN PTR banido.grafia.org.
    7 IN PTR pabro.grafia.org.
    ---------------------------------------------------------------------


    meu vhosts no apache está assim:

    NameVirtualHost 192.168.200.7

    <VirtualHost 192.168.200.7>
    ServerAdmin pabro@grafia.org
    ServerName pabro.grafia.org
    DocumentRoot /www/pabro
    </VirtualHost>
    ----------------------------------------------------------------------

    e por fim, tenho os alias criados na minha eth0 (192.168.200.6):

    eth0:0 192.168.200.5
    eth0:1 192.168.200.7
    eth0:2 192.168.200.8

  2. #2
    ozzymaia
    Meu, tem muita coisa errada.
    Apague esses alises, não é necessário!!!!!

    Agoora lá no named.conf, vc deve colocar o IP completo da sua placa de rede.
    E lá no Apache, o erro eu tenho certeza que é esse, quando vc cria o Virual Host, vc escreve exatamente o que vc escreveu, e para acrescentar novos dominios, é simples. Esse primeiro que vc criou será como se fosso o master, portanto quando vc for criar o outro VirtualHost, crie uma pasta dentra do www(no seu caso!!!) e no DocumentRoot, vc coloca o camiho completo, lembrando que a pagina inicial seré sempre chamada de index.htm ou .html, etc.

    Se eu te ajudei blz, caso contrário se tiver outra dúvida, pergunte novamente que estamos aqui para nos ajudarmos!!!!






Tópicos Similares

  1. Apache 2 + mod_jk + Dominios virtuais
    Por csdiedrich no fórum Servidores de Rede
    Respostas: 2
    Último Post: 29-01-2009, 14:56
  2. Apache não sobe com 2 dominios virtuais
    Por GuE no fórum Servidores de Rede
    Respostas: 5
    Último Post: 23-01-2009, 12:21
  3. dominios virtuais APACHE + BIND
    Por no fórum Servidores de Rede
    Respostas: 3
    Último Post: 12-01-2003, 20:22
  4. Domínios Virtuais
    Por ediguedes no fórum Servidores de Rede
    Respostas: 0
    Último Post: 12-09-2002, 20:43
  5. Configuração de domínios virtuais no webalizer?
    Por Ysgruvis no fórum Servidores de Rede
    Respostas: 1
    Último Post: 29-07-2002, 16:05

Visite: BR-Linux ·  VivaOLinux ·  Dicas-L