Página 1 de 2 12 ÚltimoÚltimo
+ Responder ao Tópico



  1. #1
    Perdigao
    Visitante

    Padrão URGENTE

    Amigos, desculpe o apelo ai no topico, mas estou precisando levantar o PHP no Red Hat 8.0 ele já esta instalado tudo, Mysql, PHP e tudo mais, entretanto, não consigo fazer com que o PHP levante ... a instalação é a padrão, já esta tudo certinho, com as devidas dependencias e parece que esta tudo certo, mas não consigo fazer com que a pagina que esta em php funcione... <IMG SRC="images/forum/icons/icon_frown.gif">

    No Aguardo desta ajuda de vocês,

    Perdigao <IMG SRC="images/forum/icons/icon27.gif"> <IMG SRC="images/forum/icons/icon_frown.gif">

  2. #2
    Futuremax
    Visitante

    Padrão URGENTE

    Olhe no seu httpd.conf e veja se estas linhas estão ok e descomentadas...

    LoadModule php4_module libexec/libphp4.so

    php_flag engine on

    AddType application/x-httpd-php .php

    Se der mais algum erro, posta aí....
    <IMG SRC="images/forum/icons/icon_wink.gif">



  3. #3
    Visitante

    Padrão URGENTE

    Olá Mano !!

    Vá até o fórum na opção apache e veja o tópico

    Apache 2.0.40 + PHP4 não consigo

    hasta....Junior

  4. #4
    Perdigao
    Visitante

    Padrão URGENTE

    Os modulos na versão do RH8.0 são levantados em /etc/httpd/conf.d/ ali tem o php, mysql e tudo mais... entretanto ele não levanta.. já verifiquei e nada...

    <IMG SRC="images/forum/icons/icon_frown.gif">

    No Aguardo,
    Perdigao



  5. #5

    Padrão URGENTE

    como o futeremax disse coloque no seu httpd.conf

    AddType application/x-httpd-php .php

    depois verifique se no seu php.ini a variavel ta assim:
    Engine = On


  6. #6
    Perdigao
    Visitante

    Padrão URGENTE

    Nada amigos,...
    acho que não é isso, pois da mesma maneira não carregou

    <IMG SRC="images/forum/icons/icon_frown.gif">

    acho que ta coplicado <IMG SRC="images/forum/icons/icon_frown.gif">

    Alguem pode me dar um help mais???

    Perdigao <IMG SRC="images/forum/icons/icon_confused.gif">



  7. #7
    Futuremax
    Visitante

    Padrão URGENTE

    Posta pra gente dar uma olhada esse conf.d e tb se dá algum erro qual é...

  8. #8
    Perdigao
    Visitante

    Padrão URGENTE

    Segue o arquivo php.conf que esta dentro de /etc/httpd/conf.d/php.conf

    ----------------------------INICIO---------------------------------------------------

    #
    # PHP is an HTML-embedded scripting language which attempts to make it
    # easy for developers to write dynamically generated webpages.
    #

    LoadModule php4_module modules/libphp4.so

    #
    # Cause the PHP interpreter handle files with a .php extension.
    #
    <Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
    LimitRequestBody 524288
    </Files>

    #
    # Add index.php to the list of files that will be served as directory
    # indexes.
    #
    DirectoryIndex index.php

    ---------------------------------------FIM--------------------------------------------------


    No aguardo...

    Perdigao <IMG SRC="images/forum/icons/icon_eek.gif">



  9. #9
    AndrewAmorimdaSilva
    Visitante

    Padrão URGENTE

    Perá, o arquivo não seria o php.ini???

    Não ouvi falar de php.conf ainda.

    VErifique se a opção no /etc/php.ini está:

    shortopentag = on

    Um abraço!

  10. #10
    Administrador Avatar de Fernando
    Ingresso
    Jul 2001
    Localização
    Campinas Area
    Posts
    4.996
    Posts de Blog
    4

    Padrão URGENTE

    O arquivo eh mod_php.conf



  11. #11
    Visitante

    Padrão URGENTE

    Ola Perdigao !!

    Explica para nos se voce compilou o apache ou instalou atraves dos
    RPMs?
    Para que o PHP funcione e&acute; necessario que os modulos estejam presentes.
    Quando vc inicia o apache, aparece alguma mensagem de erro ?

    tenta isso:

    no diretorio htdocs crie o arquivo teste.php

    <?php
    phpinfo()
    ?>

    digite no navegador localhost/teste.php

    O que acontece ??

    hasta....Junior

  12. #12
    Futuremax
    Visitante

    Padrão URGENTE

    Pelo que entendi no seu conf.d falta ainda umas linhas para que o php rode normalmente:

    php_flag engine on

    AddType application/x-httpd-php .php

    E conta pra gente, ele starta o httpd??? Ou tenta fazer download do arquivo.php??? Detalhe mais o erro, não sabemos de onde começar....



  13. #13

    Padrão URGENTE

    Bom o nome deste arquivo depende das distro isto sei pois eu tenho um slackware 81 e um RH7.3 com apache e php
    no RH nao tem o mod_php.conf estas configuracoes ja estao adicionadas diretamente no http.conf
    ja no slackeware existe um include para este arquivo pois é que ficam as configuracoes do php referente ao apache
    nos dois existem o php.ini
    Este é o grande problemas das distros nao esite um padrao para os mesmos softwares

    Isto foi so para tirar as dúvidas <IMG SRC="images/forum/icons/icon_wink.gif">

  14. #14
    Perdigao
    Visitante

    Padrão URGENTE

    Meus amigos, acho que estamos em desacordo, no RH 8.0 não usa mais as linhas no httpd.conf

    ele tem uma pasta a mais que é a conf.d em /etc/httpd/conf.d e dentro desta pasta estão os arquivos .conf para inicialização dos modulos, seja PHP, MYSQL dentre outros...

    é diferente, e posso dizer que não esta levantando... o principio deve ser o mesmo, entretanto não esta carregando...

    No arquivo httpd.conf tem uma linha que é a seguinte:

    #
    Include conf.d/*.conf
    #

    assim ele vai carregar todos os modulos que nesta versão estão em .conf como exemplo, o php.conf , o ssl.conf, o auth_mysql.conf e assim por diante...

    entendem???

    Tenho de fazer levantar o php... ou continuar tentando, se alguem já tiver passado por isso, ou se por acaso souberem como resolver este problema, me avisem...

    Se por ventura quizerem entrar na minha maquina (teste) para verificar a diferença é só entrar em contato comigo por SIM-ICQ 15889316

    Abraços,

    Perdigao

    <IMG SRC="images/forum/icons/icon_razz.gif">



  15. #15
    Perdigao
    Visitante

    Padrão URGENTE

    Existe o arquivo php.ini também, entretanto para levantar os modulos do php, ao invels de vc colocar o AddType etc etc no httpd.conf vc colocar no php.conf só pra ficar mais organizado eu acho...

    Quanto ao shortopentag = on já habilitei ele no php.ini, mas não mudou em nada...

    <IMG SRC="images/forum/icons/icon_biggrin.gif">

    Abraços

    Perdigao

  16. #16
    Perdigao
    Visitante

    Padrão URGENTE

    Anonimo, eu estou com o servidor de web, php, mysql e tudo mais instalado via RPM feito na instalação do Linux mesmo...


    E já usei o programa pra teste pi.php para ver as informações e se o PHP esta funionando certinho, mas só me aparece o fonte do scriptzinho mesmo...

    Não ta carregando alguma coisa do PHP... <IMG SRC="images/forum/icons/icon_frown.gif">

    Ë isso ai, ta dificil <IMG SRC="images/forum/icons/icon_frown.gif">




  17. #17
    Perdigao
    Visitante

    Padrão URGENTE

    Já Adicionei estas linhas, entretanto o "engine on" é no php.ini que seto ele como on ou off e o AddType já coloquei mas não carrega do mesmo jeito...

    Não dá erros quando dou o comando /etc/init.d/httpd restart ele não me dá erro algum, apenas não consigo abrir a pagina em php, ele só me aparece o fonte...

    Abacos,

    Perdigao
    <IMG SRC="images/forum/icons/icon_razz.gif">

  18. #18
    Neckratal
    Visitante

    Padrão URGENTE

    esta configurado no httpd.conf para ler arquivos .php?



  19. #19
    Mr_Mind
    Visitante

    Padrão URGENTE

    nem um nem outro! por base e&acute; sim o /etc/php.ini .. mas ate lh posso chamar 45345.dsfsdf ou morde_aqui_a_ver_s_deixo! eu odeio rpm&acute;s .. mas por certo o teu PHP ta a funcar .. so o teu php.ini nao ta configurado como deve! o teu httpd.conf tem d chamar o PHP como foi dito em cima!

    abraços <IMG SRC="images/forum/icons/icon_wink.gif">

  20. #20
    Visitante

    Padrão URGENTE

    Olá Perdigão !

    Quer um conselho ??!!

    Compila tudo pelo código fonte que funciona, pois estou usando o RH 8.0
    com PHP 4.3.0 e mysql 4.0.7 e está tudo redondo.

    Essas requisições de bilbiotecas do Linux são uma porcaria!!

    Há 15 dias atrás estava com RH 7.3 e KDE 3.05a rodando, instalei
    o RH 8.0 e quando vou compilar o Kpackage pede libdb.a. O mais
    impressionante é que está instalada, mas mesmo assim não pega.
    Baixei o fonte e compilei a Berkely DB II e mesmo assim continua
    pedindo a maldita biblioteca.

    outra coisinha.....o linux também trava!!!. Com o squid funcionando
    entre no KDE e apague o cache. Não teste numa máquina com
    programas importantes, pois tive que reinstalar. Usuário novato...
    essas coisas acontecem!!!!

    hasta....Junior